OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Controlling Mplayer?, it plays things but I can't control it!
JohnX
post Nov 21 2005, 09:06 PM
Post #1





Group: Members
Posts: 126
Joined: 4-May 05
From: Lynnwood, WA, US
Member No.: 7,070



OK, so I setup a bitbake build environment, I compiled mplayer-atty 1.1.5 for openzaurus. I installed bvdd (manually installed files from the ipk) from atty.skr.jp. With this stuff together I can watch video fairly smoothly on OpenZaurus, both GPE and Opie! Now GPE has come a long way, but I prefer Opie for day to day PDA stuff (notes, appointments, etc), so that's what I'm running right now. Under GPE, if I run mplayer from rxvt, I can use the keyboard to control it just like in Linux! left and right arrows to go 10 seconds backwards or forwards. up and down for a minute forwards or backwards. The OSD works and everything is swell. If I launch it from a script/icon I can't control it, which is no big deal, cause I can just have a script call an rxvt which can call mplayer. laugh.gif Under Opie however, once I run mplayer it takes over control of my Zaurus and I cannot do anything until the video is over or I ssh in and kill mplayer. Has anyone had any luck getting kino2 or zplayer or anything to properly control mplayer on OpenZaurus. I think one of the factors that's against me is that I want to use -vo bvdd for hardware video scaling. I seem to remember it working as long as I was using -vo sdl, but that was a while ago. I'll test some things and edit this later.

-John X
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 14th July 2014 - 01:33 AM