OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Linux Kernel 2.6.14 Breaks Usbnet Xfer From Zaurus
post Nov 29 2005, 08:40 AM
Post #1

Group: Members
Posts: 233
Joined: 2-December 03
From: Boston, MA
Member No.: 1,029


I recently discovered that Linux Kernel 2.6.14 breaks usbnet transfers from the Zaurus.

Specifically, I was using 2.6.14-1 from the Fedora Core 4 update server with a C860.

The first problem I noticed was that my connection hung when trying to enter a certain directory using samba (while browsing from my PC). Some directories worked fine and some hung.

I next noticed that certain file transfers would hang, regardless of the protocol (I tried scp, ftp, and samba). Some files transferred just fine, others hung.

I eventually determined that any file with a size >= 1458 bytes would hang. Any file with a size smaller than this transferred just fine.

Additionally, I'm assuming that the directory browsing issue is related to the number of entries in the directory and, therefore, the size of the directory contents transfer.

When I rebooted into kernel 2.6.12, everything worked fine again.

I later determined that kernel 2.6.13 is also fine.

I tried google'ing some kernel activity to try and find the cause and found some interesting stuff but nothing conclusive. I noticed that the kernel guys are still mucking around with usbnet: they've been engaged in a massive refactoring of that module since at least 2.6.11 (which I earlier discovered completely broke connectivity with the C860). I noticed one comment regarding the implementation of some sort of "hard mtu" feature which sounded somewhat suspicious to me. I haven't researched this any further though so it may be a red herring.

The latest stable kernel release is 2.6.14-3 (Fedora's latest is 2.6.14-1) so it's possible it's been fixed in -2 or -3 but I haven't been able to try them and I haven't seen any patch that addresses this issue (but I haven't looked really well yet either). The ChangeLogs for -2 and -3 don't mention anything that sounds related.

So, if you're a Linux & Zaurus user, I would recommend that you avoid 2.6.14 and try later versions with caution.

Go to the top of the page
+Quote Post
Start new topic
post Feb 20 2006, 02:08 PM
Post #2

Group: Members
Posts: 233
Joined: 2-December 03
From: Boston, MA
Member No.: 1,029

FYI: The above solution also seems to work if applied on the PC-side. Apparently, the fix works so long as you apply the MTU=576 to either side of the connection.

Those of us running Fedora/Red Hat or distros derived from them probably have a /etc/sysconfig/network-scripts/ifcfg-usb0 script to set-up the Z's usbnet connection. I added MTU=576 to mine (after disabling my edits, described above, from the Z) and transfers don't hang.

This strikes me as a "better" solution. IMO, the problem lies in Linux 2.6.14+ (and sounds like a bug to me) and so the fix should reside there as well.

Go to the top of the page
+Quote Post

Posts in this topic
raybert   Linux Kernel 2.6.14 Breaks Usbnet Xfer From Zaurus   Nov 29 2005, 08:40 AM
Stubear   I've been using 2.6.14 on Gentoo for about 2 w...   Nov 29 2005, 06:57 PM
raybert   QUOTE(Stubear @ Nov 29 2005, 09:57 PM)I'v...   Nov 30 2005, 08:06 AM
rmrfchik   QUOTE(raybert @ Nov 29 2005, 07:40 PM)Howdy, ...   Nov 30 2005, 04:36 AM
7_feet_up   The problem lies in the usbnet module. Since kerne...   Nov 30 2005, 01:45 PM
rmrfchik   QUOTE(7_feet_up @ Dec 1 2005, 12:45 AM)The pr...   Dec 1 2005, 04:15 AM
7_feet_up   QUOTE(rmrfchik @ Dec 1 2005, 01:15 PM)QUOTE(7...   Dec 1 2005, 09:27 AM
raybert   QUOTE(7_feet_up @ Nov 30 2005, 04:45 PM)The p...   Dec 1 2005, 07:19 AM
richb01906   QUOTE(7_feet_up @ Nov 30 2005, 04:45 PM)The p...   Dec 19 2005, 12:31 PM
Hrw   You have to select one option more to get usbnet w...   Dec 1 2005, 03:11 AM
raybert   QUOTE(Hrw @ Dec 1 2005, 06:11 AM)You have to ...   Dec 1 2005, 08:51 AM
raybert   As promised, these are the config options in FC4, ...   Dec 2 2005, 01:25 PM
anunakin   QUOTE(richb01906 @ Dec 19 2005, 08:31 PM)QUOT...   Jan 9 2006, 04:29 AM
raybert   Hi, Has anyone managed to find a solution to this...   Feb 19 2006, 09:02 AM
pgas   try this: On the Z: # ifconfig usbd0 mtu 576 (fr...   Feb 19 2006, 09:08 AM
raybert   pgas, Thanks for the pointer; I missed those thre...   Feb 20 2006, 12:10 PM
raybert   FYI: The above solution also seems to work if appl...   Feb 20 2006, 02:08 PM
hvontres   QUOTE(raybert @ Feb 20 2006, 03:08 PM)FYI: Th...   Mar 29 2006, 08:56 AM
raybert   QUOTE(hvontres @ Mar 29 2006, 11:56 AM)Has an...   Mar 30 2006, 10:21 AM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 21st May 2018 - 06:48 PM