OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Copying Roms To Flash Card From Osx, Nightmare with Zaurus SL-5500 ROMs/ OSX
sentinel
post Dec 2 2005, 01:15 AM
Post #1





Group: Members
Posts: 41
Joined: 23-November 05
Member No.: 8,601



Hi,

I've previously made some posts to the general 55xx forum, but suspect some of my questions are more relevant here.

I bought a Zaurus SL-5500, which displayed some strange behaviour (applications starting automatically and cycling between each other), and was advised to update the ROM to the latest Sharp Image (3.13)

However, it keeps bombing on the ROM upgrades.

Two possibilities - each the device I have is a lemon, and no amount of fiddling will ever make it work again - OR, because I am copying ROM images to a flash card from OSX (10.4.3), some minor quirk could be causing a problem.

The first thing that came to mind were the hidden files that are copied to the Flash Card (i.e. .DSSTORE, .Trashes folder), so I went into the Terminal / Midnight Commander and removed these hidden files.

Do these have the potential to cause problems (and do they get written back to the card anyway when I eject it from the Desktop) ?

I just thought I'd check with others who have or may not have had problems upgrading the Zaurus via OSX.


Thanks
Neil.
Go to the top of the page
 
+Quote Post
TimW
post Dec 2 2005, 03:42 AM
Post #2





Group: Members
Posts: 288
Joined: 8-December 03
From: London, UK
Member No.: 1,065



QUOTE(sentinel @ Dec 2 2005, 09:15 AM)
Hi,

I've previously made some posts to the general 55xx forum, but suspect some of my questions are more relevant here.

I bought a Zaurus SL-5500, which displayed some strange behaviour (applications starting automatically and cycling between each other), and was advised to update the ROM to the latest Sharp Image (3.13)

However, it keeps bombing on the ROM upgrades.

Two possibilities - each the device I have is a lemon, and no amount of fiddling will ever make it work again - OR, because I am copying ROM images to a flash card from OSX (10.4.3), some minor quirk could be causing a problem.

The first thing that came to mind were the hidden files that are copied to the Flash Card (i.e. .DSSTORE, .Trashes folder), so I went into the Terminal / Midnight Commander and removed these hidden files.

Do these have the potential to cause problems (and do they get written back to the card anyway when I eject it from the Desktop) ?

I just thought I'd check with others who have or may not have had problems upgrading the Zaurus via OSX.


Thanks
Neil.
*

I've had no problems copying images from my Mac. I deleted the extra files using my Z, though. Do ls -a /mnt/cf on the Z before flashing just to make sure those extra files aren't there.

If they have been removed then its most likely that your images got corrupted in the download, I would think. Have you checked the MD5s?
Go to the top of the page
 
+Quote Post
sentinel
post Dec 2 2005, 04:58 AM
Post #3





Group: Members
Posts: 41
Joined: 23-November 05
Member No.: 8,601



I'm not sure exactly how to check the md5 checksum on a Mac.
Go to the top of the page
 
+Quote Post
koen
post Dec 2 2005, 05:05 AM
Post #4





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(sentinel @ Dec 2 2005, 12:58 PM)
I'm not sure exactly how to check the md5 checksum on a Mac.
*


just like on *bsd/gnu:
CODE
powerbook-wlan:~/temp koen$ md5sum sectest-gpe-image-h3900-20050126100549.rootfs.jffs2
48544a6572c997aaf7995e92103adf96  sectest-gpe-image-h3900-20050126100549.rootfs.jffs2
Go to the top of the page
 
+Quote Post
sentinel
post Dec 2 2005, 05:21 AM
Post #5





Group: Members
Posts: 41
Joined: 23-November 05
Member No.: 8,601



Thanks for that. I'll try it when I get home.

One thing that occured to me is because my Zaurus is totally unusable right now, I can't access a terminal on the Zaurus to remove the hidden files. But if I try and remove them via the OSX Terminal, do these hidden files get written back to CF Card when I try and unmount it ?
Go to the top of the page
 
+Quote Post
lardman
post Dec 2 2005, 07:01 AM
Post #6





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



I wouln't worry too much about extra files, it's only if they have certain filenames that they will be written (what are the filenames anyone with romburst handy?).

That said, if you do accidentally overwrite the bootloader/flashing software because you happen to have a file with the right/wrong name, that would be bad.

I flash with a couple of directories on my card usually.


Si
Go to the top of the page
 
+Quote Post
jfv
post Dec 2 2005, 07:11 AM
Post #7





Group: Members
Posts: 438
Joined: 24-June 03
Member No.: 202



I usually load ROM images on my flash card using my wife's Mac, since my linux box is an ancient beast without a usb port. I've never bothered removing hidden or non-hidden files and, in fact, sometimes if I want to try a different program on a different ROM, I put the ipk on the card, so when it's done flashing, it can be installed and tried right away. Never had any problems with that. As long as your initrd.bin and zImage are correctly named and in the card's root directory, it should work. As people above mentioned, either the files are corrupted (check the md5sums) or it's something with the Zaurus.

Felipe
Go to the top of the page
 
+Quote Post
lpetroni
post Dec 7 2005, 05:39 PM
Post #8





Group: Members
Posts: 52
Joined: 5-June 05
Member No.: 7,271



QUOTE(sentinel @ Dec 2 2005, 07:15 AM)
The first thing that came to mind were the hidden files that are copied to the Flash Card (i.e. .DSSTORE, .Trashes folder), so I went into the Terminal / Midnight Commander and removed these hidden files.
*

Neil,

I've been copying files using CFs and SDs with no problems from my G4/Panther just using a USB card reader/writer. It works bidirectionaly (Mac <-> Zaurus) with no problems and the MacOS hidden files does not cause any problems on the Z side.

To flash your Zaurus you *must* copy the ROM image files to a FAT formatted CF card. I don't know it will work in case you reformatted the card with MacOS X.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2014 - 04:17 AM