OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Copying Roms To Flash Card From Osx, Nightmare with Zaurus SL-5500 ROMs/ OSX
sentinel
post Dec 2 2005, 01:15 AM
Post #1





Group: Members
Posts: 41
Joined: 23-November 05
Member No.: 8,601



Hi,

I've previously made some posts to the general 55xx forum, but suspect some of my questions are more relevant here.

I bought a Zaurus SL-5500, which displayed some strange behaviour (applications starting automatically and cycling between each other), and was advised to update the ROM to the latest Sharp Image (3.13)

However, it keeps bombing on the ROM upgrades.

Two possibilities - each the device I have is a lemon, and no amount of fiddling will ever make it work again - OR, because I am copying ROM images to a flash card from OSX (10.4.3), some minor quirk could be causing a problem.

The first thing that came to mind were the hidden files that are copied to the Flash Card (i.e. .DSSTORE, .Trashes folder), so I went into the Terminal / Midnight Commander and removed these hidden files.

Do these have the potential to cause problems (and do they get written back to the card anyway when I eject it from the Desktop) ?

I just thought I'd check with others who have or may not have had problems upgrading the Zaurus via OSX.


Thanks
Neil.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
TimW
post Dec 2 2005, 03:42 AM
Post #2





Group: Members
Posts: 288
Joined: 8-December 03
From: London, UK
Member No.: 1,065



QUOTE(sentinel @ Dec 2 2005, 09:15 AM)
Hi,

I've previously made some posts to the general 55xx forum, but suspect some of my questions are more relevant here.

I bought a Zaurus SL-5500, which displayed some strange behaviour (applications starting automatically and cycling between each other), and was advised to update the ROM to the latest Sharp Image (3.13)

However, it keeps bombing on the ROM upgrades.

Two possibilities - each the device I have is a lemon, and no amount of fiddling will ever make it work again - OR, because I am copying ROM images to a flash card from OSX (10.4.3), some minor quirk could be causing a problem.

The first thing that came to mind were the hidden files that are copied to the Flash Card (i.e. .DSSTORE, .Trashes folder), so I went into the Terminal / Midnight Commander and removed these hidden files.

Do these have the potential to cause problems (and do they get written back to the card anyway when I eject it from the Desktop) ?

I just thought I'd check with others who have or may not have had problems upgrading the Zaurus via OSX.


Thanks
Neil.
*

I've had no problems copying images from my Mac. I deleted the extra files using my Z, though. Do ls -a /mnt/cf on the Z before flashing just to make sure those extra files aren't there.

If they have been removed then its most likely that your images got corrupted in the download, I would think. Have you checked the MD5s?
Go to the top of the page
 
+Quote Post
sentinel
post Dec 2 2005, 04:58 AM
Post #3





Group: Members
Posts: 41
Joined: 23-November 05
Member No.: 8,601



I'm not sure exactly how to check the md5 checksum on a Mac.
Go to the top of the page
 
+Quote Post
koen
post Dec 2 2005, 05:05 AM
Post #4





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(sentinel @ Dec 2 2005, 12:58 PM)
I'm not sure exactly how to check the md5 checksum on a Mac.
*


just like on *bsd/gnu:
CODE
powerbook-wlan:~/temp koen$ md5sum sectest-gpe-image-h3900-20050126100549.rootfs.jffs2
48544a6572c997aaf7995e92103adf96  sectest-gpe-image-h3900-20050126100549.rootfs.jffs2
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th December 2014 - 07:49 AM