OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Compiling Sdl
merli
post Dec 29 2005, 04:00 AM
Post #1





Group: Members
Posts: 227
Joined: 27-April 05
Member No.: 7,008



Hello

I try to compile SDL on Zaurus using devimg. Everything seems to be OK except when I try to compile actual application I get foloowing messages

/home/QtPalmtop/lib/libSDL.a(SDL_audio.o): In function `SDL_RunAudio':
/home/userdata/zx/SDL-1.2.9/src/audio/SDL_audio.c:152: undefined reference to `SDL_ThreadID'
/home/QtPalmtop/lib/libSDL.a(SDL_audio.o): In function `SDL_LockAudio_Default':
/home/userdata/zx/SDL-1.2.9/src/audio/SDL_audio.c:257: undefined reference to `SDL_ThreadID'
/home/QtPalmtop/lib/libSDL.a(SDL_audio.o): In function `SDL_UnlockAudio_Default':
/home/userdata/zx/SDL-1.2.9/src/audio/SDL_audio.c:265: undefined reference to `SDL_ThreadID'
/home/QtPalmtop/lib/libSDL.a(SDL_audio.o): In function `SDL_RunAudio':
/home/userdata/zx/SDL-1.2.9/src/audio/SDL_audio.c:125: undefined reference to `DISKAUD_bootstrap'
/home/QtPalmtop/lib/libSDL.a(SDL_sysvideo.o): In function `QT_CreateDevice':
/home/userdata/zx/SDL-1.2.9/src/video/qtopia/SDL_sysvideo.cc:149: undefined reference to `QT_InitOSKeymap'
/home/userdata/zx/SDL-1.2.9/src/video/qtopia/SDL_sysvideo.cc:149: undefined reference to `QT_PumpEvents'
/home/QtPalmtop/lib/libSDL.a(SDL_events.o): In function `SDL_Lock_EventThread':
/home/userdata/zx/SDL-1.2.9/src/events/SDL_events.c:77: undefined reference to `SDL_ThreadID'
/home/QtPalmtop/lib/libSDL.a(SDL_events.o): In function `SDL_Unlock_EventThread':
/home/userdata/zx/SDL-1.2.9/src/events/SDL_events.c:87: undefined reference to `SDL_ThreadID'
/home/QtPalmtop/lib/libSDL.a(SDL_events.o): In function `SDL_GobbleEvents':
/home/userdata/zx/SDL-1.2.9/src/events/SDL_events.c:94: undefined reference to `SDL_ThreadID'
/home/QtPalmtop/lib/libSDL.a(SDL_thread.o): In function `SDL_GetErrBuf':
/home/userdata/zx/SDL-1.2.9/src/thread/SDL_thread.c:171: undefined reference to `SDL_ThreadID'
/home/QtPalmtop/lib/libSDL.a(SDL_thread.o): In function `SDL_RunThread':
/home/userdata/zx/SDL-1.2.9/src/thread/SDL_thread.c:203: undefined reference to `SDL_SYS_SetupThread'
/home/userdata/zx/SDL-1.2.9/src/thread/SDL_thread.c:207: undefined reference to `SDL_ThreadID'
/home/QtPalmtop/lib/libSDL.a(SDL_thread.o): In function `SDL_CreateThread':
/home/userdata/zx/SDL-1.2.9/src/thread/SDL_thread.c:257: undefined reference to `SDL_SYS_CreateThread'
/home/QtPalmtop/lib/libSDL.a(SDL_thread.o): In function `SDL_WaitThread':
/home/userdata/zx/SDL-1.2.9/src/thread/SDL_thread.c:277: undefined reference to `SDL_SYS_WaitThread'
/home/QtPalmtop/lib/libSDL.a(SDL_thread.o): In function `SDL_GetThreadID':
/home/userdata/zx/SDL-1.2.9/src/thread/SDL_thread.c:293: undefined reference to `SDL_ThreadID'
/home/QtPalmtop/lib/libSDL.a(SDL_thread.o): In function `SDL_KillThread':
/home/userdata/zx/SDL-1.2.9/src/thread/SDL_thread.c:301: undefined reference to `SDL_SYS_KillThread'
collect2: ld returned 1 exit status

I need libSDLmain.a, libSDL.la, libSDL.a to compile application.

Can someone point me to right direction? What am I doing wrong?
Thank you very much
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 29th September 2016 - 10:58 PM