OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> How To Start A .jar File From The Command Line?, using J2ME personal profile...
post Jan 2 2006, 12:38 AM
Post #1

Group: Members
Posts: 53
Joined: 9-December 05
Member No.: 8,688

I am diving into the Personal Profile world, aided by some docs. But I need some help, because I'm only 1 week old in Java (Personal Java even younger)

The release notes of J2ME Personal Profile for Zaurus
and http://java.sun.com/j2me/docs/pdf/PP_Programmer_Guide.pdf

In order to really understand what is inside an .ipk package containing a Java application, I want to launch the file manually using the command line.

I have installed the J2ME Personal Profile for Zaurus Version 1.0, Early Access Release (from sun web site).

In the programmer guide it is mentionned that to launch a .jar file, I should use the following command:
cvm [-Djava.class.path=classpath] className

But my file is a .jar

When running cvm from the directory where my .jar file is, I have tried:
cvm -Djava.class.path=. MyApplication.jar MyApplication

As well as
cvm -Djava.class.path=. -jar MyApplication.jar MyApplication

cvm -jar MyApplication.jar MyApplication

But none will work.

The application is the dictionary babbletower, that I've got working following Meanie's indication and a little reading on his web site (see thread https://www.oesf.org/forums/index.php?showtopic=10160)

So can I run a .jar file if I don't have .class file? It's fine on my PC with the command
java -jar MyApplication.jar MyApplication

But not with cvm. What am I missing here? Do I need to create classes to be able to run the .jar file?

Thanks for any help

Go to the top of the page
+Quote Post
Start new topic
post Sep 6 2006, 07:09 AM
Post #2

Group: Members
Posts: 5
Joined: 23-November 05
Member No.: 8,595

Hi, Bob,

I'm just fighting with Solun (120b) to get it working on my poodle.
(Sorry, I'm a real linux-novice!!)

Have tried your command line, but got only:
"java.lang.NoClassDefFoundError: JSolun/JSolun"

Any idea what's going wrong there?

I'm running Zynergy Rom and jeode 1.1.7 on my poodle...

Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 26th May 2018 - 06:19 AM