OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Blackdown Installation Details, and questions
ludo
post Jan 17 2006, 12:46 AM
Post #1





Group: Members
Posts: 53
Joined: 9-December 05
Member No.: 8,688



After I've tried jeode, and personal profile, it was time to go for the real java: the blackdown jre.

If you want to install blackdown j2re1.3.1 on your C3000, you can follow what is described on Meanie's web site:
www.users.on.net/_hluc/myZaurus/custom.html#java
What follwos comes from this site, but I have some question and that may be usefull for others. Beside any beginer will learn quite a lot by doing the installation (you work with symlinks, on the consol, ...)

- I have personally downloaded:
blackdown-jdk_1.3.1_arm.ipk

- It couldn't let me install it on a CF card, so it was installed by defult in:
/usr/local/j2re1.3.1

Until here no problem.

- Now you should make symbolic link as:

# ln -s /usr/local/j2re1.3.1/bin/java /usr/bin/java
# ln -s /usr/local/j2re1.3.1/bin/armv4l /usr/local/j2re1.3.1/bin/armv5tel
# ln -s /usr/local/j2re1.3.1/lib/armv4l /usr/local/j2re1.3.1/lib/armv5tel

Here I have a little doubt because on Meanie's site, this links should apply if you install the bz2 version, not the .ipk. Anyway, I think the above applies to blackdown-jdk_1.3.1_arm.ipk.

- Still following Meanie's instructions (the one refering to the ipk installation), I've edited the java file, but mine is located in /usr/local/j2re1.3.1/bin I couldn't find the lines to edit, so do I have anything to do in my java file?

- You need also libstdc++, no problem for this.

- I wasn't sure if I had the differnent libraries libXm.so and libXp.so, so I installed additional-ipaq-stuff.tar.gz

- Where should the various libraries be located?
I have now

in /usr/local/lib the library required:
libBrokenLocale-2.2.2.so but not linked to libBrokenLocale.so.1,
libXm.so.2.1 not linked to libXm.so.2, also libXm.so
libXp.so.6.2 not linked to libXp.so.6 , libXp.so

but also (after installing additional-ipaq-stuff.tar.gz) in
/usr/lib/lib
libBrokenLocale-2.2.2.so linked to libBrokenLocale.so.1
and in
/usr/lib/usr/X11R6/lib/
libXm.so.2 linked to libXm.so.2.1 (should it be the other way round as Meanie mentions), also libXm.so linked to libXm.so.2.1
libXp.so.6 linked to libXp.so.6.2 , libXp.so linked to libXp.so.6.2

What should the symlinks be (which one to link to which one for sure)?

Should I put everything in /usr/lib?

In my /etc/ld.so.conf file, which path should I indicate?

My original ld.so.conf contained:
/lib
/usr/lib
/home/QtPalmtop/lib

I have tried the following:
/lib
/usr/local/lib
/home/QtPalmtop/lib

Should I put there all the path to my lib path?

I then ran ldconfig, but I couldn't run my application.

I am honestly in the fog now.

Is there any thing I should do on the PATH variable? (and where to find it)

I ran my apps using
java -classpath myApps.jar MyApps

And I got a lot of error messages but the most relevent is probably:
CODE
Exception in thread "main" java.lang.UnsatisfiedLinkError: /hdd2/usr/local/j2re1.3.1/lib/armv4l/libawt.so: libXt.so.6: cannot load shared object file: No such file or directory.


I've the feeling I'm almost OK, but I need a hand to help.

Ludo
C3000 sharp rom
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd July 2014 - 04:19 PM