OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Xdm Use On 3.9 Beta
iamasmith
post Jan 27 2006, 05:08 PM
Post #1





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



After a little head scratching I have a good working setup and some good news on xdm support in 3.9.

It works fairly reliably, you *EDIT see next post*don't need to disable any ttys in /etc/ttys*/EDIT* and you can switch consoles without it hanging up but you MUST do the following once you have enabled xdm in rc.conf...

edit

/etc/X11/xdm/Xservers

and change the line saying...

:0 local /usr/X11R6/bin/X

to...

:0 local /usr/X11R6/bin/X vt01

this seems to be an ommision from the config... without the vt01 flag xdm will find the first available vt (vt02 or ttyC1), unfortunately the wsfb driver for Xorg is set to use /dev/ttyC0 and causes problems with that console if left to run on ttyC1.

Specifying vt01 on the line ensures that the X server that xdm starts runs on vt01 or ttyC0 (as configured in the xorg.conf file)... and ensures correct behaviour... since this doesn't effect ttyC1 now you can switch over to it should you want a text login by using Ctrl-Alt-F2.

Ctrl-Alt-F1 takes you back to your X session then

or of course if you don't run xdm then you can benefit from the warning NOT to run your X session on ttyC1 if you intend to switch to ttyC0 since this, like the initial xdm config will screw up the keyboard input on ttyC0.

- Andy
Go to the top of the page
 
+Quote Post
iamasmith
post Jan 27 2006, 05:30 PM
Post #2





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



update... disable ttyC0 in /etc/ttys if you are going to run xdm like this.... I found that without doing this occasionally you could switch back to X but X wouldn't get keyboard focus.

This is a tad annoying if you have enabled mach.kbdreset=1 to get around the occasional hang since the machine halts as normal but you can't hit a key to reboot once it's halted tongue.gif
Go to the top of the page
 
+Quote Post
iamasmith
post Jan 28 2006, 03:10 AM
Post #3





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



*sigh* still one last quirk to be aware of...

If you logout of your xdm session wait until xdm has spawned the login X server before switching to your text console... it seems to spawn X on ttyC1 if you don't rolleyes.gif.... I will try to 'bottom out' what's happening here.
Go to the top of the page
 
+Quote Post
iamasmith
post Jan 29 2006, 05:53 AM
Post #4





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



OK, I have to say the new Xorg 6.9 on 3.9 beta seems to be a little more stable.

The most workable config I have found is to use xdm as I have described here, with this config it properly switches back to xdm login if for some reason you do overload the X server (mouse event queues too long with lots of paging activity seem to do this). This is nice since when the X server dies ungracefully there is no switch back to text mode emulation at that vt, at least it allows for recovery by logging in again.

So, I'm getting closer to my 'holy grail' of long 'uptime' figures smile.gif

- Andy
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th July 2014 - 11:28 PM