OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Oe Build Always Fails When Patching Glibc-2.3.5, Can't get the armeb toolchain compiled..
magicyang
post Feb 11 2006, 09:12 PM
Post #1





Group: Members
Posts: 4
Joined: 3-January 06
Member No.: 8,842



Hi, I tried to use "machine=ixp4xxx", which uses the armeb toolchain. But when OE tries to build the toolchain, it always fails when patching glibc:

NOTE: package glibc-2.3.5+cvs20050627-r1: task do_patch: started
NOTE: Applying patch 'arm-audit.patch'
ERROR: function do_patchcmd failed
ERROR: log data follows (/develop/oe/build/tmp/work/glibc-2.3.5+cvs20050627-r1/temp/log.do_patchcmd.14586)
| Importing patch /develop/oe/org.openembedded.dev/packages/glibc/glibc-cvs-2.3.5/arm-audit.patch (stored as arm-audit.patch)
| Applying patch arm-audit.patch
| patching file sysdeps/generic/ldsodefs.h
| Hunk #1 succeeded at 211 (offset 8 lines).
| Hunk #2 FAILED at 294.
| Hunk #3 FAILED at 366.
| 2 out of 3 hunks FAILED -- rejects in file sysdeps/generic/ldsodefs.h
| patching file elf/tst-auditmod1.c
| Hunk #1 FAILED at 192.
| 1 out of 1 hunk FAILED -- rejects in file elf/tst-auditmod1.c
| Patch arm-audit.patch does not apply (enforce with -f)
NOTE: Task failed: /develop/oe/build/tmp/work/glibc-2.3.5+cvs20050627-r1/temp/log.do_patchcmd.14586
NOTE: package glibc-2.3.5+cvs20050627-r1: task do_patch: failed

Does anyone else use the armeb toolchain? Any suggestion? Thanks very much!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th November 2014 - 05:20 AM