OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Using Gcc Directly On The Z, Some troubles when linking...
larrycow
post Mar 4 2006, 03:52 AM
Post #1





Group: Members
Posts: 15
Joined: 9-October 05
Member No.: 8,280



I'm trying to compile some world-hailing test program on my zaurus. I installed gcc and, as far as I know, everything needed. But when I'm trying to

CODE
arm-linux-gcc hello.c  -o hello


I got an ugly

CODE
/usr/lib/gcc/arm-linux/3.4.3/../../../../arm-linux/bin/ld:/usr/lib/gcc/arm-linux/3.4.3/../../../libc.so: file format not recognized; treating as linker script
/usr/lib/gcc/arm-linux/3.4.3/../../../../arm-linux/bin/ld:/usr/lib/gcc/arm-linux/3.4.3/../../../libc.so:4: syntax error
collect2: ld returned 1 exit status


Would anyone understand this? And, better, explain me why?

Thanks alot.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Hakkikkt
post Apr 8 2006, 05:32 AM
Post #2





Group: Members
Posts: 21
Joined: 15-April 04
From: Brugg, Schweiz
Member No.: 2,858



Hoi,
I had a similar problem with libc6. You should check that you have libc6 installed.
If this is already the case, you should check that libc6.so.6 is in the path ...

Greetings, Georg
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 2nd August 2014 - 12:35 AM