OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Memory Shortage When Compiling Inside X/qt, How to let X/Qt fully use the swap space
xjqian
post Mar 8 2006, 01:45 AM
Post #1





Group: Members
Posts: 500
Joined: 17-January 04
From: St. Louis, USA
Member No.: 1,478



I tried to natively compile a GUI program in X/Qt. However, during the make process, it often popped up a window saying that memory of the workspace was too low (suggesting me to close X/Qt). Frequently X/Qt was automatically shut down due to insufficient memory. Although I did enable 256Mb swap space, it was hardly used by more than half as I monitored.


Anybody had experience with this. Is such a compiling prohibitive in nature due to Z's memory limitation?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
DoTheDog
post Jul 20 2006, 04:20 AM
Post #2





Group: Members
Posts: 92
Joined: 9-August 05
Member No.: 7,823



Hi Shiroikuma,
How do you bind it in chroot? when I do "echo $TMPDIR" it comes back blank in Pocketworkstation. I can see the card though.

DoTheDog

EDIT:
In qt I tried
"mount -o bind /mnt/card /hdd2/debroot/mnt/card"
and it still comes up blank in pocketworkstation.

Edit2:
Looks like the card is already mounted in debian. mount in qt gives:
/dev/mmcda1 on /usr/mnt.rom/card type vfat (rw,noatime)

So I tried export TMPDIR=/mnt/card/tmp in Pocketworkstation.
Now in chroot echo $TMPDIR, gives /mnt/card/tmp AND in qt I get the same, but I still get the Qt Memory status thing.

Help?
Go to the top of the page
 
+Quote Post

Posts in this topic
xjqian   Memory Shortage When Compiling Inside X/qt   Mar 8 2006, 01:45 AM
qx773   You might have to change the "/etc/fstab...   Mar 8 2006, 05:09 AM
pgas   some compilations (especially C++) requires a lot ...   Mar 8 2006, 08:10 AM
Meanie   There is a env variable you can set, maybe TMP, ca...   Mar 8 2006, 08:15 PM
xjqian   thanks for the advice. I didn't notice any RAM...   Mar 9 2006, 08:03 AM
xjqian   finally built it. but seg fault   Mar 13 2006, 10:43 PM
chyang   Originally, I would set the environment variable T...   Mar 14 2006, 12:13 AM
xjqian   Inside the chroot env CODEexport TMP=/tmp export T...   Mar 27 2006, 01:41 AM
PaulBx1   QUOTESo I believe that such warning shows up whene...   Mar 31 2006, 07:09 AM
xjqian   Do you know how to use the "nice" comman...   Apr 1 2006, 05:10 PM
Da_Blitz   It might be that the progrom has a hardcoded /tmp ...   Apr 2 2006, 04:45 AM
ShiroiKuma   I'm not sure if it's the tmpfs that gets m...   Apr 5 2006, 02:48 AM
Meanie   does export TMPDIR=/mnt/card/tmp help? i thin...   Apr 5 2006, 04:32 AM
ShiroiKuma   QUOTE(Meanie @ Apr 5 2006, 01:32 PM)does ex...   Apr 5 2006, 04:50 AM
ShiroiKuma   QUOTE(Meanie @ Apr 5 2006, 01:32 PM)does ex...   Apr 8 2006, 10:40 PM
xjqian   CODEexport TMPDIR=/mnt/card/.tmpand it no longer b...   Apr 9 2006, 03:39 AM
ShiroiKuma   That doesn't work. Just run it from the comman...   Apr 9 2006, 05:57 AM
xjqian   QUOTE(ShiroiKuma @ Apr 9 2006, 08:57 AM)That ...   Apr 9 2006, 09:48 PM
ShiroiKuma   QUOTE(xjqian @ Apr 10 2006, 06:48 AM)Nope, th...   Apr 9 2006, 10:37 PM
xjqian   I understand this is an Qtopia problem. I works fo...   Apr 10 2006, 06:11 AM
DoTheDog   Resurrecting an old post. I've been trying to ...   Jul 19 2006, 08:05 AM
ShiroiKuma   QUOTE(DoTheDog @ Jul 19 2006, 05:05 PM)In qto...   Jul 20 2006, 02:49 AM
DoTheDog   Hi Shiroikuma, How do you bind it in chroot? when ...   Jul 20 2006, 04:20 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2014 - 12:02 AM