OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

14 Pages V  < 1 2 3 4 5 > »   
Reply to this topicStart new topic
> 2gb And Up Sd Cards Supported, driver available for cxxxx
Cresho
post Mar 29 2006, 09:11 AM
Post #31





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



woops. i screwed up on the first ipk. made a new one and someone is testing it.

update...i added the new ipk. Some problems i came accross was going between modules.rom and modules. reason being is that modules.rom has the original driver while the modules carries a symlink-looks like one. so what the installer does is overwrites the symlink. the original driver stays as is in the modules.rom directory. Not sure if the file system is the same on all handhelds. But that was really my dilema.

papadon tested a few ipk's and now his sandisk 2gb works fine. he used the ipk installer.

So there you have it folks. ipk is at the start of this thread.
Go to the top of the page
 
+Quote Post
InSearchOf
post Mar 29 2006, 10:05 AM
Post #32





Group: Admin
Posts: 1,209
Joined: 20-January 06
From: York, Pennsylvania
Member No.: 8,961



I think it is time to look into selling my 1 gig and getting a 2 gig'er...

Thanks Cresho for the find and ipk...
Go to the top of the page
 
+Quote Post
Jon_J
post Mar 29 2006, 10:17 AM
Post #33





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



Why not overwrite the original file?
Here's a screenshot of my /lib/modules.rom/2.4.20/kernel/drivers/block
(original sharp driver)
C3100 here, Cacko lite 1.23

EDIT:
BTW, thank you for uploading this. smile.gif
I edited this post because I didn't want to clutter up this thread more.
EDIT2:
I noticed the symlink is the same bytesize as the original file.
Must be a hard link. (terminology correct?)
Anyway, I'll be getting a 2GB Sandisk Ultra II card at Staples today or tomorrow.

This post has been edited by Jon_J: Mar 31 2006, 06:25 PM
Attached File(s)
Attached File  SD_driver_orig.jpg ( 70.56K ) Number of downloads: 385
 
Go to the top of the page
 
+Quote Post
Jon_J
post Mar 31 2006, 09:42 AM
Post #34





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I got my 2gb card today, had to order it. Local Staples was out of them.
It's a Sandisk Ultra II 2GB SD card. It works as shown below in the console.
Install went fine, except for one thing. I forgot to take out my Picsel Browser card.
When I rebooted, I was getting continous error messages about IDE drive, or CF drive.
I pulled the battery and everything was fine after that.
So remember, when installing this new SD driver, Remove all cards first!!

CODE
$ df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                   19.0M     19.0M         0 100% /
/dev/root                19.0M     19.0M         0 100% /
/dev/ram1               108.0k     28.0k     80.0k  26% /dev
/dev/loop0               14.4M     14.4M         0 100% /usr
/dev/mtdblock3          102.0M     19.9M     82.1M  19% /home
none                     10.0M     52.0k      9.9M   1% /dev/shm
/dev/hda1                 9.5M      1.0M      8.0M  11% /hdd1
/dev/hda2                 9.5M      1.1M      7.9M  12% /hdd2
/dev/hda3                 3.8G     92.2M      3.7G   2% /hdd3
/dev/mmcda1               1.9G     64.0k      1.9G   0% /usr/mnt.rom/card  
Go to the top of the page
 
+Quote Post
albertr
post Mar 31 2006, 09:57 AM
Post #35





Group: Members
Posts: 535
Joined: 7-March 04
Member No.: 2,195



Did anyone actually test performance of the new Sharp's driver against the old Sharp's driver? It would be interesting to see how does it compare. Maybe to make it more compatible Sharp just hindicapped its performance?
-albertr
Go to the top of the page
 
+Quote Post
Cresho
post Mar 31 2006, 11:16 AM
Post #36





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



QUOTE(Jon_J @ Mar 31 2006, 09:42 AM)
I got my 2gb card today, had to order it. Local Staples was out of them.
It's a Sandisk Ultra II 2GB SD card. It works as shown below in the console.
Install went fine, except for one thing. I forgot to take out my Picsel Browser card.
When I rebooted, I was getting continous error messages about IDE drive, or CF drive.
I pulled the battery and everything was fine after that.
So remember, when installing this new SD driver, Remove all cards first!!

CODE
$ df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                   19.0M     19.0M         0 100% /
/dev/root                19.0M     19.0M         0 100% /
/dev/ram1               108.0k     28.0k     80.0k  26% /dev
/dev/loop0               14.4M     14.4M         0 100% /usr
/dev/mtdblock3          102.0M     19.9M     82.1M  19% /home
none                     10.0M     52.0k      9.9M   1% /dev/shm
/dev/hda1                 9.5M      1.0M      8.0M  11% /hdd1
/dev/hda2                 9.5M      1.1M      7.9M  12% /hdd2
/dev/hda3                 3.8G     92.2M      3.7G   2% /hdd3
/dev/mmcda1               1.9G     64.0k      1.9G   0% /usr/mnt.rom/card  

*


must be related to cacko. I did not expirience this problem since everything i did was from the cf card.

just remember not to install it from the sd card just incase. a few times i was running the sd card after deleting the driver which was making me laugh for a while. Only after a reboot, the sd card was not functioning. installing the new driver and rebooting fixed this problem.

congradulations on your new sd card.

has anybody tried the 4gb PQI sd card? only 160 at a local fry's. i was going to buy it but i was out of luck and got my 2gb patriot for 70 dollars.
Go to the top of the page
 
+Quote Post
Jon_J
post Mar 31 2006, 11:34 AM
Post #37





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I installed it from my hard drive.
/hdd3/Documents/Install_Files
Since I got my Picsel card, I always copy files that I need on my Zaurus to /hdd3
I probably won't be purchasing any new cards soon. I already have more than I need now.
Jon
Go to the top of the page
 
+Quote Post
DaemonsGR
post Mar 31 2006, 01:55 PM
Post #38





Group: Members
Posts: 237
Joined: 28-December 05
Member No.: 8,801



Any to test 4GB card?
BTW can this driver be usefull for pdaxrom devel?

thnx,
tasos
Go to the top of the page
 
+Quote Post
Cresho
post Mar 31 2006, 02:03 PM
Post #39





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



where is the location of the sd driver? size, name? kernel version?
Go to the top of the page
 
+Quote Post
daniel3000
post Mar 31 2006, 02:35 PM
Post #40





Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027



hi Cresho, Meanie,

may I ask what is the difference between that package and the one Meanie prepared s few weeks ago?

Which one is safer? More tested?

Thank you fpr providing this precious piece of software! Now I only have to find a good SD card.

daniel
Go to the top of the page
 
+Quote Post
Cresho
post Mar 31 2006, 07:09 PM
Post #41





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



QUOTE(daniel3000 @ Mar 31 2006, 02:35 PM)
hi Cresho, Meanie,

may I ask what is the difference between that package and the one Meanie prepared s few weeks ago?

Which one is safer? More tested?

Thank you fpr providing this precious piece of software! Now I only have to find a good SD card.

daniel
*


he made drivers? Where?
Go to the top of the page
 
+Quote Post
Jon_J
post Apr 1 2006, 09:47 AM
Post #42





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



QUOTE(Cresho @ Mar 31 2006, 09:09 PM)
he made drivers?  Where?
*

Here:
http://www.oesf.org/forums/index.php?showtopic=18077&hl=

"New Sd Driver In Pdaxrom Sd >1gb, This compatable with Cacko?"
Go to the top of the page
 
+Quote Post
Meanie
post Apr 2 2006, 05:34 PM
Post #43





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Cresho @ Mar 30 2006, 03:11 AM)
woops.  i screwed up on the first ipk.  made a new one and someone is testing it.

update...i added the new ipk.  Some problems i came accross was going between modules.rom and modules.  reason being is that modules.rom has the original driver while the modules carries a symlink-looks like one.  so what the installer does is overwrites the symlink.  the original driver stays as is in the modules.rom directory.  Not sure if the file system is the same on all handhelds.  But that was really my dilema.

papadon tested a few ipk's and now his sandisk 2gb works fine.  he used the ipk installer.

So there you have it folks.  ipk is at the start of this thread.
*


Cresho and anyone else interested in this,

All the C3x00/C1000 Zauri use 2.4.20 linux kernel (unless you install OZ which use 2.6.15 or BSD)
They are all the same, except some have extra updated patches (ie tetsu special kernel)
The kernel sources are available from Sharp, except for the sd module which is binary only so nobody can update the driver except Sharp.
Sashz has compiled an opensource replacement for pdaXrom which, because it is opensource. we have the source code for it. And because pdaXrom is also using 2.4.20 kernel, the modules can be compiled for Sharp ROM or even copied over.
Now with the 3200 sd module, you can remove the symlink from /lib/modules/2.4.20/kernel/drivers/block/sharp_mmcsd_m.o and replace it with the new module, or you can replace the one under /lib/modules.rom/2.4.20/kernel/block/sharp_mmcsd_m.o directly, you you will need to remount / as rw before you can do that. On a C3000, that would be preferrable, because of the limited size of the NAND, but it is also dangerous because, if the NAND gets full during the replacement, you will not be able to update nor delete files from the NAND anymore unless you reflash the kernel. Same is with /home which is an another NAND partition, but it is not as crammed full as the / partition on the other NAND partition.
Also, it would be a good idea to unmount /mnt/card first and then shut down the SD manager by running /etc/rc.d/init.d/sd stop. Once you replace the module, you can start the SD manager again /etc/rc.d/init.d/sd start and you should be able to mount your SD card again without requiring a reboot.
Go to the top of the page
 
+Quote Post
Cresho
post Apr 2 2006, 06:02 PM
Post #44





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



I am aware of those..............issues. Just installing and rebooting works fine with the sharprom. easier said and easier done.

Never tried sashz driver though.

your right about the 3000 but someone dived into it and runs fine. Cacko did have a little issue with it but re-rebooting worked as well. /etc/rc.d/init.d/sd stop and /etc/rc.d/init.d/sd start is the best bet for cacko.

So how is the pdaxrom driver working out for your 3100?
Go to the top of the page
 
+Quote Post
pgas
post Apr 2 2006, 11:53 PM
Post #45





Group: Members
Posts: 1,099
Joined: 17-December 03
From: Athens, Greece
Member No.: 1,210



sashz driver is in devel, and the one in beta2 is buggy (for instance it needs a cf card in the Z to work.
hopefully this should be fix in the upcoming 1.1.0beta3

I think 2G sd cards are not working with the driver in beta2

The good news is that he has 2.4.20 working on 7x0 so maybe we could also use the 3200 driver on these machine...
Go to the top of the page
 
+Quote Post

14 Pages V  < 1 2 3 4 5 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th July 2014 - 05:09 PM