OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> X/qt Installed, Sort Of, still have a few issues
PaulBx1
post Mar 29 2006, 12:39 AM
Post #1





Group: Members
Posts: 41
Joined: 26-February 06
Member No.: 9,234



I decided to go ahead and try a cramfs install on my C1000 even though I'm not sure of some issues. It works in some respects (I can get the xwindow running), however:

1) Cacko 1.23 seemed to have some sort of automount facility already before starting this. At least, when I took the SD card out or put it in, it automatically mounted it. I tried installing X/QT without Meanies automounter, thinking this other one might work. No. Then I tried installing automounter. Now I don't know which is working, but I still don't get the cramfs automatically mounted, my guess is automounter still is not working (if I type "automounter" it says "command not found"). I have to do the mount manually (e.g. after boot) to get it up. No swap either. <later> This appears to be a problem of definition (link?) of "automounter" because if I go to /etc/rc.d/init.d I find mntloop and if I invoke it with "status" it shows me the loop devices including xqt.

2) Not sure what the swap situation for X/Qt is supposed to be on a C1000 anyway. My sd card is 256MB...

3) I get lots of error messages on boot. First is "cramfs: wrong magic" and then "FAT: bogus logical sector size 381". Then a whole pile of complaints like:

pxa_sd_wait_id_response: responce time out (cmd=01 MMC_STAT=0x2142)

4) I neglected to do a "tee" or whatever one does to capture the output when running xqt-install.sh; is there any log lying around to look at?

5) Oh, I unzipped these packages on my windoze box, where I had downloaded them; was that a mistake? I noticed the script handled unzipping. I guess I needed to unzip the script if nothing else.

6) I noticed in one thread Cresho had a recipe for this install:
QUOTE
install--needed files or it will not work
----------------------------------------
automounter-c3000_0.4.5_arm.ipk
sudo_0.1_arm.ipk
zlib_1.2.3-1_arm.ipk
qconsole(disable magnifyby holding down with stylus and removing check)
...

http://www.oesf.org/forums/index.php?showtopic=13011&st=390
sudo is there but I don't know if zlib is, or how to tell. I'm just using the regular QKonsole that came with Cacko.

My efforts to search for answers to these on the forum were not fruitful.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 29th July 2014 - 02:55 PM