OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Usb Ethernet For C1000/cacko1.23?
vpJIqe
post Mar 31 2006, 12:54 PM
Post #1





Group: Members
Posts: 3
Joined: 31-March 06
Member No.: 9,499



Can anyone recommend a USB Ethernet adapter that works with the C1000?

Thanks
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
uth
post Mar 31 2006, 01:43 PM
Post #2





Group: Members
Posts: 106
Joined: 27-February 06
Member No.: 9,243



QUOTE(vpJIqe @ Mar 31 2006, 04:54 PM)
Can anyone recommend a USB Ethernet adapter that works with the C1000?

Thanks
*


I've tested these myself:

D-Link DUB-E100
LinkSys USB200M

They both work with Cacko, plug-n-play.

The D-Link one is a bit large though, almost as big as the Z, so it doesn't make sense to use with a portable. the LinkSys is much smaller, about the size of a thumb drive.
Go to the top of the page
 
+Quote Post
zdroyer
post Oct 17 2007, 07:59 AM
Post #3





Group: Members
Posts: 3
Joined: 17-October 07
Member No.: 20,835



Hi Folks!

QUOTE(uth @ Mar 31 2006, 11:43 PM) *
I've tested these myself:
D-Link DUB-E100
LinkSys USB200M
They both work with Cacko, plug-n-play.


Bad news (at least for me).
I've just bought a Z SL-C3200 and D-Link DUB-E100 (H/W Ver.:B1) and tried both with Cacko 1.23.
I use the usb-network-modules-2.4.20_arm.ipk provided by the original cacko feed and the eth adaptor isn't recognized.
dmesg says:

CODE

usbh: hotplug_schedule_bh: schedule bh
hotplug_schedule_bh: schedule bh
usbh: hotplug_bh:
usbh: udc_connected: ACTIVE_LOW: 1<7>usbh: monitor_connected: 1
usbh: monitor_restore: RESTORE_LOADED
usbh: monitor_hotplug: agent: usbh interface: monitor action: restore-loaded
new hp status=0
hotplug_bh:
monitor_connected: 1
monitor_restore: RESTORE_LOADED
monitor_hotplug: agent: usbd interface: monitor action: restore-loaded
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usbdcore: usbdcore 0.1 035 2002-06-12 20:00 (dbg="")
usb-ohci.c: USB OHCI at membase 0xfe000000, IRQ 3
net_fd 0.1 035 2002-06-12 20:00 (dbg="",alwaysup=0,OUT=64,IN=64)
vendorID: 4dd productID: 9031
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
pxa27x_bi 0.1-alpha 035 2002-06-12 20:00 (dbg="")
bi_modinit: call udc_startup_events
bi_device_event: call udc_enable
bi_device_event: call udc_all_interrupts
udc_connect: host cable connected.
hub.c: new USB device -2, assigned address 2
usb.c: USB device 2 (vend/prod 0x2001/0x3c05) is not claimed by any active driver.


Somewhere in the Linux forum I read, that support for the B1 HW version of the adapter was added to the asix minidriver in 2006, so I tried to find a newer version, but I didn't succeed.
Do you have any idea what can I do in order to make the adapter work with my Cacko powered Z?


Thanks in advance


Go to the top of the page
 
+Quote Post
tux
post Oct 17 2007, 09:16 AM
Post #4





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



QUOTE(zdroyer @ Oct 17 2007, 04:59 PM) *
Hi Folks!

QUOTE(uth @ Mar 31 2006, 11:43 PM) *
I've tested these myself:
D-Link DUB-E100
LinkSys USB200M
They both work with Cacko, plug-n-play.


Bad news (at least for me).
I've just bought a Z SL-C3200 and D-Link DUB-E100 (H/W Ver.:B1) and tried both with Cacko 1.23.
I use the usb-network-modules-2.4.20_arm.ipk provided by the original cacko feed and the eth adaptor isn't recognized.
dmesg says:

CODE

usbh: hotplug_schedule_bh: schedule bh
hotplug_schedule_bh: schedule bh
usbh: hotplug_bh:
usbh: udc_connected: ACTIVE_LOW: 1<7>usbh: monitor_connected: 1
usbh: monitor_restore: RESTORE_LOADED
usbh: monitor_hotplug: agent: usbh interface: monitor action: restore-loaded
new hp status=0
hotplug_bh:
monitor_connected: 1
monitor_restore: RESTORE_LOADED
monitor_hotplug: agent: usbd interface: monitor action: restore-loaded
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usbdcore: usbdcore 0.1 035 2002-06-12 20:00 (dbg="")
usb-ohci.c: USB OHCI at membase 0xfe000000, IRQ 3
net_fd 0.1 035 2002-06-12 20:00 (dbg="",alwaysup=0,OUT=64,IN=64)
vendorID: 4dd productID: 9031
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
pxa27x_bi 0.1-alpha 035 2002-06-12 20:00 (dbg="")
bi_modinit: call udc_startup_events
bi_device_event: call udc_enable
bi_device_event: call udc_all_interrupts
udc_connect: host cable connected.
hub.c: new USB device -2, assigned address 2
usb.c: USB device 2 (vend/prod 0x2001/0x3c05) is not claimed by any active driver.


Somewhere in the Linux forum I read, that support for the B1 HW version of the adapter was added to the asix minidriver in 2006, so I tried to find a newer version, but I didn't succeed.
Do you have any idea what can I do in order to make the adapter work with my Cacko powered Z?


Thanks in advance


cool.gif You don't say whether you are using the lite or full version of the Cacko 1.23? If you are using the lite you might need to install more of the usb modules, or so I've seen remarked in these forums.

If you have the full version then your best bet is to go and have a look at Meanies site. My usb lan dongle needed a module that I was able to find and use with the information from there. biggrin.gif

You'll probably find useful information by searching these forums, though it sometimes takes a lot of scratching about! smile.gif

You could try using the command depmod and/or modprobe ohci-hcd in a terminal and seeing if that does anything?

Good Luck!
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th September 2014 - 09:58 AM