OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Request Bestcrypt, Encryption
SNi
post Apr 7 2006, 02:49 AM
Post #1





Group: Members
Posts: 53
Joined: 14-June 04
From: Cincinnati, OH, USA
Member No.: 3,682



Could some compile Bestcrypt for Sharp stock ROM?? http://www.jetico.com/linux/
TIA,
SNI

SL-C3000, 4GB CF, 4GB SD
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
sidmoraes
post Apr 15 2006, 05:51 PM
Post #2





Group: Members
Posts: 116
Joined: 25-July 05
From: Brazil
Member No.: 7,691



Can you test again?

New package in first post.
Go to the top of the page
 
+Quote Post
SNi
post Apr 15 2006, 08:08 PM
Post #3





Group: Members
Posts: 53
Joined: 14-June 04
From: Cincinnati, OH, USA
Member No.: 3,682



QUOTE(sidmoraes @ Apr 15 2006, 05:51 PM)
Can you test again?

New package in first post.
*

Sidmoraes,
Thanx for your continued help.. I downloaded your update. First bcrypt loads the modules OK, then when I tried to create a new container I got a message re missing libstdc++-libc6.2-2.so.3 file. I searched, found and put into /usr/lib (symlink to libstdc++3-libc6-2.2.2.10.0.so). Again tried to create new container, and got message:

/lib/libc.so.6: version 'GLIBC_2.3' not found (required by /usr/lib/libstdc++-libc6.2.2.so.3)

I can symlink libc.so.6 to libc-2.3.6.so in /usr/lib but it seems looks to /lib where libc.so.6 is symlinked to libc-2.2.2.so and not to /usr/lib... and I can't change in /lib... You seem to have it working, any ideas?
Thanx again,
SNi
Go to the top of the page
 
+Quote Post
sidmoraes
post Apr 15 2006, 08:46 PM
Post #4





Group: Members
Posts: 116
Joined: 25-July 05
From: Brazil
Member No.: 7,691



QUOTE(SNi @ Apr 15 2006, 08:08 PM)
QUOTE(sidmoraes @ Apr 15 2006, 05:51 PM)
Can you test again?

New package in first post.
*

Sidmoraes,
Thanx for your continued help.. I downloaded your update. First bcrypt loads the modules OK, then when I tried to create a new container I got a message re missing libstdc++-libc6.2-2.so.3 file. I searched, found and put into /usr/lib (symlink to libstdc++3-libc6-2.2.2.10.0.so). Again tried to create new container, and got message:

/lib/libc.so.6: version 'GLIBC_2.3' not found (required by /usr/lib/libstdc++-libc6.2.2.so.3)

I can symlink libc.so.6 to libc-2.3.6.so in /usr/lib but it seems looks to /lib where libc.so.6 is symlinked to libc-2.2.2.so and not to /usr/lib... and I can't change in /lib... You seem to have it working, any ideas?
Thanx again,
SNi
*



Try this ipk: http://www.zaurususergroup.org/feed/libstd...95.4-16_arm.ipk
Go to the top of the page
 
+Quote Post
SNi
post Apr 16 2006, 07:37 AM
Post #5





Group: Members
Posts: 53
Joined: 14-June 04
From: Cincinnati, OH, USA
Member No.: 3,682



QUOTE(sidmoraes @ Apr 15 2006, 08:46 PM)


OK, I removed the files that I had added and then installed this ipk instead. Can load all modules then I'm back to this error message when I try to mount an existing container, create a new, or get info on an existing..

/usr/lib/libkgsha.so: undefined symbol: _divsi3
Can not Load Key Generators

sad.gif
SNi
Go to the top of the page
 
+Quote Post
sidmoraes
post Apr 16 2006, 10:07 AM
Post #6





Group: Members
Posts: 116
Joined: 25-July 05
From: Brazil
Member No.: 7,691



QUOTE(SNi @ Apr 16 2006, 07:37 AM)
QUOTE(sidmoraes @ Apr 15 2006, 08:46 PM)


OK, I removed the files that I had added and then installed this ipk instead. Can load all modules then I'm back to this error message when I try to mount an existing container, create a new, or get info on an existing..

/usr/lib/libkgsha.so: undefined symbol: _divsi3
Can not Load Key Generators

sad.gif
SNi
*



Did you get my new package? I tested in my C1K. Give to me the output of this command:
ldd /usr/lib/libkgsha.so
Go to the top of the page
 
+Quote Post
SNi
post Apr 16 2006, 01:24 PM
Post #7





Group: Members
Posts: 53
Joined: 14-June 04
From: Cincinnati, OH, USA
Member No.: 3,682



QUOTE(sidmoraes @ Apr 16 2006, 10:07 AM)
Did you get my new package? I tested in my C1K. Give to me the output of this command:
ldd /usr/lib/libkgsha.so
*


Looks like other folks have downloaded sidmoraes' package as well... Anyone else having either any success or any issues? Sidmoraes apparently has it working on his C1000 w/ Cacko, I'm having issues with a C3000 & stock ROM...

SNi
Go to the top of the page
 
+Quote Post
SNi
post Apr 16 2006, 04:48 PM
Post #8





Group: Members
Posts: 53
Joined: 14-June 04
From: Cincinnati, OH, USA
Member No.: 3,682



QUOTE(SNi @ Apr 16 2006, 01:24 PM)
Looks like other folks have downloaded sidmoraes' package as well...  Anyone else having either any success or any issues? Sidmoraes apparently has it working on his C1000 w/ Cacko, I'm having issues with a C3000 & stock ROM...
SNi
*


OK, turns out I had two different versions of libfloat.so.1 and after getting rid of one this works just fine. Use sidmoraes' package (attached to his first response) and also the ipk he linked to and Bestcrypt works perfectly on the C3000.

Now I have an encrypted container on my CF that I can access via the z and Windows desktop (I purchased the Windows version). Fantastic smile.gif thanx Sid laugh.gif

SNi
Go to the top of the page
 
+Quote Post

Posts in this topic
SNi   Request Bestcrypt   Apr 7 2006, 02:49 AM
sidmoraes   QUOTE(SNi @ Apr 7 2006, 02:49 AM)Could some c...   Apr 7 2006, 10:27 AM
SNi   QUOTE(sidmoraes @ Apr 7 2006, 10:27 AM)I bele...   Apr 8 2006, 08:06 AM
sidmoraes   QUOTE(SNi @ Apr 8 2006, 08:06 AM)QUOTE(sidmor...   Apr 8 2006, 01:37 PM
SNi   QUOTE(sidmoraes @ Apr 8 2006, 01:37 PM)Did yo...   Apr 10 2006, 03:42 PM
w14   There should be an init script which loads the mod...   Apr 10 2006, 11:47 PM
SNi   QUOTE(w14 @ Apr 10 2006, 11:47 PM)There shoul...   Apr 11 2006, 02:49 PM
SNi   QUOTE(SNi @ Apr 11 2006, 02:49 PM)QUOTE(w14 ...   Apr 15 2006, 11:41 AM
sidmoraes   Can you test again? New package in first post.   Apr 15 2006, 05:51 PM
SNi   QUOTE(sidmoraes @ Apr 15 2006, 05:51 PM)Can y...   Apr 15 2006, 08:08 PM
sidmoraes   QUOTE(SNi @ Apr 15 2006, 08:08 PM)QUOTE(sidmo...   Apr 15 2006, 08:46 PM
SNi   QUOTE(sidmoraes @ Apr 15 2006, 08:46 PM)Try t...   Apr 16 2006, 07:37 AM
sidmoraes   QUOTE(SNi @ Apr 16 2006, 07:37 AM)QUOTE(sidmo...   Apr 16 2006, 10:07 AM
SNi   QUOTE(sidmoraes @ Apr 16 2006, 10:07 AM)Did y...   Apr 16 2006, 01:20 PM
SNi   QUOTE(sidmoraes @ Apr 16 2006, 10:07 AM)Did y...   Apr 16 2006, 01:24 PM
SNi   QUOTE(SNi @ Apr 16 2006, 01:24 PM)Looks like ...   Apr 16 2006, 04:48 PM
daniel3000   Hello, now I'm also trying to set up BestCryp...   Jun 10 2006, 12:26 PM
Drake01   QUOTE(SNi @ Apr 16 2006, 07:48 PM)OK, turns o...   Sep 13 2006, 06:12 PM
w14   This happens with the version I compiled for pdaXr...   Jun 10 2006, 12:42 PM
SNi   QUOTE(w14 @ Jun 10 2006, 12:42 PM)This happen...   Jun 16 2006, 01:17 AM
expsion   I tried Bestcrypt as compiled by sidmoraes, but th...   Jul 3 2006, 04:54 AM
bam   I tried Sid's package, and it works brilliantl...   Sep 9 2006, 07:10 PM
telemetric_au   hi, im getting this error now with custom build im...   Jul 5 2007, 11:41 PM
qwer_asdf7   Hopefully this message gets someone's attentio...   Aug 13 2008, 10:00 PM


Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2014 - 12:39 PM