OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Qtopia4 Core, anyone testing?
speculatrix
post Apr 19 2006, 10:03 AM
Post #1





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



I've build qt/e 4 aka qtopia-4-core, and am trying it out. It's pretty huge - had to install on sdcard and cross-link.

I've managed to get most of the demos to work, some don't build/link, either due to missing symbols or maybe because I'm using gcc2.95.3

The programs which build are:

books composition deform interview mainwindow pathstroke spreadsheet sqlbrowser textedit

Some won't run due to needing the SQL drivers. Loading speed is q slow, running speed OK-ish.

Still got a few things to fix though before programs will normally from qtopia1.5 desktop on Z!!!
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
speculatrix
post Apr 20 2006, 03:32 AM
Post #2





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



oh yeah, here's the command I ran after I unpacked the tar.gz:

./configure -embedded arm -xplatform qws/linux-arm-g++ -big-endian --prefix=/home/zaurus/QT4

this is on suse10.0 machine

PATH:
/usr/local/Trolltech/Qt-4.1.2/bin:/home/zaurus/Embedix/tools/bin:/home/zaurus/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin:/opt/kde3/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin

(where the first part of the path was an already built qt-4-x11 install so I could use the binaries; there's a softlink from /home/zaurus/Embedix in /opt)
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 10:04 AM