OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Flickr Viewer For The Zaurus, in Python and PyQT
post Apr 19 2006, 11:25 AM
Post #1

Group: Members
Posts: 668
Joined: 3-December 03
From: US
Member No.: 1,034

Just to increase the score for python and Python apps for the Zaurus...

Here's a little app I designed as a Flickr Viewer for the Zaurus.
Its still a work in progress, so be patient with features.

Allows to view photo groups, photos for any users.
Able to view by Flickr NSID or by Username.
I haven't implemented the Flickr Authentication API method yet (since that requires a browser login, and I wanted a self-contained app).

Also able to view photos by "Interestingness" in Flickr.
Able to store photos to local disk for offline viewing (no photo titles or tags in offline mode). Can delete local photos to clear up memory space.

Future Plans
Plan to implement searching by photo Tags, most Popular Tags.
Search by email ID etc later on. Ability to change settings etc.
Also implement Authenication so as to allow read/write access to user Flickr account.
That would include upload photos to Flickr from Zaurus.

Python (tested with Kopsis Python) on the Zaurus.

The link
Attached thumbnail(s)
Attached Image
Attached Image
Attached Image
Go to the top of the page
+Quote Post
Start new topic
post Sep 14 2006, 04:37 PM
Post #2

Group: Members
Posts: 1,853
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821

I have a C3100 with Cacko 1.23 lite
I have no programming experiance at all, and spent the entire day reading this python subforum.
I thoroughly enjoyed reading most all the posts. smile.gif
I have installed kopsis python24 image and executable, as instructed on website where I downloaded it.
I then installed flickrz_0.2_arm.ipk.
It gives me this error message in the package installer in Cacko:
The extract of some files are failed.
The application may not execute normally.
When you cannot operate the application,
please remove it.

I have downloaded it 3 times,
(once with my browser, and twice with a download manager)
I still get the same errors upon install.

However, the application launches and seems to work.
I'm not sure what to input as a username or NSID
I tried "zaurus" and (no username). Login didn't work.
How do I login? Is login necessory to browse the filesystem for pics?
I have also tried "Execute with root privilage" in the "tap & hold" dialog.
How do I browse the filesystem to view my picture files?
If I click "View local pics", all I can view is the included sample picture.

Thank you,
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 25th May 2018 - 02:53 AM