OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Pdaxqtrom & Apps, Started new thread
Jon_J
post Apr 26 2006, 10:24 AM
Post #1





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I hope nobody minds me starting a dedicated thread for pdaXqtrom.
I thought it would be easier to search.

Meanie has posted information about pdaXqtrom here:
http://www.oesf.org/forums/index.php?showtopic=16209
and here:
http://www.oesf.org/forums/index.php?showtopic=18789

BTW, Thank you Meanie for such a comprehensive package. smile.gif

I'm not an experienced Linux user, so many of the applications in the apps package are foreign to me.
I'm using the cramfs versions.
I installed pdaXqtrom 1.1.0 - beta 0.7.5 first all by itself.
Then later decided to install pdaXqtApps - beta 0.7.5
I have this installed to a 128MB Lexar SD card formatted as ext2
I haven't installed zgcc2-95-2
I have a couple questions, and observations to list.
I use Cacko Lite 1.23 on my C3100
I enabled a 128MB swapfile in Cacko.

Do I need the automounter? I assumed it is already installed by Cacko.
I have 2 mount points shown in console for the two packages that I installed.
CODE
$ df -h
Filesystem         Size      Used Available Use% Mounted on
rootfs            19.0M     19.0M         0 100% /
/dev/root         19.0M     19.0M         0 100% /
/dev/ram1        108.0k     28.0k     80.0k  26% /dev
/dev/loop0        14.4M     14.4M         0 100% /usr
/dev/mtdblock3   102.0M     28.8M     73.2M  28% /home
none              10.0M     72.0k      9.9M   1% /dev/shm
/dev/hda1          9.5M      1.0M      8.0M  11% /hdd1
/dev/hda2          9.5M      1.1M      7.9M  12% /hdd2
/dev/hda3          3.8G     22.9M      3.8G   1% /hdd3
/dev/mmcda1      117.4M     85.0M     26.3M  76% /usr/mnt.rom/card
/dev/loop1        81.1M     81.1M         0 100% /home/system/var/mnt/pdaXqtrom-base
/dev/loop2       121.0M    121.0M         0 100% /home/system/var/mnt/pdaXqtrom-apps

Has the libfloat problem mentioned here been addressed?
http://www.oesf.org/forums/index.php?showt...ndpost&p=124465

I tried to launch Abiword from the X/Qt tab in Qtopia and it only launches X/Qt, but not Abiword.
So far, I've been able to launch Dillo and GQview.
(I can launch these from X/Qt and from Qtopia)
GQview doesn't seem to be able to "see" my picture files in any of my directories on my FAT formatted /hdd3.
Is the problem with GQview related to my FAT formatted drive? It shows the directory structure, but no files.
I haven't tried any other applications yet, but will add more to this post later.
Below is the output from console during the install process.
pdaXqtrom-base was already installed. This is from when I installed pdaXqtrom-apps.
CODE
# ./pdaXqtrom-install.sh
X/Qt super jumbo installer - version 0.3.6.1
automounter is not installed.
it is recommended to install automounter or something similar
The system has 8 loop devices.
There are 2 cramfs/squashfs images.
...purging /etc/X11
...checking for pdaXqtrom-base
...installing pdaXqtrom-base to /usr/mnt.rom/card/xqt
pdaXqtrom 1.1.0 - beta 0.7.5
Installing pdaXqtrom-base on borzoi...
...updating package info
...copying desktop config files to /opt/QtPalmtop/apps/XQt
...copying icons files to /opt/QtPalmtop/pics144
...linking files to /opt/QtPalmtop/help/html
...linking files to /opt/QtPalmtop/share/locale/ja/LC_MESSAGES
...linking files to /opt/QtPalmtop/share/themes
...linking files to /opt/QtPalmtop/share
...linking files to /opt/QtPalmtop/etc
...linking files to /opt/QtPalmtop/bin
...linking files to /opt/QtPalmtop/lib/X11
...linking files to /opt/QtPalmtop/lib/gconv
...linking files to /opt/QtPalmtop/lib/glib-2.0
...linking files to /opt/QtPalmtop/lib/gtk-2.0
...linking files to /opt/QtPalmtop/lib/locale
...linking files to /opt/QtPalmtop/lib/pango
...linking files to /opt/QtPalmtop/lib
...linking files to /usr/bin
...linking files to /usr/lib
...linking files to /usr/share
...linking files to /usr/local/bin
...linking files to /usr/local/lib
...linking files to /usr/local/share
...copying config files to /etc/X11
...copying app-defaults to /etc/X11/app-defaults
...copying defaultwm to /etc/X11/defaultwm
...copying kb to /etc/X11/kb
...copying proxymngr to /etc/X11/proxymngr
...copying rstart to /etc/X11/rstart
...copying twm to /etc/X11/twm
...copying xdm to /etc/X11/xdm
...copying xinit to /etc/X11/xinit
...copying xserver to /etc/X11/xserver
...copying xsm to /etc/X11/xsm
...copying config files to /etc/bonobo-activation
...copying config files to /etc/fonts
...copying config files to /etc/gconf
...copying config files to /etc/gnome-vfs-2.0
...copying config files to /etc/gtk-2.0
...copying config files to /etc/imlib
...copying config files to /etc/pango
...copying config files to /etc/sound
...linking X server and config
...copying xmodmaprc to /etc/X11/kb
...copying user config files to /home/zaurus
...loading libraries
...generating config files
pdaXqtrom-base configured.
...checking for pdaXqtrom-apps
...installing pdaXqtrom-apps to /usr/mnt.rom/card/xqt
pdaXqtApps - beta 0.7.5
Installing pdaXqtApps on borzoi...
...updating package info
...copying desktop config files to /opt/QtPalmtop/apps/XQt
...copying abiword.desktop to /opt/QtPalmtop/apps/XQt/abiword.desktop
...copying axyftp.desktop to /opt/QtPalmtop/apps/XQt/axyftp.desktop
...copying bluefish.desktop to /opt/QtPalmtop/apps/XQt/bluefish.desktop
...copying dia.desktop to /opt/QtPalmtop/apps/XQt/dia.desktop
...copying dillo.desktop to /opt/QtPalmtop/apps/XQt/dillo.desktop
...copying firefox.desktop to /opt/QtPalmtop/apps/XQt/firefox.desktop
...copying galculator.desktop to /opt/QtPalmtop/apps/XQt/galculator.desktop...copying gimp.desktop to

/opt/QtPalmtop/apps/XQt/gimp.desktop
...copying gnumeric.desktop to /opt/QtPalmtop/apps/XQt/gnumeric.desktop
...copying gqview.desktop to /opt/QtPalmtop/apps/XQt/gqview.desktop
...copying nedit.desktop to /opt/QtPalmtop/apps/XQt/nedit.desktop
...copying scite.desktop to /opt/QtPalmtop/apps/XQt/scite.desktop
...copying stardict.desktop to /opt/QtPalmtop/apps/XQt/stardict.desktop
...copying sylpheed.desktop to /opt/QtPalmtop/apps/XQt/sylpheed.desktop
...copying thunderbird.desktop to /opt/QtPalmtop/apps/XQt/thunderbird.desktop
...copying xarchiver.desktop to /opt/QtPalmtop/apps/XQt/xarchiver.desktop
...copying xchat.desktop to /opt/QtPalmtop/apps/XQt/xchat.desktop
...copying xmms.desktop to /opt/QtPalmtop/apps/XQt/xmms.desktop
...copying xpdf.desktop to /opt/QtPalmtop/apps/XQt/xpdf.desktop
...copying icons files to /opt/QtPalmtop/pics144
...copying abiword.png to /opt/QtPalmtop/pics144/abiword.png
...copying axyftp.png to /opt/QtPalmtop/pics144/axyftp.png
...copying bluefish.png to /opt/QtPalmtop/pics144/bluefish.png
...copying bochs.png to /opt/QtPalmtop/pics144/bochs.png
...copying dia.png to /opt/QtPalmtop/pics144/dia.png
...copying dillo.png to /opt/QtPalmtop/pics144/dillo.png
...copying ethereal.png to /opt/QtPalmtop/pics144/ethereal.png
...copying firefox.png to /opt/QtPalmtop/pics144/firefox.png
...copying flfm.png to /opt/QtPalmtop/pics144/flfm.png
...copying fltdj.png to /opt/QtPalmtop/pics144/fltdj.png
...copying galculator.png to /opt/QtPalmtop/pics144/galculator.png
...copying gimp.png to /opt/QtPalmtop/pics144/gimp.png
...copying gnumeric.png to /opt/QtPalmtop/pics144/gnumeric.png
...copying gqview.png to /opt/QtPalmtop/pics144/gqview.png
...copying grisbi.png to /opt/QtPalmtop/pics144/grisbi.png
...copying linux_debian.png to /opt/QtPalmtop/pics144/linux_debian.png
...copying minimo.png to /opt/QtPalmtop/pics144/minimo.png
...copying nedit.png to /opt/QtPalmtop/pics144/nedit.png
...copying openoffice.png to /opt/QtPalmtop/pics144/openoffice.png
...copying scite.png to /opt/QtPalmtop/pics144/scite.png
...copying stardict.png to /opt/QtPalmtop/pics144/stardict.png
...copying sylpheed.png to /opt/QtPalmtop/pics144/sylpheed.png
...copying thunderbird.png to /opt/QtPalmtop/pics144/thunderbird.png
...copying vnc.png to /opt/QtPalmtop/pics144/vnc.png
...copying xarchiver.png to /opt/QtPalmtop/pics144/xarchiver.png
...copying xchat.png to /opt/QtPalmtop/pics144/xchat.png
...copying xpdf.png to /opt/QtPalmtop/pics144/xpdf.png
...linking files to /opt/QtPalmtop/bin
...linking files to /usr/bin
...linking files to /usr/lib
...linking files to /usr/share
...linking files to /usr/local/bin
...linking files to /usr/local/share
...copying config files to /etc/gconf
...copying config files to /etc/gimp
...copying 2.0 to /etc/gimp/2.0
...copying config files to /etc/tuxpaint
...copying tuxpaint.conf to /etc/tuxpaint/tuxpaint.conf
...linking X server and config
...copying user config files to /home/zaurus
...copying .AbiSuite to /home/zaurus/.AbiSuite
...copying .dillo to /home/zaurus/.dillo
...copying .gimp-2.3 to /home/zaurus/.gimp-2.3
...copying .xmms to /home/zaurus/.xmms
...copying .xpdfrc to /home/zaurus/.xpdfrc
...loading libraries
...generating config files
pdaXqtApps configured.
...checking for zgcc2-95-2
zgcc2-95-2 not found!

X/Qt installed and configured (if found).
use xlauncher or the StartX icon to start it.
#


This post has been edited by Jon_J: Apr 26 2006, 10:56 AM
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Jon_J
post Apr 26 2006, 01:10 PM
Post #2





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I'm thinking of installing the automounter (0.4.7)
I'm going to wait and see if Meanie replys to my post, before I install it.
Below are the reasons why I think I need it, and reason why I didn't install it earlier.

When I first installed the pdaXqtrom-base and pdaXqtrom-apps these 2 cramfs packages were already mounted.
I've been told Cacko already has an automounter, and pdaXqtrom seemed to run fine without an additional automounter.
Later, I rebooted, and my mounts to these packages were gone.
(Also on a side note, Cacko booted with different error messages, and with a black screen, instead of the Cacko graphic, and the blue Cacko background graphic).
I went into console and entered:
mount -a

Now these cramfs packages were mounted, but would NOT launch from their icons in the X/Qt tab.
I can launch startx-wrapper from the console, and the X/Qt package seems to run fine.
There are no error messages in the console.

The main reason that I didn't want to install the automounter, is because the last time I installed it, and uninstalled it, it broke my Cacko setup.
I needed to reflash Cacko, and restore a backup.
Which brings me to another reason for not installing automounter.
You need to remember to do the following when using the Qtopia backup/restore app:

You will need to turn off automounter by runnning
CODE
------------------------------
su
/etc/rc.d/init.d/mntloop stop
------------------------------
before doing any backup or restore operations.

you can then turn it back on by running
CODE
------------------------------
su
/etc/rc.d/init.d/mntloop start
------------------------------
Go to the top of the page
 
+Quote Post
Meanie
post Apr 26 2006, 08:25 PM
Post #3





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Jon_J @ Apr 27 2006, 07:10 AM)
I'm thinking of installing the automounter (0.4.7)
I'm going to wait and see if Meanie replys to my post, before I install it.
Below are the reasons why I think I need it, and reason why I didn't install it earlier.

When I first installed the pdaXqtrom-base and pdaXqtrom-apps these 2 cramfs packages were already mounted.
I've been told Cacko already has an automounter, and pdaXqtrom seemed to run fine without an additional automounter.
Later, I rebooted, and my mounts to these packages were gone.
(Also on a side note, Cacko booted with different error messages, and with a black screen, instead of the Cacko graphic, and the blue Cacko background graphic).
I went into console and entered:
mount -a

Now these cramfs packages were mounted, but would NOT launch from their icons in the X/Qt tab.
I can launch startx-wrapper from the console, and the X/Qt package seems to run fine.
There are no error messages in the console.

The main reason that I didn't want to install the automounter, is because the last time I installed it, and uninstalled it, it broke my Cacko setup.
I needed to reflash Cacko, and restore a backup.
Which brings me to another reason for not installing automounter.
You need to remember to do the following when using the Qtopia backup/restore app:

You will need to turn off automounter by runnning
CODE
------------------------------
su
/etc/rc.d/init.d/mntloop stop
------------------------------
before doing any backup or restore operations.

you can then turn it back on by running
CODE
------------------------------
su
/etc/rc.d/init.d/mntloop start
------------------------------
*


I'll check into abiword, maybe it just needs more memory because it is a big app after all.
I don't think the problem with GQview has anything to do with the file system. Maybe its a filter. What type of images do you have?

automounter is for mounting the cramfs/squashfs images for you automatically upon reboot and also for creating extra loop devices. the installer creates extra loop devices for you as well, thus it can mount the loop devices for you. however, when you reboot, the extra loop devices are gone. auto mounter recreates them for you during boot and also mounts the devices for you. Cacko, and even Sharp ROM both automatically mount the loop devices for you if they are present in /etc/fstab, but they only mount the first 2 and then run out of loop devices. automounter then creates more loop devices and mounts all the left over entries that were not previously mounted and automounter also carefully checks which entries had already been mounted and won't mount them again. Previous versions of automounter had problem on Cacko, because it also unmounted Cacko's internal loop device when you ran automounter stop. The latest version, 0.4.7 fixes this, and it also makes a backup of the usb-storage file prior to installation so when you uninstall automounter it is able to restore the usb-storage script. In the previous versions, the installer/uninstaller program just removed usb-storage.
/etc/rc.d/init.d/mntloop is now linked to /usr/bin/automounter so you can just run
automounter stop/start
Go to the top of the page
 
+Quote Post

Posts in this topic
Jon_J   Pdaxqtrom & Apps   Apr 26 2006, 10:24 AM
Jon_J   I'm thinking of installing the automounter (0....   Apr 26 2006, 01:10 PM
Meanie   QUOTE(Jon_J @ Apr 27 2006, 07:10 AM)I'm t...   Apr 26 2006, 08:25 PM
DReymann   Hello, QUOTE(Jon_J @ Apr 26 2006, 07:24 PM)[...   Apr 27 2006, 12:40 AM
Jon_J   After using some of the apps, I've made some m...   Apr 27 2006, 08:13 AM
Meanie   QUOTE(Jon_J @ Apr 28 2006, 02:13 AM)After usi...   May 3 2006, 08:09 PM
Meanie   New updated version is now ready for testing. lots...   May 2 2006, 03:00 PM
ShiroiKuma   QUOTE(Meanie @ May 3 2006, 12:00 AM)New updat...   May 3 2006, 04:25 AM
Meanie   QUOTE(ShiroiKuma @ May 3 2006, 10:25 PM)QUOTE...   May 3 2006, 04:58 AM
ShiroiKuma   QUOTE(Meanie @ May 3 2006, 01:58 PM)you can a...   May 3 2006, 05:07 AM
Meanie   QUOTE(ShiroiKuma @ May 3 2006, 11:07 PM)QUOTE...   May 3 2006, 07:56 PM
freebird   QUOTE(Meanie @ May 2 2006, 11:00 PM)New updat...   May 3 2006, 08:47 AM
Meanie   QUOTE(freebird @ May 4 2006, 02:47 AM)QUOTE(M...   May 3 2006, 08:23 PM
Jon_J   freebird, download it again. My copy is 35.6MB (cr...   May 3 2006, 09:51 AM
adf   how's the speed on the pdaxqtrom stuff? My ea...   May 3 2006, 11:54 AM
Meanie   QUOTE(Jon_J @ May 4 2006, 03:51 AM)freebird, ...   May 3 2006, 08:42 PM
Jon_J   QUOTE(adf @ May 3 2006, 02:54 PM)how's th...   May 3 2006, 12:09 PM
Meanie   QUOTE(Jon_J @ May 4 2006, 06:09 AM)QUOTE(adf ...   May 3 2006, 08:27 PM
Jon_J   I'm having problems with automounter. It doesn...   May 3 2006, 07:07 PM
thurifer13   Meanie, firstly thanks, thanks, thanks, for all yo...   May 6 2006, 04:19 PM
Meanie   Cacko does not have X/Qt packages. The packages yo...   May 6 2006, 05:13 PM
adf   just installed pdaxqtrom base and apps using the c...   May 19 2006, 09:55 AM
adf   QUOTE(adf @ May 19 2006, 05:55 PM)just instal...   May 19 2006, 12:22 PM
adf   Fixed. Just a matter of finding libraries. on th...   May 20 2006, 02:31 PM
Meanie   QUOTE(adf @ May 21 2006, 08:31 AM)Fixed....   May 20 2006, 11:21 PM
adf   I guessed java might be a problem. why not tunnel...   May 20 2006, 11:50 PM
Thirrouard   Meanie? Why don't you provide the squashfs ver...   May 22 2006, 02:37 PM
Meanie   QUOTE(Thirrouard @ May 23 2006, 08:37 AM)Mean...   May 22 2006, 06:25 PM
adf   I can't seem to do secure-shell X forwarding f...   May 25 2006, 11:53 AM
moe   Seems I also have a gtk related problem.. After a...   May 26 2006, 12:33 AM
adf   a few posts up meanie posted "...try running ...   May 26 2006, 07:39 AM
moe   QUOTE(adf @ May 26 2006, 11:39 PM)a few posts...   May 27 2006, 07:51 AM
adf   QUOTE(moe @ May 27 2006, 03:51 PM)QUOTE(adf ...   May 27 2006, 10:18 AM
moe   Found some scripts in the other thread, and after ...   May 27 2006, 07:47 PM
adf   it worked! gimp now runs on my cacko/pdaxqt s...   May 27 2006, 09:00 PM
moe   QUOTE(adf @ May 28 2006, 01:00 PM)it worked...   May 27 2006, 10:15 PM
adf   QUOTE(moe @ May 28 2006, 06:15 AM)QUOTE(adf ...   May 27 2006, 11:56 PM
moe   Thanks for shedding the light Got GIMP working.. ...   May 28 2006, 08:54 AM
Meanie   QUOTE(moe @ May 29 2006, 02:54 AM)Thanks for ...   May 30 2006, 01:47 AM
moe   QUOTE(Meanie @ May 30 2006, 05:47 PM)you coul...   May 30 2006, 07:06 AM
bluedevils   I would like to run the sharp rom version of gaim ...   May 30 2006, 10:16 AM
Meanie   QUOTE(bluedevils @ May 31 2006, 04:16 AM)I wo...   Jun 3 2006, 12:25 AM
bluedevils   I tried pdaxqtrom today and got the gtk errors try...   May 26 2006, 12:10 PM
adf   QUOTE(bluedevils @ May 26 2006, 08:10 PM)I tr...   May 26 2006, 12:17 PM
moe   I tried to install Gaim, said failed to extract so...   Jun 1 2006, 02:27 AM
xamindar   How can I grab a window with the mouse and drag it...   Jun 2 2006, 07:55 PM
Raul   I cannot get any application to work except xpdf a...   Jun 3 2006, 09:28 AM
xamindar   QUOTE(Raul @ Jun 3 2006, 09:28 AM)I cannot ge...   Jun 11 2006, 06:00 PM
Cresho   Not sure but you need to delete all files from pre...   Jun 3 2006, 10:07 AM
Raul   I run xqtcleanup script. Installed pdaXqtrom once ...   Jun 3 2006, 11:17 AM
Meanie   QUOTE(Raul @ Jun 4 2006, 05:17 AM)I run xqtcl...   Jun 3 2006, 11:10 PM
Raul   It didn't help. Is there anyone with cacko rom...   Jun 10 2006, 07:12 AM
plcg   QUOTE(Raul @ Jun 10 2006, 03:12 PM)It didn...   Jun 10 2006, 10:44 AM
Raul   I'm doing it as root user , always.   Jun 10 2006, 03:11 PM
xamindar   Ok, simply removing it and reinstalling it fixed t...   Jun 11 2006, 11:28 PM
Raul   Did you reboot after reinstalling? Or after cleanu...   Jun 12 2006, 02:17 AM
xamindar   I didn't actually use the cleenup script. All...   Jun 12 2006, 03:31 AM
Raul   QUOTE(xamindar @ Jun 12 2006, 01:31 PM)I didn...   Jun 12 2006, 07:52 AM
miskinis   Hi, I have been trying to setup pdaXqtrom on an S...   Jun 14 2006, 09:27 AM
miskinis   Oh yeh, I forgot to mention how cool I think this ...   Jun 14 2006, 10:24 AM
Meanie   QUOTE(miskinis @ Jun 15 2006, 04:24 AM)Oh yeh...   Jun 14 2006, 06:06 PM
miskinis   Hi, OK, I'll help out some more on testing it...   Jun 15 2006, 09:01 AM
miskinis   QUOTE(miskinis @ Jun 15 2006, 05:01 PM)OK, I...   Jun 15 2006, 11:07 AM
Cresho   HORRAY!!!! a new version. awwwhhh...   Jun 14 2006, 06:33 PM
Meanie   QUOTE(Cresho @ Jun 15 2006, 12:33 PM)HORRAY...   Jun 15 2006, 04:06 AM
stbrock   QUOTE(Meanie @ Jun 15 2006, 08:06 AM)maybe no...   Jun 15 2006, 06:14 AM
Cresho   QUOTE(Meanie @ Jun 15 2006, 04:06 AM)QUOTE(Cr...   Jun 15 2006, 11:05 AM
Raul   QUOTE(Meanie @ Jun 15 2006, 02:06 PM)maybe no...   Jun 16 2006, 01:46 AM
Jon_J   QUOTE(miskinis @ Jun 15 2006, 12:01 PM)monoli...   Jun 15 2006, 10:17 AM
miskinis   Well, since I can't get the pdaXqtrom stuff ru...   Jun 15 2006, 06:15 PM
miskinis   Well, I just restored by SL-6000 to the sharp ROM,...   Jun 16 2006, 09:56 AM
miskinis   There seems to be an issue on the SL-6000, such th...   Jun 16 2006, 04:29 PM
climber   I 've installed the current cram version from ...   Jun 23 2006, 04:56 AM
netog   I have a C1000 with Cacko ROM 1.23 I am using the...   Jul 19 2006, 06:33 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd November 2014 - 01:07 PM