OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Wifi Card Stopped Registering Properly
Ventmore
post May 1 2006, 01:46 AM
Post #1





Group: Members
Posts: 62
Joined: 16-April 06
Member No.: 9,632



I have posted this problem in a different thread, but wanted to give it its own for more visibility.

I flashed my 5500 to tkrom 2 alpha 3, with the async kernel, and /home on SD script. Everything went fine until I put my wifi card in. It was recognised correctly, but I didn't get the little network monitor icon on the taskbar with the option to connect, and the led on the card would come on, and stay on, whereas, when it is recognised correctly, it will flash a few times, then go off until I connect. Running opera would bring up a connection box, but it would have no entries, even though the network settings were all correct.

I reflashed back to the Sharp ROM, and everything was OK.

I decided to give tkrom another try, and this time I tried the wifi card after every step. I flashed the rom then tried it...flashed the async kernel, and tried again, and finally ran the prep-home-sd script using the -c option to copy my network settings across to the new /home.

The wifi card came up every time, and behaved as it should. I did a few resets, with and without the card in, to see if it caused a problem. It was still working.

After a few days of messing around (installing different software), it is now not working again. The card is being recognised as usual, but now network connection icon, and the light comes on and stays solid again.

Any help would be most appreciated smile.gif
Ventmore
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
sdjf
post Jun 4 2006, 09:36 PM
Post #2





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



I've seen this kind of connectivity problem all over the forums, and believe it has something to do with the process daemaens (or whatever) getting a bit whaky and messing up the interfaces.

For me, I thought it was Opera, but NeIC does it also....I'm working on a script for myself to automate the aggravating process of trying to get connected once things get messed up.

The surest solution if cardctl reset 0 doesn't work for me has been to kill the offending pppd process (and maybe also a chat process as well), on a Sharp ROM 2.38 using dialup...different than this thread, but maybe this idea will help.

The pid's may need to be extracted from a 'ps ax' listing...not necessarily just /var/run/chat.pid or /var/run/ppp0.pid.

and look at /tmp/qpe-pppd-log or the equivalent on your system...if there are lines following the one showing "status = 0x0" then something's wrong, for me it's usually some stupid process trying to erase a non-existent /var/run/chat.pid file.

sdjf
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2014 - 03:27 AM