OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Is It Possible To Set Up Zgcc On Sharp Rom 313?, without having to change from cramfs
post May 3 2006, 05:20 PM
Post #1

Group: Members
Posts: 41
Joined: 18-February 05
Member No.: 6,498

i read through and tried to follow the methods to my best ability of this page:

i can get mnt/card/.zgcc and mnt/card/.include mounted
by dropping into root using "su" an doing:
mknod /dev/loop[n] b 7 [n]

then come back to user "zaurus" an run the script "mntzgcc.sh"
mount -t cramfs /mnt/card/zgcc2Bin.cramfs /mnt/card/.zgcc -o loop
mount -t cramfs /mnt/card/zgcc2Inc.cramfs /mnt/card/.include -o loop

some reason, i cant get them to fully link or get $PATH to look in them, when i run zgcc.sh
export GCC_EXEC_PREFIX=/mnt/card/.zgcc/lib/gcc-lib/arm-linux/2.95.2/
export COMPILER_PATH=/mnt/card/.zgcc/bin:/mnt/card/.zgcc/lib/gcc-lib/arm-linux/2.95.2/
export CPATH=/mnt/card/.include/
export LIBRARY_PATH=/mnt/card/.zgcc/lib/:/mnt/card/.zgcc/lib/gcc-lib/arm-linux/2.95.2/:/lib/:/home/QtPalmtop/lib/
export CPLUS_INCLUDE_PATH=/mnt/card/.include/g++-3/
export PATH
ln -sf /lib/libc.so.6 /usr/lib/libc.so
ln -sf /lib/libm.so.6 /usr/lib/libm.so
ln -sf /mnt/card/.zgcc/bin/libstdc++-3-libc6.1-2-2.10.0.so /home/QtPalmtop/lib/libstdc++-libc6.2-2.so.3

it doesnt show any errors when i run this,
but then it doesnt seem to be looking for anything its suppose to be??? rolleyes.gif

the strange thing is, that while in 1 Konsole tab where an when i run the scripts, i somehow got it before to see gcc from doing "which gcc"
cant remember how i did it, tho it brung up the proper location of gcc
(And only gcc tongue.gif )

if i start another tab in Konsole, an do "which gcc" it wont find it at all.
very peculiar!!?!?

i would like to do all this in one sweep from running 1 shell script, or most preferable have it set itself up at boottime. (aiming for that one, but will be happy with the other.)

so im unsure which file i need to be modifying, making or where it would go.
Could i alleviate all this by putting a script of sorts in "/home/zaurus"? or maybe even somewhere else that is rw? maybe like /usr? i would like it to be seperate from important files, but it doesnt have to be.

for over a month now laugh.gif ive been trying to figure out how to compile this package:

i do imagine some of you reading this, may have seen my post at the bottom in the thread about permissions. no one was answering so i figured i should restructure an make my own thread. i did search too, but i cant figure out what the true problem is!

it seems to me that $path $Path and $PATH are all different things, an now ive gone crosseyed.

thanks for you time.
Go to the top of the page
+Quote Post
post May 3 2006, 07:13 PM
Post #2

Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811

I would suggest to use option 2 mentioned under http://s91215199.onlinehome.us/zaurus/zgcc2install.html

It works very smoothly for me. Whenever I want to use gcc, I just type "source zgcc.sh". (Please note that you need around 30 MB space for one-time installation of gcc files on CF or SD for this option)

I type "which gcc" to check whether it is configured correctly.

You may wish to type "env" to check whether the paths are configured correctly.

I hope the above will help.
Go to the top of the page
+Quote Post
post May 23 2006, 09:06 PM
Post #3

Group: Members
Posts: 41
Joined: 18-February 05
Member No.: 6,498

thanks for your advice i followed it an it wasnt zgcc that was giving my problems with compiling, i actually did have it running properly i guess, i got the same errors from following your advice so i figure it is more related to something i need other than what i have. oh well no big deal. if i was meant to be a 3d graphics ruby programmer, i would have figured this out.

the whole Path PATH path thing absolutely confuses me! i should stick with ruby in 2d. tongue.gif maybe one of these days there will be a binary of that opengl lib. then the crazy,wireless,3d,qtruby,OSC controller. but for now its only the crazy,wireless,qtruby,OSC controller.
probably going to be named "zOSCR├╝by" pronounced zee-oscar-ooby.
(still need to finish how its going to work, an if it should have a pattern sequencer) great thing about this is, since hardly anyone knows what OSC is, whenever i finally get it to the point its working good, everyone will still be amazed! AND the big corporate audio software goons will have adapted. so it will seem new! biggrin.gif
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th May 2018 - 12:11 PM