OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Issue In Usb To Ethernet(pegasus.c)
Sashi Bhusan Moh...
post May 15 2006, 05:40 AM
Post #1





Group: Members
Posts: 1
Joined: 15-May 06
Member No.: 9,865



Hi ,

I am trying to use USB-Ethernet Converter in my Custom board in Montavista Linux. The USB memory stick as well as Ethernet are working fine in my board. But while using USB - Ethernet Converter it is getting detected but neither ping nor tftp are working.

Following are the details :

Linux Kernel Card Services 3.1.22
options: [pci] [cardbus]
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.1.2.1 $ time 12:03:10 May 12 2006
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0x19000000, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
Product: USB UHCI Root Hub
SerialNumber: 19000000
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0x19000020, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
Product: USB UHCI Root Hub
SerialNumber: 19000020
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
pegasus.c: v0.4.32 (2003/06/06):Pegasus/Pegasus II USB Ethernet driver
usb.c : registered new driver pegasus
rtl8150.c: rtl8150 based usb-ethernet driver v0.4.3 (2002/12/31)
usb.c: registered new driver rtl8150
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
Tracer: Initialization complete
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 512 bind 1024)
NET4: Unix domain sockets 1.0 /SMP for Linux NET4.0.
ds: no socket drivers loaded!
cramfs: wrong magic
FAT: bogus logical sector size 6552
VFS: Mounted root (jffs2 filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 64k freed
execve of /sbin/ltt_boot_trace failed
hub.c: new USB device 00:02.0-1, assigned address 2
Algorithmics/MIPS FPU Emulator v1.5
Manufacturer: ADMtek
Product: USB To LAN Converter
SerialNumber: 0001
pegasus.c : eth0: ADMtek ADM8511 "Pegasus II" USB Ethernet
pegasus.c: setup Pegasus II specific registers
INIT: version 2.78 booting
Activating swap...
Mounting local filesystems...
tmpfs on /mnt/ram type tmpfs (rw,size=8096k)
Cleaning\: /etc/network/ifstate.
Setting up IP spoofing protection\: rp_filter.
Configuring network interfaces\: done.
Starting portmap daemon\: portmap.
insmod: 8139too.o: no module by that name found
INIT: Entering runlevel: 3

MontaVista® Linux® Professional Edition 3.1

(none) login: root

# ifconfig
eth0 Link encap:Ethernet HWaddr 00:40:F4:D1:54:48
inet addr:10.41.1.249 Bcast:10.41.3.255 Mask: 255.255.252.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:15 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:61425 (59.9 kb) TX bytes:0 (0.0 cool.gif

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 cool.gif TX bytes:0 (0.0 cool.gif

# ifconfig eth0 192.168.1.1 up
# ifconfig
eth0 Link encap:Ethernet HWaddr 00:40:F4:D1:54:48
inet addr:192.168.1.1 Bcast: 192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 cool.gif TX bytes:0 (0.0 cool.gif

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 cool.gif TX bytes:0 (0.0 cool.gif

# tftp 192.168.1.2
tftp> bin
tftp> get Makefile
Transfer timed out.

tftp> q



This Transfer timed out is coming.
Can anybody help me out in resolving this issue.


Thanks,
Sashi
Go to the top of the page
 
+Quote Post
Sequethin
post May 15 2006, 06:58 AM
Post #2





Group: Members
Posts: 72
Joined: 12-December 04
Member No.: 5,903



QUOTE(Sashi Bhusan Mohapatra @ May 15 2006, 09:40 AM)
Hi ,

I am trying to use USB-Ethernet Converter in my Custom board in Montavista Linux. The USB memory stick as well as Ethernet are working fine in my board. But while using USB - Ethernet Converter it is getting detected but neither ping nor tftp are working.


wrong forum friend, this is the OpenBSD forum.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd November 2014 - 10:40 PM