OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Disable Rotation (c3100), Wrong screen rotation after wake up
tml
post Jun 4 2006, 09:49 AM
Post #1





Group: Members
Posts: 105
Joined: 3-August 05
Member No.: 7,766



Hi,

Is there a way to disable screen rotation? I have a c3100. On resume, the c3100 sometimes wakes up with the screen wrongly rotated. I use the c3100 always in clamshell mode (i.e. as a mini laptop) so I don't need this automatic rotation thing. I nevertheless would like to keep the possibility to rotate the screen manually.

Any help?

Regards,
Thomas.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies (1 - 3)
daniel3000
post Jun 4 2006, 09:54 AM
Post #2





Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027



Hi THomas,

I assume it only happens when you suspend the Zaurus by closing the screen?
THen that's because the "screen rotaion" switch in the screen hinge is activated before the "suspend" switch.
Maybe a software approach would be to delay the software routine which handles the rotation switch. But no idea how to do that.

A workaround would be to always suspend using the OnOff button before closing the screen.
That's how I avoid that.

But I'd also be interested in another solution.
However, I'd prefer rotation mode to be available (but maybe only manually), since in rare cases I'd still like to use it, e.g. for reading ebooks with opie reader.

daniel
Go to the top of the page
 
+Quote Post
tml
post Jun 7 2006, 08:42 PM
Post #3





Group: Members
Posts: 105
Joined: 3-August 05
Member No.: 7,766



QUOTE(daniel3000 @ Jun 4 2006, 07:54 PM)
I assume it only happens when you suspend the Zaurus by closing the screen?
THen that's because the "screen rotaion" switch in the screen hinge is activated before the "suspend" switch.
*


Thanks for this tip. I didn't think of that as I assumed all of this happens when turning the c3100 on. I still wish though there was a way to turn automatic rotation off. I searched /etc/rc.d but didn't find anything suitable. Oh well.
Go to the top of the page
 
+Quote Post
Jiba
post Jul 15 2008, 02:56 PM
Post #4





Group: Members
Posts: 13
Joined: 26-January 08
Member No.: 21,267



I also want to disable screen rotation, because I use the Zaurus in tablet mode only for viewing photo.

Here is the solution I found : edit all .desktop files in /opt/Qtopia/apps/*/ and replace :

Display=640x480/144dpi,480x640/144dpi

By :

Display=640x480/144dpi

This will forbid screen rotation for all these applications (you need to restart QTopia before it is taken into account).
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th November 2014 - 03:21 AM