OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Wifi: Major Problems With My Ambicomm Card, Can't connect; ioctl claims card busy
TP Diffenbach
post Jun 13 2006, 03:39 PM
Post #1

Group: Members
Posts: 1
Joined: 13-June 06
Member No.: 10,155

I'm having majot problems with my AmbiComm CF wireless card.

I suspect it may just be a hardware malfunction, but I'd like help diagnosing this.

My linux experience is pretty limited, but I can follow directions.

The card appears to be OK, the card's led lights when it should. But it can't seem to connect to any wireless network, either mine at home or a free cafe service.

For a while, kismet was working (so I at least knew the card was receiving); now kismet no longer shows any activity.

When I run (as root), cardctl ident, I see the expected product info. But when I run cardctl suspend, with the card apparently off (no led), I get "ioctl(): Device or resource busy".

cardctl resume makes the card's led blink and gives no error.

cardctl scheme qpwelan6 (qwpelan6 is the scheme for my home wifi) gives:
checking: eth0
Changing scheme from "CardSuspend" to 'qpwelan6'...
SIOCSIFFLAGS: No such device
ioctl(): Device or resource busy

Attempting to connect using the netmon subapplet makes the card's led blink, and eventually pops up a message box with "No Connection Detected/Check your TCP/IP settings". Of course, in my attempts to connect, I've got WEP turned off on my home wifi.

It's been a while since I've used my zaurus; back when I was using it, I had no problem connecting (albeit to a different router than the one I have now).

How can I figure out if the problem is the card's hardware or my software set up on the zaurus? At this time, I'd prefer to avoid purchasing another CF wifi card in order to test.

Go to the top of the page
+Quote Post
post Jun 14 2006, 08:48 AM
Post #2

Group: Members
Posts: 573
Joined: 8-June 05
Member No.: 7,295


Then Format or reflash to Default.

The model of Zaurus would help: If you have a 5500, you just have to do a hard-reset to clear the data.

Then from default, setup JUST the wifi and try it.

If it's no good, the card's dead.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 7th October 2015 - 07:46 AM