OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Updated Ruby And Rubygems Ipk
Sy Ali
post Jun 19 2006, 01:07 AM
Post #1





Group: Members
Posts: 120
Joined: 14-June 06
Member No.: 10,168



http://rubyforge.org/projects/ruby/
http://rubyforge.org/projects/rubygems/

Ruby is up to 1.8.4, and an ipk file for rubygems would be handy.

I try a manual installation of RubyGems, and I get a string of errors.

The most interesting one seems to be:
QUOTE
/opt/QtPalmtop/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29: in `require': libcrypto.so.0.9.6: cannot load shared object file: No such file or directory - /opt/QtPalmtop/lib/ruby/1.8/arm-linux/digest/md5.so (LoadError)


I'm going to check with the ruby-talk mailing list.. maybe I can solve the install problem.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Sy Ali
post Jun 19 2006, 09:31 AM
Post #2





Group: Members
Posts: 120
Joined: 14-June 06
Member No.: 10,168



fabianE reports:
I've compiled Ruby 1.8.4 including ri, gems and irb with auto-complete enabled. You can download it at http://mail.pdaxrom.org/contrib/fabian/ .

However, running "gem" gives:
QUOTE
/home/QtPalmtop/bin/gem:3 in `require': no such file to load -- rubygems (LoadError)


if I cd into

CODE
/home/QtPalmtop/lib/ruby/site_ruby/1.8


and I run it, I get a different error:

QUOTE
./rubygems.rb:51: warning: already initalized constant RubyGemsPackageVersion
./rubygems.rb:53: warning: already initalized constant DIRECTORIES


I'm not entirely sure if I have it working or not. =)

...

I've been using Cacko 1.23 so far, but perhaps I should switch over to pdaXrom 1.1.0beta4
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 2nd September 2014 - 01:15 PM