OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Pyqt Won't Display Text, Text on buttons and labels don't show up
snowfarthing
post Jun 22 2006, 06:24 AM
Post #1





Group: Members
Posts: 32
Joined: 29-October 04
Member No.: 5,265



I've tried a couple of "Hello, world" programs on my Zaurus. Both of them almost work, and I'm thrilled! except that "Hello, world!" doesn't show up on either of them.

Here's one of the programs (the simpler of the two):

CODE
import sys
from qt import *

myapp = QApplication(sys.argv)

mylabel = QLabel("Hello, world!", None)
mylabel.resize(120, 30)

myapp.setMainWidget(mylabel)
mylabel.show()
myapp.exec_loop()

I've tried both of these programs on my Linux desktop, and the text shows up just fine there. I suspect it might have something with font settings, but I'm just barely learning Qt, and don't know enough about it to know for sure.

What is the cause of this difficulty, and how can I fix it?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Mickeyl
post Jul 30 2006, 12:53 AM
Post #2





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



Sounds like the default font is not found. Try to use a QPEApplication instead -- this will set the correct default font.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th November 2014 - 12:27 AM