OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Wireless card failed to initialize?
post Feb 27 2004, 07:41 AM
Post #1

Posts: 0
Joined: --
Member No.: 0

Hello, I am new around here and new to the Zaurus. I have a SL-5000D using Sharp ROM Version 1.13 with a Linksys WCF11. I have configured everything to what I have read; IE the network settings, a listing for my card in pcmcia.conf, and the prism2_cs driver is installed.
I have been troubleshooting things for a day and a half when I ran accross a line in dmesg stating that the card failed to initialize. This may sound kinda stupid, but does this mean my card is dead or am I missing something?
Go to the top of the page
+Quote Post
post Feb 27 2004, 08:25 AM
Post #2

Group: Members
Posts: 235
Joined: 5-January 04
From: Chicago, Illinois
Member No.: 1,359

try the cardctl commands and see what they say:

# cardctl status (will tell you if card is 'ready' or 'suspended' IIRC)
# cardctl insert (will insert card if it is not recognized - happens when I restart pcmcia, for example)
# cardctl resume (if suspended, will attempt to activate the card)

FYI - I performed the following command and it seemed to fry my last WiFi card, so I'd steer clear just to be safe:
# cardctl reset

Someone will know this stuff better than me, but those are all the cmds that I need to manage my bluetooth and wifi cards.
Go to the top of the page
+Quote Post
post Feb 27 2004, 09:31 AM
Post #3

Posts: 0
Joined: --
Member No.: 0

Ok i did "cardctl status" and it shows the card is "ready", still not getting anywhere? It cant be my router I am 10 feet from it,so I dont think its a signal problem.
Also should "iwconfig" be installed or would that have any effect if it wasn't?

Here are some of the settings to view incase I screwed something up;

wlan-ng.conf entry for my card:

card "The Linksys Group, Inc.", "Wireless Network CF Card",
"ISL37300P", "RevA"
manfid: 0x0274, 0x3301
bind "prism2_cs"

Heres the part of the dmesg i was talking about:

init_module: prism2_cs.o: 0.1.12-shp Loaded
init_module: dev_info is: prism2_cs
prism2_cs: GetNextTuple: No more items
prism2sta_config: NextTuple failure? It's probably a Vcc mismatch.
prism2sta_event: prism2_cs: Initialization failed!

I appreciate the help
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 21st April 2018 - 01:30 PM