OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> How To Load G_file_storage.ko? Error Occus
andyzn
post Jul 3 2006, 06:21 AM
Post #1





Group: Members
Posts: 13
Joined: 3-July 06
Member No.: 10,306



I have a board with USB slave 1.1, and Linux installed on it.

I have connected it with a PC through a USB cable.

And I want to make the PC "know" the device?

on the board(the kernel is 2.6.11):

1. start Linux

2. dd bs=1M count=8 if=/dev/zero /root/data (FAT32)

3. modprobe g_file_storage file=/root/data

HERE IS THE ERROR MESSAGE:
*****************************************
Using /lib/modules/2.6.11-XSBase27x/kernel/drivers/usb/gadget/g_file_storage.ko
insmod: cannot insert `/lib/modules/2.6.11-XSBase27x/kernel/drivers/usb/gadget/g
_file_storage.ko': Device or resource busy (-1): Device or resource busy
modprobe: failed to load module g_file_storage
*****************************************

which device is busy?

Or
what should I do before I "modprobe g_file_storage..."?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
lardman
post Jul 11 2006, 01:05 AM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



I was going to suggest that.

Have you tried using g_file_storage as a stand-alone module?

There are also lots of:

QUOTE
usbcore: registered new driver usbfs
usbcore: registered new driver hub


Which looks like the usb port is being used as a host - this is not what you want for mass storage. Assuming this is the same port, you may need to change it from host to client mode (unless this happens automatically...?).


Si
Go to the top of the page
 
+Quote Post

Posts in this topic
andyzn   How To Load G_file_storage.ko? Error Occus   Jul 3 2006, 06:21 AM
lardman   How do you get a terminal prompt, not over a usb e...   Jul 3 2006, 06:27 AM
andyzn   Today I found g_ether is builded in. SO I recompil...   Jul 5 2006, 12:14 AM
andyzn   Here is sth after dmesg: [root@emdoor bin]# dmesg...   Jul 5 2006, 12:35 AM
lardman   I don't know, but a quick google turned up som...   Jul 5 2006, 03:03 AM
andyzn   Thanks for that. But the patch dosen't work. ...   Jul 6 2006, 10:14 PM
lardman   What does filp indicate the error is? Your file m...   Jul 10 2006, 03:25 AM
andyzn   Oh, sorry. Actually it is [root@Bill ~]fdisk -S...   Jul 10 2006, 04:18 AM
andyzn   I have checked the error, error = PTR_ERR(filp) ...   Jul 10 2006, 08:06 PM
andyzn   after dmesg,below is the information while rebooti...   Jul 10 2006, 08:19 PM
andyzn   rootfs is not mounted while open /root/back_file,a...   Jul 10 2006, 10:44 PM
lardman   I didn't notice it before, but this can't ...   Jul 10 2006, 02:57 PM
andyzn   In gadget/gadget_chips.h #ifdef CONFIG_USB_GADGET...   Jul 10 2006, 07:29 PM
lardman   I was going to suggest that. Have you tried using...   Jul 11 2006, 01:05 AM
andyzn   I am happy to say, my windows host could recognize...   Jul 11 2006, 01:13 AM
lardman   Glad you've got it sorted Si   Jul 11 2006, 01:28 AM
andyzn   The host(windows XP) always says "it should b...   Jul 11 2006, 05:54 AM
lardman   I'm not sure. You could always format it using...   Jul 11 2006, 06:05 AM
andyzn   That is interesting. I changed the partition type ...   Jul 11 2006, 09:58 PM
andyzn   Goal: To simulate the flash of the board to be a U...   Jul 11 2006, 10:39 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th December 2014 - 04:55 AM