OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Jamvm Not Working
post Jul 10 2006, 06:05 AM
Post #1

Group: Members
Posts: 38
Joined: 1-March 04
Member No.: 2,109


I have installed the base-pdaXqtrom, apps, java and zgcc cramfs in my C1000.

I have problem using jamvm with Classpath.
When I run /mnt/java/jamvm/bin/jamtest the output is:

jamvm test
swing test
bootclasspath is empty!

So I changed jamtest to run saying where the bootclasspath is:

jamvm -verbose -cp /usr/local/java/share/examples/examples.zip -bootclasspath /mnt/java/jamvm/share/classpath gnu.classpath.examples.swing.Demo

and now the output is:

[Linking class java/lang/Object]
[Linking class java/io/Serializable]
[Loaded java/lang/Class from /mnt/java/jamvm/share/classpath]
[Linking class java/lang/Class]
[Loaded java/io/Serializable from /mnt/java/jamvm/share/classpath]
[Loaded java/lang/Class from /mnt/java/jamvm/share/classpath]
[Loaded java/lang/Object from /mnt/java/jamvm/share/classpath]
[Loaded java/lang/Runnable from /mnt/java/jamvm/share/classpath]
[Linking class java/lang/Runnable]
[Loaded java/lang/Thread from /mnt/java/jamvm/share/classpath]
[Linking class java/lang/Thread]
[Loaded java/lang/VMThread from /mnt/java/jamvm/share/classpath]
[Linking class java/lang/VMThread]
Error initialising VM (initialiseMainThread)

What is wrong now?

Thanks in advance.
Go to the top of the page
+Quote Post

Posts in this topic
netog   Jamvm Not Working   Jul 10 2006, 06:05 AM
Meanie   QUOTE(netog @ Jul 11 2006, 12:05 AM)Hello I ...   Jul 10 2006, 05:00 PM
netog   I fixed the symlinks and everything worked OK. Swi...   Jul 11 2006, 06:36 AM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th June 2018 - 09:39 PM