OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Problem With Pegasus Usb Ethernet Solved, problem with pegasus usb ethernet solved
Lemuus
post Jul 27 2006, 09:53 PM
Post #1





Group: Members
Posts: 36
Joined: 23-July 06
Member No.: 10,508



I was having some trouble with a pegasus usb ethernet an OpenZaurus, kernel 2.6 spitz.
The kernel module doesn't catch the pegasus because in kernel 2.6, the kernel now keeps track of USB power budgets, because of that some usb devices doesn't get configured by the kernel, the solution...
use lsusb -v , to see the power requeriments, if you think that are aceptable, at your own risk..., use
echo -n "bconfigvalue" >/sys/bus/usb/devices/"usb address"/bConfigurationValue
example:
echo -n 1 >/sys/bus/usb/devices/1-2/bConfigurationValue
where 1 is the config value you see in lsusb -v, and 1-2 is the address of the usb device...
Sorry for the bad english, because i don't speak it very well...
Daniel
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd November 2014 - 10:51 AM