OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Damaged Power Cable Causes Battery Charge Problem
post Jul 28 2006, 07:43 AM
Post #1

Group: Members
Posts: 4
Joined: 28-July 06
Member No.: 10,552

Hi guys, gals, and small furry creatures from Alpha Centauri,

After a lot of experimenting, and a lot of reading here on OESF, I finally tracked down the source of my mysterious battery problems with my Zaurus SLC-860. I'd like to describe in detail the problem I had and its solution, in case anyone else may have a similar problem.


The basic problem was a faulty power cable preventing enough current from reaching the battery to fully charge it, but providing enough current to light the charging LED and barely, weakly charge the battery. This took a long time to diagnose due to the odd symptoms.


Zaurus SLC-860 and EA-BL08 1700 mAH battery are almost 3 years old.

Original Zaurus AC adapter silently died after about 1 year. I occasionally used external commercial battery packs with the Zaurus. I never, ever connected reverse polarity or over-voltage to the Zaurus, so I was pretty sure I didn't destroy the Zaurus charging circuit.

I bought a replacement adapter with a very thin power cable, rated at 5V 1000 mA and (apparently) regulated. Measuring output with a voltmeter gave 5.2v, within acceptable tolerance.

The replacement adapter worked fine for many months, then came... THE PROBLEMS.

Problems and symptoms:

1. Charging light comes on when A/C adapter plugged in, but battery doesn't charge, even overnight.
2. Zaurus turns itself after a few minutes off due to insufficient power, even while connected to A/C adapter.
3. Battery life when not connected to A/C adapter is around 10 minutes.
4. Measuring charger voltage gives 5.2 volts, the expected value.
5. Charging only works with Zaurus completely turned off. Afterwards, still only about 10 minutes of use.
6. Charging only continues for about 15 minutes, then stops (the charging LED turns off), even if battery is not full. Unplugging and replugging charger leads to another 15 minutes of charging.
6. Measuring charge voltage at battery terminals of Zaurus during charging (having pulled out the battery during charging) gives 4.2 volts, the expected value.
7. Using the "D+M charging trick" described elsewhere on these forums didn't charge the battery; it drained it. Note: the D+M charging trick is to go into the D+M service menu, then go to screen 2 and select "Batt Voltage Adjust", then plug in the AC adapter and leave the Zaurus sitting on that "Battery Voltage Adjust" screen (where it shows "Main Bat AD" and "Flash Data" and "Set Flash"). According to another article on these forums, this should charge the battery even above the set flash level.
8. The adapter never got really hot when charging.
9. The maximum battery voltage, measured with a multimeter, was ~3.74 volts after charging with Zaurus turned off and repeatedly plugging/unplugging the charger for several 15-minute charging sessions (see symptom 6). This was below expected; according to other posts, the maximum voltage should be 4.2 volts for a fully-charged battery (though the battery is rated at 3.7 volts).
10. The maximum "flash level" of the battery after charging (shown in D+M menu "Low Battery" or "Batt Voltage Adjust" menus) was 198. This was below expected; it should be above 200 (one report listed 217 as a maximum obtained value).

The pitiful battery life made it effectively impossible to use my Zaurus. After suffering what seemed like ages of horrible chills, aches, and fever - also known as Zaurus Withdrawal Syndrome - I set about in earnest to understand and solve the problem, with the following results.

The cause:

The thin power cable apparently became partly broken, enough to prevent the Zaurus from ever receiving enough charging current. Still, a multimeter showed 5.2V coming from the charger, so I didn't originally suspect the cable. But, eventually I excluded other possible causes and became convinced the cable was to blame, so I spliced the cable for the new adapter together with the old cable and plug from my old broken adapter, and - after verifying multiple times that I did not accidentally reverse the polarity - connected the newly spliced adapter/cable to the Zaurus.

Now the Zaurus is charging normally again.

Continued in next post...
Go to the top of the page
+Quote Post
Start new topic
post Jul 28 2006, 07:46 AM
Post #2

Group: Members
Posts: 4
Joined: 28-July 06
Member No.: 10,552

Continued from previous post...

In particular, I'd like to confirm that the "D+M menu charging trick" does indeed work and allows you to charge the battery as high as possible, even above the flashed-in battery level. If it doesn't work, then there may be problems with the charger or cable or plug.

The mysterious thing was that originally, the D+M charging trick didn't work for me. The reason, I now understand, was that my faulty cable was preventing enough current from reaching the battery for a full charge. Therefore, the power-hungry Zaurus screen was DRAINING the battery faster than the weak current (through the faulty cable) could charge the battery.

This also explained why I could only charge with the Zaurus turned off: only with the screen OFF could the weak current charge the battery at all. As soon as I turned on the Zaurus, the screen would quickly drain the battery faster than the weak current could charge it back up, leading to the Zaurus turning itself off even though it looked like it was charging (charging LED was on).

In my experiments, I tried flashing the current (low) battery level of 198 into the Zaurus to see if it would help, having read that flashing a level - ANY level - is sometimes necessary. It didn't change anything for me, and then I was stuck with a low "watermark" level for future charges. However, as mentioned before, the D+M charging trick allows you to charge even above the watermark level, so it's still possible to fully charge and re-flash a high watermark level even if you accidentally flashed in a low watermark level.

Right now, I am charging with the D+M charging trick and my Zaurus is displaying on the "Battery Voltage Adjust" screen. The previous flashed battery level was 198 but it is currently charging at level 205 and seems to still be increasing. It takes maybe 6-10 minutes for the battery charge level to go up one "unit" (e.g. 204 to 205), exactly as described in another post on these forums, but the charge time seems to increase as the battery charge level nears its maximum (which makes sense to avoid overcharging).

Also, my charger is comfortably warm right now, giving me a nice satisfied feeling that charging is, indeed, taking place.

Another post suggested using wires from the AC adapter connected directly to the battery to charge it. This seems risky (lithium ion batteries, I have read, can explode if overcharged or charged with too much current), whereas the D+M charging trick uses the controlled Zaurus trickle-charging circuitry to safely charge the battery to the maximum level.

So, to summarize:

1. Even if the voltmeter says 5.2 volts are coming out of the adapter, and even if the charging light comes on, that doesn't automatically mean the Zaurus will charge!
2. If the D+M charging trick doesn't work, or the charger doesn't get noticably warm during charging, suspect the charger.

Thanks to everyone here on OESF who have posted helpful and incredibly detailed information about all kinds of Zaurus battery and charging issues, information without which I could not have solved the problem.

It's good to see that my 3-year-old battery still has some life yet in it.

Comments or corrections welcome.
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 22nd June 2018 - 07:27 AM