OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Troubles Again With Nano, qemu-native and gcc4
ant
post Aug 19 2006, 12:31 PM
Post #1





Group: Members
Posts: 163
Joined: 11-March 04
From: IT
Member No.: 2,270



Hi,

building nano to test the toolchain I got this error:

NOTE: package qemu-native-0.8.1-r1: task do_fetch: completed
NOTE: package qemu-native-0.8.1-r1: task do_unpack: started
NOTE: Unpacking /home/arklinux/stuff/sources/dl_dir/qemu-0.8.1.tar.gz to /home/arklinux/stuff/build/tmp/work/armv5te-linux/qemu-native-0.8.1-r1/
NOTE: package qemu-native-0.8.1-r1: task do_unpack: completed
Updating /home/arklinux/stuff/build/tmp/stamps/armv5te-linux/qemu-native-0.8.1-r1.do_unpack
NOTE: package qemu-native-0.8.1-r1: task do_patch: started
NOTE: package qemu-native-0.8.1-r1: task do_patch: completed
Updating /home/arklinux/stuff/build/tmp/stamps/armv5te-linux/qemu-native-0.8.1-r1.do_patch
NOTE: package qemu-native-0.8.1-r1: task do_configure: started
ERROR: function do_configure failed
ERROR: log data follows (/home/arklinux/stuff/build/tmp/work/armv5te-linux/qemu-native-0.8.1-r1/temp/log.do_configure.2904)
| NOTE: Running /home/arklinux/stuff/build/tmp/work/armv5te-linux/qemu-native-0.8.1-r1/qemu-0.8.1/configure --build=i686-linux --host=i686-linux --target=i686-linux --prefix=/home/arklinux/stuff/build/tmp/staging/i686-linux --exec_prefix=/home/arklinux/stuff/build/tmp/staging/i686-linux --bindir=/home/arklinux/stuff/build/tmp/staging/i686-linux/bin --sbindir=/home/arklinux/stuff/build/tmp/staging/i686-linux/bin --libexecdir=/home/arklinux/stuff/build/tmp/staging/i686-linux/libexec --datadir=/home/arklinux/stuff/build/tmp/staging/i686-linux/share --sysconfdir=/home/arklinux/stuff/build/tmp/staging/i686-linux/etc --sharedstatedir=/home/arklinux/stuff/build/tmp/staging/i686-linux/com --localstatedir=/home/arklinux/stuff/build/tmp/staging/i686-linux/var --libdir=/home/arklinux/stuff/build/tmp/staging/i686-linux/lib --includedir=/home/arklinux/stuff/build/tmp/staging/i686-linux/include --oldincludedir=/home/arklinux/stuff/build/tmp/staging/i686-linux/include --infodir=/home/arklinux/stuff/build/tmp/staging/i686-linux/share/info --mandir=/home/arklinux/stuff/build/tmp/staging/i686-linux/share/man ...
| ERROR: "gcc" looks like gcc 4.x
| QEMU is known to have problems when compiled with gcc 4.x
| It is recommended that you use gcc 3.x to build QEMU
| To use this compiler anyway, configure with --disable-gcc-check
| FATAL: oe_runconf failed
NOTE: Task failed: /home/arklinux/stuff/build/tmp/work/armv5te-linux/qemu-native-0.8.1-r1/temp/log.do_configure.2904
NOTE: package qemu-native-0.8.1-r1: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package qemu-native-0.8.1: failed
ERROR: Build of nano failed
[arklinux@dhcppc0 build]$

My local conf is a slightly modified local.conf-openzaurus.3.5.4:

DL_DIR = "/home/arklinux/stuff/sources/dl_dir/"
#BBFILES := "/home/arklinux/stuff/org.openembedded.oz354fam083/packages/*/*.bb"
BBFILES := "/home/arklinux/stuff/org.openembedded.oz354x/packages/*/*.bb"
MACHINE = "c7x0"
DISTRO = "openzaurus-3.5.4.1"
PARALLEL_MAKE = "-j3"

What about --disable-gcc-check? Is it normal?

TIA

ant
Go to the top of the page
 
+Quote Post
Greg2
post Aug 19 2006, 12:52 PM
Post #2





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



Do:
CODE
apt-get install qemu
and edit your local.conf with:
ASSUME_PROVIDED += "qemu-native"
Go to the top of the page
 
+Quote Post
ant
post Aug 19 2006, 01:27 PM
Post #3





Group: Members
Posts: 163
Joined: 11-March 04
From: IT
Member No.: 2,270



Thx Greg,

now restarted compiling (resumed with glibc-2.3.5+cvs)

Tonight will be a long night...
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th December 2014 - 07:04 AM