OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Failed To Build 3.5.4.1 2.4 For Collie, Is this a bug?
DoTheDog
post Sep 13 2006, 07:45 PM
Post #1





Group: Members
Posts: 92
Joined: 9-August 05
Member No.: 7,823



Hi,
I am trying to build a gpe-image for collie kernel 3.5.4.1 however, it always pukes on checking for GCONF_DBUS. Is this a bug or a problem with my config? d-bus was built earlier in the image compile. Here is the error:
clip
| checking whether the ccache arm-linux-g77 -march=armv4 -mtune=xscale linker (arm-linux-ld) supports shared libraries... yes
| checking dynamic linker characteristics... GNU/Linux ld.so
| checking how to hardcode library paths into programs... immediate
| checking whether stripping libraries is possible... yes
| FYI: Using default config source xml::${sysconfdir}/gconf/gconf.xml.defaults for schema installation
| FYI: Will build with debug checks but no debug spew
| checking for gtkdoc-mkdb... false
| checking for db2html... true
| checking for GCONF_DBUS... configure: error: You need either ORBit or D-BUS for IPC
| FATAL: oe_runconf failed
NOTE: Task failed: /media/usbdisk/collie/bitbake-1.4/tmp/work/gconf-dbus-0.0cvs20060102-r9/temp/log.do_configure.14955
NOTE: package gconf-dbus-0.0cvs20060102-r9: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package gconf-dbus-0.0cvs20060102: failed
ERROR: Build of gpe-image failed
/clip

Should I submit a bug report? or is this some problem with my environment?

DoTheDog
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Hrw
post Sep 14 2006, 11:29 AM
Post #2





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



update metadata and build again
Go to the top of the page
 
+Quote Post
DoTheDog
post Sep 15 2006, 04:30 AM
Post #3





Group: Members
Posts: 92
Joined: 9-August 05
Member No.: 7,823



QUOTE(Hrw @ Sep 14 2006, 01:29 PM)
update metadata and build again
*


Hrw,
Thanks for the help. I updated (actually I rebuilt the environment) and I get a little farther. Now I have a problem in that it dies while building linux-openzaurus-2.6.17-r25. I am trying to build this for 2.4. I also noted it is building gcc-cross-3.4.4-r4 but I want it to use 2.95. I have downloaded and set up the 2.95 like this:

wget http://handhelds.org/download/projects/too...-2.95.3.tar.bz2.
mkdir -p /usr/local/arm
cp ~/media/usbdisk/collie/cross-2.95.3.tar.bz2 /usr/local/arm
cd /usr/local/arm
tar -xjf cross-2.95.3.tar.bz2
cd /usr/local/arm/2.95.3/bin
mv arm-linux-gcc arm-linux-gcc-2.95
mv arm-linux-ld arm-linux-ld-2.11.2
export PATH=/media/usbdisk/collie/bitbake/bin:/usr/local/arm/2.95.3/bin$PATH
export BBPATH=/media/usbdisk/collie/build:/media/usbdisk/collie/bitbake/tmp/org.openembedded.oz354x

In my local.conf I have:
ASSUME_PROVIDED += "virtual/arm-linux-gcc-2.95"
MACHINE = "collie"
TARGET_ARCH = "arm"
DISTRO = "openzaurus-3.5.4.1"
KERNEL_VERSION = "2.4"

Here is the error:
<clip>
| CC arch/arm/common/rtctime.o
| CC arch/arm/common/locomo.o
| arch/arm/common/locomo.c: In function `locomo_frontlight_set':
| arch/arm/common/locomo.c:1064: warning: passing arg 1 of `locomo_gpio_write' from incompatible pointer type
| arch/arm/common/locomo.c:1066: warning: passing arg 1 of `locomo_gpio_write' from incompatible pointer type
| CC arch/arm/common/sharpsl_param.o
| CC arch/arm/common/scoop.o
| LD arch/arm/common/built-in.o
| CC arch/arm/mach-sa1100/clock.o
| CC arch/arm/mach-sa1100/generic.o
| CC arch/arm/mach-sa1100/irq.o
| CC arch/arm/mach-sa1100/dma.o
| CC arch/arm/mach-sa1100/time.o
| CC arch/arm/mach-sa1100/collie.o
| arch/arm/mach-sa1100/collie.c: In function `collie_uart_set_mctrl':
| arch/arm/mach-sa1100/collie.c:99: error: `uart_dev' undeclared (first use in this function)
| arch/arm/mach-sa1100/collie.c:99: error: (Each undeclared identifier is reported only once
| arch/arm/mach-sa1100/collie.c:99: error: for each function it appears in.)
| arch/arm/mach-sa1100/collie.c:102: error: invalid type argument of `->'
| arch/arm/mach-sa1100/collie.c:104: error: invalid type argument of `->'
| arch/arm/mach-sa1100/collie.c:107: error: invalid type argument of `->'
| arch/arm/mach-sa1100/collie.c:109: error: invalid type argument of `->'
| arch/arm/mach-sa1100/collie.c: In function `collie_uart_get_mctrl':
| arch/arm/mach-sa1100/collie.c:116: error: `uart_dev' undeclared (first use in this function)
| arch/arm/mach-sa1100/collie.c:118: error: invalid type argument of `->'
| arch/arm/mach-sa1100/collie.c: In function `collie_uart_probe':
| arch/arm/mach-sa1100/collie.c:134: error: `uart_dev' undeclared (first use in this function)
| arch/arm/mach-sa1100/collie.c: In function `collie_uart_remove':
| arch/arm/mach-sa1100/collie.c:140: error: `uart_dev' undeclared (first use in this function)
| make[1]: *** [arch/arm/mach-sa1100/collie.o] Error 1
| make: *** [arch/arm/mach-sa1100] Error 2
| FATAL: oe_runmake failed
NOTE: Task failed: /media/usbdisk/collie/bitbake-1.4/tmp/work/linux-openzaurus-2.6.17-r25/temp/log.do_compile.17407
NOTE: package linux-openzaurus-2.6.17-r25: task do_compile: failed
ERROR: TaskFailed event exception, aborting
NOTE: package linux-openzaurus-2.6.17: failed
ERROR: Build of gpe-image failed
</clip>

What am I doing wrong?

Rob
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 10th July 2014 - 11:29 AM