OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Failed To Build 3.5.4.1 2.4 For Collie, Is this a bug?
DoTheDog
post Sep 13 2006, 07:45 PM
Post #1





Group: Members
Posts: 92
Joined: 9-August 05
Member No.: 7,823



Hi,
I am trying to build a gpe-image for collie kernel 3.5.4.1 however, it always pukes on checking for GCONF_DBUS. Is this a bug or a problem with my config? d-bus was built earlier in the image compile. Here is the error:
clip
| checking whether the ccache arm-linux-g77 -march=armv4 -mtune=xscale linker (arm-linux-ld) supports shared libraries... yes
| checking dynamic linker characteristics... GNU/Linux ld.so
| checking how to hardcode library paths into programs... immediate
| checking whether stripping libraries is possible... yes
| FYI: Using default config source xml::${sysconfdir}/gconf/gconf.xml.defaults for schema installation
| FYI: Will build with debug checks but no debug spew
| checking for gtkdoc-mkdb... false
| checking for db2html... true
| checking for GCONF_DBUS... configure: error: You need either ORBit or D-BUS for IPC
| FATAL: oe_runconf failed
NOTE: Task failed: /media/usbdisk/collie/bitbake-1.4/tmp/work/gconf-dbus-0.0cvs20060102-r9/temp/log.do_configure.14955
NOTE: package gconf-dbus-0.0cvs20060102-r9: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package gconf-dbus-0.0cvs20060102: failed
ERROR: Build of gpe-image failed
/clip

Should I submit a bug report? or is this some problem with my environment?

DoTheDog
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
lardman
post Sep 15 2006, 07:30 AM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
dies while building linux-openzaurus-2.6.17-r25


QUOTE
I am trying to build this for 2.4.


QUOTE
I also noted it is building gcc-cross-3.4.4-r4 but I want it to use 2.95.


3.xx is correct for the 2.6.x kernels, and it's trying to build a 2.6.x kernel atm.

It would appear it's not building the one you want.


QUOTE
In my local.conf I have:
ASSUME_PROVIDED += "virtual/arm-linux-gcc-2.95"
MACHINE = "collie"
TARGET_ARCH = "arm"
DISTRO = "openzaurus-3.5.4.1"
KERNEL_VERSION = "2.4"


I didn't think that KERNEL_VERSION is valid for the Collie, however I'm not sure as I've not been using bitbake for a while (holiday) so this may have changed.

I'll ask hrw.


Si
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th July 2014 - 04:36 AM