OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Failed To Build 3.5.4.1 2.4 For Collie, Is this a bug?
DoTheDog
post Sep 13 2006, 07:45 PM
Post #1





Group: Members
Posts: 92
Joined: 9-August 05
Member No.: 7,823



Hi,
I am trying to build a gpe-image for collie kernel 3.5.4.1 however, it always pukes on checking for GCONF_DBUS. Is this a bug or a problem with my config? d-bus was built earlier in the image compile. Here is the error:
clip
| checking whether the ccache arm-linux-g77 -march=armv4 -mtune=xscale linker (arm-linux-ld) supports shared libraries... yes
| checking dynamic linker characteristics... GNU/Linux ld.so
| checking how to hardcode library paths into programs... immediate
| checking whether stripping libraries is possible... yes
| FYI: Using default config source xml::${sysconfdir}/gconf/gconf.xml.defaults for schema installation
| FYI: Will build with debug checks but no debug spew
| checking for gtkdoc-mkdb... false
| checking for db2html... true
| checking for GCONF_DBUS... configure: error: You need either ORBit or D-BUS for IPC
| FATAL: oe_runconf failed
NOTE: Task failed: /media/usbdisk/collie/bitbake-1.4/tmp/work/gconf-dbus-0.0cvs20060102-r9/temp/log.do_configure.14955
NOTE: package gconf-dbus-0.0cvs20060102-r9: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package gconf-dbus-0.0cvs20060102: failed
ERROR: Build of gpe-image failed
/clip

Should I submit a bug report? or is this some problem with my environment?

DoTheDog
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Hrw
post Sep 17 2006, 07:32 AM
Post #2





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



1. set MACHINE_KERNEL_VERSION = "2.4" in conf/local.conf
2. update metadata
3. build

I just finished building of bootstrap/gpe/opie images for OZ 3.5.4.1 for collie with 2.4.18-crapix kernel. It took 3 days (my machine is not fastest one).
Go to the top of the page
 
+Quote Post
miskinis
post Sep 17 2006, 05:07 PM
Post #3





Group: Members
Posts: 333
Joined: 8-January 05
From: North East, USA Today
Member No.: 6,159



QUOTE(Hrw @ Sep 17 2006, 11:32 AM)
1. set MACHINE_KERNEL_VERSION = "2.4" in conf/local.conf
2. update metadata
3. build

I just finished building of bootstrap/gpe/opie images for OZ 3.5.4.1 for collie with 2.4.18-crapix kernel. It took 3 days (my machine is not fastest one).
*


Wow, I'd love to know how fast your machine is... I have been contemplating setting
up a kernel building environment for the Z, SL-5500 to start with. I remember seeing
the "right arrow held down continously causes suspend" issue fixed in an OZ
kernel patch, and I'm currently hunting down a good set of kernel sources to use.

Now, I'd ultimately like (love) to be able to compile a new kernel on the SL-5500
itself, probably 2.4 (I know you are a 2.6 fan) but I only have experience with
2.0.35 through 2.4.* on PCs.

Am I insane to actually persue an on-board kernel compilation, and development
environment?
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th December 2014 - 07:01 PM