OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Complete Vmware-zaurussdk With Lots Of Libs
matthis
post Sep 15 2006, 10:24 PM
Post #1





Group: Members
Posts: 218
Joined: 12-February 06
From: Tokyo
Member No.: 9,124



Hello devs and all,

I have tried the vmware-player image of zaurus SDK and it is really nive and easy to use. It is quite fast on my PIII-1Ghz so that was a nice surprise too.

The point of using it for me would not to make my programs, but to port existing programs to the sharp rom, lacking programs when compared to pdaXrom especially.

In order to do that we need other libs in the SDK to make porting programs easy.

I thought I would start adding SDL dev libs, so I got a fresh SDL tarball 1.2.11
I however fail to build-it.

Here is what I did:

Set de environment to arm with dev-arm-qpe.sh
configure with:
CODE
NM=arm-linux-nm LD=arm-linux-ld CC=arm-linux-gcc CXX=arm-linux-g++ RANLIB=arm-linux-ranlib AR=arm-linux-ar ./configure  --enable-video-qtopia --disable-video-dummy --disable-video-dga --disable-arts --disable-esd --disable-alsa --disable-cdrom --disable-video-x11 --disable-video-fbcon --disable-nasm --prefix=/home/dsl/sdl-cross/ --host=arm-unknown-linux-gnu


Then make, but gets the following error:

CODE
./src/video/qtopia/SDL_sysvideo.cc: In function `int QT_VideoInit(SDL_VideoDevice *, SDL_PixelFormat *)':
./src/video/qtopia/SDL_sysvideo.cc:230: invalid use of `this' in non-member function
./src/video/qtopia/SDL_sysvideo.cc:231: invalid use of `this' in non-member function
make: *** [build/SDL_sysvideo.lo] Error 1


Any help?
Thanks!
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th April 2014 - 07:52 AM