OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Sl-7500c 128m Flash Upgrade Failed!, Is there still hope?
wrc4
post Sep 18 2006, 07:05 PM
Post #1





Group: Members
Posts: 114
Joined: 12-May 06
Member No.: 9,848



Last week I opened my Zaurus SL-7500C and replaced the Flash chip with a K9F1G08UOM. (My original chip is also K9F... the only difference is the capacity).

I carefully checked the pins to make sure they are properly connected. Then I booted to the Service Menu using Fn+D+M. The up-right corner of Sevice Menu shows "SL-C760". But the chip wasn't properly recognized. Clicking on the version list gave me the following information:

CPU: PXA255 A0
Board: c760
Serial No: 00000b0d
ROM Checksum: bca1
RAM Size: 65536KB
NAND modules(0MB)
unknown[unknown]

I tried all the NAND Flash related command (NAND restore and NAND Full Erase) in the service menu and they all gave me an "Error -2". Restoring NAND backup or installing U-Boot didn't work either.

I can't put back my original chip because I damaged it when I removed it. (There must be some glue under the chip.) So basically my 7500 is dead.

I heard that somebody has successfully upgraded their Flash chip. So maybe he can share his experience with me. I'd be very appreciated.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Hrw
post Oct 1 2006, 02:34 AM
Post #2





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



albertr: iirc there was infos that cxx00 serial i/o port is 'JTAG only' now - not to be used by users at all...
Go to the top of the page
 
+Quote Post

Posts in this topic
wrc4   Sl-7500c 128m Flash Upgrade Failed!   Sep 18 2006, 07:05 PM
Reaper   I'm going to upgrade my C3000 and the first th...   Sep 18 2006, 08:33 PM
wrc4   QUOTE(Reaper @ Sep 18 2006, 08:33 PM)I'm ...   Sep 19 2006, 12:11 AM
Hrw   wrc4: you probably need to use same chip as the on...   Sep 19 2006, 04:10 AM
wrc4   QUOTE(Hrw @ Sep 19 2006, 04:10 AM)wrc4: you p...   Sep 19 2006, 05:08 AM
wrc4   I found a same 64MB chip as the previous one and s...   Sep 22 2006, 01:50 AM
chyang   Wow, so cool. I even asked the maker on this repai...   Sep 22 2006, 02:08 AM
pelrun   What was the full code on the original chip? When ...   Sep 22 2006, 05:36 AM
wrc4   pelrun, The full code is: K9F1G08UOM YCBO I wil...   Sep 22 2006, 04:52 PM
pelrun   No, I meant the original chip from your Z, you alr...   Sep 22 2006, 07:49 PM
wrc4   QUOTE(pelrun @ Sep 22 2006, 07:49 PM)No, I me...   Sep 23 2006, 12:54 AM
pelrun   From the datasheets, the K9F1208UOM ID is 76C0, bu...   Sep 23 2006, 08:04 AM
wrc4   QUOTE(pelrun @ Sep 23 2006, 08:04 AM)From the...   Sep 23 2006, 04:36 PM
pelrun   How would you replace the firmware if you need the...   Sep 23 2006, 06:30 PM
wrc4   QUOTE(pelrun @ Sep 23 2006, 06:30 PM)How woul...   Sep 23 2006, 07:37 PM
guylhem   The easiest way is to fill up the new chip with a ...   Sep 25 2006, 03:58 AM
speculatrix   is it possible to put a jtag interface on the Z an...   Sep 26 2006, 12:59 AM
albertr   I belive that JTAG is available on the Zaurus, At ...   Sep 26 2006, 08:33 AM
guylhem   The P2ROM is where the FN+D+M menu is stored, but ...   Sep 28 2006, 07:02 AM
Hrw   http://www.hrw.one.pl/2006/08/09/sharp-zaurus-jtag...   Sep 28 2006, 11:20 PM
albertr   Hrw, your link must be for old Zaurii models, like...   Sep 30 2006, 03:15 PM
Hrw   albertr: iirc there was infos that cxx00 serial i/...   Oct 1 2006, 02:34 AM
scholbert   QUOTE(Hrw @ Oct 1 2006, 11:34 AM)albertr: iir...   Nov 28 2006, 02:55 PM
albertr   QUOTE(scholbert @ Nov 28 2006, 05:55 PM)In an...   Nov 30 2006, 06:19 PM
scholbert   QUOTE(albertr @ Dec 1 2006, 03:19 AM)QUOTE(sc...   Dec 1 2006, 06:28 AM
Reaper   My old (and bricked due to KB cable/connector prob...   Oct 1 2006, 08:35 AM
guylhem   Hrw - I didn't see that in the 3xxx service ma...   Oct 4 2006, 01:25 AM
Reaper   Thank you very much for advice. I'll try it as...   Oct 4 2006, 09:59 AM
Hrw   Hmm. checked in 3100sm and there is UART connected...   Nov 28 2006, 04:23 PM
scholbert   QUOTE(Hrw @ Nov 29 2006, 01:23 AM)Hmm. checke...   Nov 29 2006, 07:14 AM
guylhem   According to the datasheets, there are JTAG lines ...   Dec 1 2006, 04:32 AM
albertr   No problem, I just wanted to set the record streig...   Dec 1 2006, 11:13 AM
pelrun   The 3100 schematic definitely provides for JTAG wi...   Dec 1 2006, 06:32 PM
scholbert   Hi pelrun, great information. I thought it would ...   Dec 3 2006, 02:10 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2014 - 11:05 PM