OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Strange Php Parse Errors, brackets acting funny
tnfiddler
post Sep 20 2006, 01:54 PM
Post #1





Group: Members
Posts: 8
Joined: 2-April 05
Member No.: 6,771



I've installed apache+php, mysql, and phpmyadmin. phpmyadmin works. apache works. So, I started in on my own php pages. It seems that any control structure involving squiggly brackets {} gives a parse error. It seems that everything else I've tried works.

For example:

<?php

for ($index = 0; $index < 5; $index++) {
echo "count";
}

?>

gives a parse error, but when I delete the brackets I get:

countcountcoutcountcount

like I would expect.

I am entering the brackets from the popup keyboard, but they display correctly. Is this some odd Zaurus thing? Is it some characterset thing?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
tnfiddler
post Oct 10 2006, 04:13 PM
Post #2





Group: Members
Posts: 8
Joined: 2-April 05
Member No.: 6,771



Bolbit: I installed MySQL 3.22.32-2, I can't remember if I had to tweak something to get it to work, try searching the forums. I don't know about Cacko.

Baallrog: Yeah, I'm a little concerned about the flash RAM, apparently one can move the MySQL data directory to a card with symbolic links. You can also start MySQL with a command line option to use a specific data directory. One of those is the next step. This isn't production, and I'm not doing heavy writing/mods, so I'm not too worried.

I am more concerned with the apache htdocs directory, where I am modifying the documents a lot. I tried to symlink it to the SD card, even set permissions and ownership, but it didn't work. Still working on that.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd September 2014 - 04:26 PM