OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Ipkg Can't Satisfy Dependecies -, opie-base, task-opie
jeevandras
post Sep 29 2006, 06:49 PM
Post #1





Group: Members
Posts: 21
Joined: 15-July 06
Member No.: 10,417



Hi,
I am always hitting a brickwall with installing vlc for my Z. I have got OZ and Opie 1.2.
I downloaded an Opie friendly VLC from
http://www.videolan.org/vlc/download-familiar.html

Tried installing the file opie-vlc_0.6.0_arm.ipk through the package manager and I get the error

Error: Cannot satisfy the following dependencies for opie-vlc:

opie-base
opie-libsdl

Also tried installing the file opie-libsdl from the same site and I get the error
Error: Cannot satisfy the following dependencies for opie-libsdl

task-opie

I see that task-opie and opie-base are the culprits here

I looked at the Packages installed using Package Manager on Opie and I find that a myriad of task-opie-something packages installed including task-opie-base installed. Is this what its looking for and don't see?

I assume that the packages i have could be older version and need to be updated?

How do I get them?

I know ipkg update should help with updating the ipks, no? Is that one of its uses? However, I have still not able to get my Z connected to my laptop to get it on the Internet. My more optimistic option would be to put them onto my CF or SD cards. Can anyone advise on if this is the way of doing it and how should I go about this, properly?

Also, I see that in the Package Manager configurator there is a means to specify the src of my feed. My Z's previous owner has left some ipks on the SD card he has given to me. However, when I do and ipkg update I get the error

"wget: not an http pr ftp url: /media/card/progs/Packages"

the folder /media/card is where my sd card is mounted on and just to state the obvious /progs is a folder on my sd card containing various ipks.

I can see that its obvious that why wget would fail if its looking at /media/card/progs/ because its no path on an HTTP server or FTP server but merely the path on my sd card.

So I assume thats not a good src for ipkg update. How else can I do an ipkg update if I don't have network connection to my Z.

I must say that some of the things I assume above could be rubbish coz I am a newbie to Z and linux. I appreciate any advice you can give. I am slowly but persevering at learning to figure out my Z and really appreciate your help. Many thanks!

Jeev
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2014 - 09:23 AM