OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Problem With Wireless Lan Wl-672 Wifi Card
post Nov 10 2006, 06:27 AM
Post #1

Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811

I got two pieces of the above-mentioned WiFi cards from my friend.

The response of "cardctl ident" is as follows:

product info: "Wireless LAN", "11Mbps PC Card", Version 01.02", ""
manfid: 0x0156, 0x0002
function: 6 (network)

I added the following in /etc/pcmcia/wlan-ng.conf:

card "Wireless LAN"
manfid 0x0156, 0x0002
bind "prism2_cs"

After restarting the cardmanager, I received the following from "cardctl stauts":

Socket 0:
3.3V 16-bit PC Card
function 0: [ready]

When I tried to use the network module to connect the card to the wireless LAN of my Linksys WAG54G modem router, which was configured as mixed mode Wireless connection, the card switched to suspended mode after short handshaking.

Any pointer to get this card worked?

My Zaurus is SL-5600 with the original Sharp ROM.
Go to the top of the page
+Quote Post
Start new topic
post Nov 13 2006, 07:50 AM
Post #2

Group: Members
Posts: 168
Joined: 14-October 05
From: Virginia
Member No.: 8,316

Actually I have one of these cars as well, and I have never had any success with it. Ambicom seems to be one of the best brand of cards to work with.
Go to the top of the page
+Quote Post
post Nov 18 2006, 04:37 AM
Post #3

Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811

I got it worked. Zaurus rocks.

I checked the content of /etc/pcmcia/network.opts and found this:

case "$ADDRESS" in
  start_fn () { return; }
   stop_fn () { return; }

I added Gateway IP and DHCP Hostname to point to my wireless router, which is configures as Wireless Access Point in Mixed Mode with disabled WEP.

I used "su cardctl status" to check the card status. The card should show:

Socket 0:
3.3V 16-bit PC Card
function 0: [ready]

If you found the card in suspended mod, issue "su cardctl resume"

As soon as the card is ready, just issue "su cardctl scehme qpewlan0 &" to configure the card. Do not make use of the network configuration module under Utilities, which does not work at all.

When this configuration command is issued first time, you should notice that the last line of message should be "resultcode=success". Then you can issue "ifconfig eth0" to check that the card has obtained a latest IP from the DHCP server residing in the router.

At times, I need to issue "su cardctl config" followed by "su cardctl scehme qewlan0 &" to get the network up.

As for Opera browser, I encountered "No proxy server" found first time. It works latter after changing the proxy setting as shown:

Use WAIS=0
Gopher Server=
WAIS Server=
No Proxy Servers=.sg
Use HTTP=0
Use FTP=0
HTTP Server
HTTPS Server
FTP Server

I still have problem to configure the card to work with my router which is configured in WEP with shared key mode.

Can someone shed light how to do it with command line?
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 22nd April 2018 - 10:06 PM