OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Sound Card Problem: Must Be 44.1khz ...
caritas
post Nov 30 2006, 05:49 AM
Post #1





Group: Members
Posts: 4
Joined: 22-February 06
Member No.: 9,203



I have a akita and installed hentges ROM on it.

For play SFC games, I compiled libsdl with fb support on (qpe support off) and snes9x.
With the QVGA support in Linux kernel 2.6.17, the video side is very good. But the sound side doesn't work.
(In Linux 2.6.16 of OZ 3.5.4.1, the sound works good, but the video is too small).

But the music can be played properly under Linux 2.6.17. So sound card driver can work, at least under some
specific condition. I try a sound wave file with 8 bit, 11025 Hz, and the it can not be played by mplayer.
So I think the sound card can work only under certain condition.

Then, I modified the snes9x, make it use 44100 Hz instead of 22050 Hz, and now I can play SFC games on
my zaurus perfectly (except the cursor, which is always there).

Why the sound card can not work in 22050 Hz?

Best Regards
Ying Huang
Go to the top of the page
 
+Quote Post
zaurick
post Nov 30 2006, 01:28 PM
Post #2





Group: Members
Posts: 19
Joined: 2-October 06
Member No.: 11,617



QUOTE(caritas @ Nov 30 2006, 02:49 PM)
I have a akita and installed hentges ROM on it.

For play SFC games, I compiled libsdl with fb support on (qpe support off) and snes9x.
With the QVGA support in Linux kernel  2.6.17, the video side is very good. But the sound side doesn't work.
(In Linux 2.6.16 of OZ 3.5.4.1, the sound works good, but the video is too small).

But the music can be played properly under Linux 2.6.17. So sound card driver can work, at least under some
specific condition. I try a sound wave file with 8 bit, 11025 Hz, and the it can not be played by mplayer.
So I think the sound card can work only under certain condition.

Then, I modified the snes9x, make it use 44100 Hz instead of 22050 Hz, and now I can play SFC games on
my zaurus perfectly (except the cursor, which is always there).

Why the sound card can not work in 22050 Hz?

Best Regards
Ying Huang
*


I don't know for the sound but i have a lot of problem with oz3.5.4.2 sound too on a spitz.
cat some sound raw to /dev/dsp don't work , volume can not be controled by opie and gpe, ...

but if it can help you :
for hide cursor, stop blinkin and disable blankin screen in console you can type
echo "\033c\033[9;0]\033[?33l\033[?25l" >/dev/console
and to return to the console default config type
echo "\033c"> /dev/console
if /dev/console doesn't word try /dev/tty or /dev/tty0.

it work fine for me.

Best Regards
zaurick
Go to the top of the page
 
+Quote Post
CoreDump
post Nov 30 2006, 01:54 PM
Post #3





Group: Members
Posts: 715
Joined: 25-July 04
From: .de
Member No.: 4,094



QUOTE(zaurick @ Nov 30 2006, 11:28 PM)
QUOTE(caritas @ Nov 30 2006, 02:49 PM)
I have a akita and installed hentges ROM on it.

For play SFC games, I compiled libsdl with fb support on (qpe support off) and snes9x.
With the QVGA support in Linux kernel  2.6.17, the video side is very good. But the sound side doesn't work.
(In Linux 2.6.16 of OZ 3.5.4.1, the sound works good, but the video is too small).

But the music can be played properly under Linux 2.6.17. So sound card driver can work, at least under some
specific condition. I try a sound wave file with 8 bit, 11025 Hz, and the it can not be played by mplayer.
So I think the sound card can work only under certain condition.

Then, I modified the snes9x, make it use 44100 Hz instead of 22050 Hz, and now I can play SFC games on
my zaurus perfectly (except the cursor, which is always there).

Why the sound card can not work in 22050 Hz?

Best Regards
Ying Huang
*


I don't know for the sound but i have a lot of problem with oz3.5.4.2 sound too on a spitz.
cat some sound raw to /dev/dsp don't work , volume can not be controled by opie and gpe, ...

but if it can help you :
for hide cursor, stop blinkin and disable blankin screen in console you can type
echo "\033c\033[9;0]\033[?33l\033[?25l" >/dev/console
and to return to the console default config type
echo "\033c"> /dev/console
if /dev/console doesn't word try /dev/tty or /dev/tty0.

it work fine for me.

Best Regards
zaurick
*



Both sound issues should be fixed by an updated kernel (well, at least the opie one is).
A new kernel should be available soon.
Go to the top of the page
 
+Quote Post
zaurick
post Dec 10 2006, 10:53 AM
Post #4





Group: Members
Posts: 19
Joined: 2-October 06
Member No.: 11,617



QUOTE
Both sound issues should be fixed by an updated kernel (well, at least the opie one is).
A new kernel should be available soon.
*


Thanks CoreDump, i have updated my 3.5.4.2 and now i can cat sound to /dev/dsp smile.gif .
Maybe caritas problem is resolved too.
The last thing that don't work is the volume control in opie.

Thanks to all OZ devloppers for their work !
I use OZ every day on my C3000 and it's the best rom for me.

Zaurick.
Go to the top of the page
 
+Quote Post
STrRedWolf
post Dec 10 2006, 05:03 PM
Post #5





Group: Members
Posts: 36
Joined: 31-December 03
Member No.: 1,319



Which kernel version is this, Coredump?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 2nd October 2014 - 08:32 AM