OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Bitbake For Single File-----openvpn
yanyan
post Dec 4 2006, 09:35 AM
Post #1





Group: Members
Posts: 7
Joined: 27-November 06
Member No.: 12,814



I want to compile the openvpn for my SL5500. I install the OE bitbake for this purpose. When I run bitbake everything is all right.
CODE
DL_DIR="/stuff/source"
BBFILES:="/stuff/org.openembedded.dev/packages/*/*.bb"

TARGET_OS="Linux"
TARGET_ARCH="arm"
TARGET_FPU="soft"

MACHINE="collie"
#DISTRO= "openzaurus-3.5.4"
DISTRO="openzaurus-unstable"
#DISTRO_VERSION = "3.5.4"

INHERIT = "package_ipk"
IMAGE_FSTYPES= "jfffs2 tar"
BBINCLUDELOGS="yes"

PREFERRED_PROVIDERS="virtual/qte:qte virtual/libqpe:libqpe-opie"
PREFERRED_PROVIDERS+= "virtual/libsdl:libsdl-qpe"
ASSUME_PROVIDED += "virtual/arm-linux-gcc-2.95"

I use DISTRO="openzaurus-unstable" because under /stuff/org.openembedded.dev/conf/dist/ there is only openzaurus-unstable.conf but not the openzaurus-3.5.4.conf. am I right?

The first time I run
bitbake -b /stuff/org.openembedded.dev/packages/openvpn/openvpn_2.0.2.bb

It generates the ipk under /stuff/build/conf/tmp/deploy. I copy to my Z, but when I use ipkg to install it responds that invalid image. How can I solve this?

so I modidied the local.conf a bit, using DISTRO= "openzaurus-3.5.4" instead of
DISTRO="openzaurus-unstable" and I also find openzaurus-3.5.4.conf from the internet and put it into the path.

but the second time I bitbake openvpn it fails. error message is

CODE
NOTE: package openvpn-2.0.2-r0: task do_configure: started
NOTE: SITE files /stuff/org.openembedded.dev/site/endian-little /stuff/org.openembedded.dev/site/arm-linux
ERROR: function do_configure failed
ERROR: log data follows (/stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/log.do_configure.4100)
| /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/run.do_configure.4100: line 565: automake: command not found
| /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/run.do_configure.4100: line 566: automake: command not found
NOTE: Task failed: /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/log.do_configure.4100
NOTE: package openvpn-2.0.2-r0: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package openvpn-2.0.2: failed
ERROR: Build of 'openvpn' failed
Build statistics:
 Attempted builds: 1
 Failed builds: 1


Thanks a lot, can someone gives me suggestions?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
hvontres
post Dec 4 2006, 09:39 AM
Post #2





Group: Members
Posts: 118
Joined: 12-May 05
From: Oceanside,Ca
Member No.: 7,121



QUOTE(yanyan @ Dec 4 2006, 10:35 AM)
I want to compile the openvpn for my SL5500. I install the OE bitbake for this purpose. When I run bitbake everything is all right.
CODE
DL_DIR="/stuff/source"
BBFILES:="/stuff/org.openembedded.dev/packages/*/*.bb"

TARGET_OS="Linux"
TARGET_ARCH="arm"
TARGET_FPU="soft"

MACHINE="collie"
#DISTRO= "openzaurus-3.5.4"
DISTRO="openzaurus-unstable"
#DISTRO_VERSION = "3.5.4"

INHERIT = "package_ipk"
IMAGE_FSTYPES= "jfffs2 tar"
BBINCLUDELOGS="yes"

PREFERRED_PROVIDERS="virtual/qte:qte virtual/libqpe:libqpe-opie"
PREFERRED_PROVIDERS+= "virtual/libsdl:libsdl-qpe"
ASSUME_PROVIDED += "virtual/arm-linux-gcc-2.95"

I use DISTRO="openzaurus-unstable" because under /stuff/org.openembedded.dev/conf/dist/ there is only openzaurus-unstable.conf but not the openzaurus-3.5.4.conf.  am I right?

The first time I run
bitbake -b /stuff/org.openembedded.dev/packages/openvpn/openvpn_2.0.2.bb

It generates the ipk under /stuff/build/conf/tmp/deploy. I copy to my Z, but when I use ipkg to install it responds that invalid image. How can I solve this?

so I modidied the local.conf a bit, using DISTRO= "openzaurus-3.5.4" instead of
DISTRO="openzaurus-unstable" and I also find openzaurus-3.5.4.conf from the internet and put it into the path.

but the second time I bitbake openvpn it fails. error message is

CODE
NOTE: package openvpn-2.0.2-r0: task do_configure: started
NOTE: SITE files /stuff/org.openembedded.dev/site/endian-little /stuff/org.openembedded.dev/site/arm-linux
ERROR: function do_configure failed
ERROR: log data follows (/stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/log.do_configure.4100)
| /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/run.do_configure.4100: line 565: automake: command not found
| /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/run.do_configure.4100: line 566: automake: command not found
NOTE: Task failed: /stuff/build/conf/tmp/work/arm-linux/openvpn-2.0.2-r0/temp/log.do_configure.4100
NOTE: package openvpn-2.0.2-r0: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package openvpn-2.0.2: failed
ERROR: Build of 'openvpn' failed
Build statistics:
 Attempted builds: 1
 Failed builds: 1


Thanks a lot, can someone gives me suggestions?
*



you might want to try using the org.openembedded.oz354x branch instead. I am not sure if openvpn is in there or not.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th October 2014 - 05:27 AM