OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Resume Event On Cacko, SIGCONT not emited
ztep
post Dec 29 2006, 02:44 AM
Post #1





Group: Members
Posts: 80
Joined: 30-March 05
Member No.: 6,751



In this page, Spencer Huang said that a SIGCONT signal is sent to each running process when the zaurus is resumed.

While testing the next version of qpegps (it is altmost here), that catchs that signal to start the gps card after a resume, I notice that the SIGCONT signal is never received.

With other tests I have proved that the SIGCONT signal is not called after a resume on Cacko (at least in versions 1.23 and 1.22 and zaurus C760 and C3100) while with the original sharp ROM the signal is fired as expected.

Anyone knows how to activate this function?

I have been thinking on adding a line (killall -SIGCONT qpegps) to a resume script, but I don't know where to put this command. Someone with more knowledge can help me?

Is there any other method to detect when the zaurus is resumed?

Thanks.
Go to the top of the page
 
+Quote Post
ztep
post Jan 9 2007, 01:22 AM
Post #2





Group: Members
Posts: 80
Joined: 30-March 05
Member No.: 6,751



Answering myself.

I have detected that cacko ROM (and the original sharp ROM on CXXX) calls Resumed() to QPE/System using QCop messages, after tha zaurus is resumed.

I have detected this event and now the GPS CF card is resumed fine.

I don't know if this will work on Opie.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th December 2014 - 08:33 PM