OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> New Kernel Install, Howto install an updated kernel ?
miloo
post Jan 19 2007, 02:08 AM
Post #1





Group: Members
Posts: 17
Joined: 10-January 06
Member No.: 8,888



Hello. I installed Hentges 3.5.4.1 for my akita and wanted to upgrade my system, using the "testing" dir of hentges feed. But I get a very bad message at reboot concerning an expected kernel-2.6.17.
I understand that the kernel-image is not installed, but how can I install the matching kernel for the upgraded system ? Where to find it ? I searched on the mirror feeds but did not find anything. The only available kernel (zImage.bin) are the ones to use for installing the OZ releases.
Please give me some clues, I'm lost ... sad.gif

Eric
Go to the top of the page
 
+Quote Post
lardman
post Jan 19 2007, 04:12 AM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



As your machine works, you're probably alright (your modules match your kernel - look at the name of the subdir of /lib/modules/ for the kernel version that your modules are for). Compare this with the output of "uname -r" to give the current kernel.

The warning script is located in /etc/init.d/ and was put in place because people used to have troubles renaming the zImage.bin file and therefore ended up flashing a new rootfs and keeping the old kernel.

Assuming you're okay, and you know you've updated your kernel & modules, you can remove/rename this script (sorry I don't have my Z with me atm so I can't tell you the name).


Si
Go to the top of the page
 
+Quote Post
miloo
post Jan 19 2007, 04:29 AM
Post #3





Group: Members
Posts: 17
Joined: 10-January 06
Member No.: 8,888



QUOTE(lardman @ Jan 19 2007, 02:12 PM)
Assuming you're okay, and you know you've updated your kernel & modules, you can remove/rename this script (sorry I don't have my Z with me atm so I can't tell you the name).


Si
*


That's the point : how do you update the kernel ? Ok for the modules, they are populated with all the kernel-module-* in the feeds, but I don't see how to install a new kernel version.
For instance, OZ 3.5.4.1 release is given with 2.6.16 kernel version, I want to update to 2.6.17. where to find kernel-2.6.17 corresponding to the kernel-module-*-2.6.17-* found in the feeds ?

Eric
Go to the top of the page
 
+Quote Post
lardman
post Jan 19 2007, 03:43 PM
Post #4





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



The kernel can only be updated by flashing a new zimage.bin (no need to flash the initrd.bin too).


Si
Go to the top of the page
 
+Quote Post
miloo
post Jan 20 2007, 03:32 AM
Post #5





Group: Members
Posts: 17
Joined: 10-January 06
Member No.: 8,888



QUOTE(lardman @ Jan 20 2007, 01:43 AM)
The kernel can only be updated by flashing a new zimage.bin (no need to flash the initrd.bin too).


Si
*


Ok but where can we find the zImage.bin corresponding to those module packages ?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th December 2014 - 09:59 PM