OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio


Welcome Guest ( Log In | Register )

> No Sl6000 Display
post Jan 27 2007, 06:34 PM
Post #1

Group: Members
Posts: 23
Joined: 29-September 04
Member No.: 4,816

When I turn on my 6000, the display is black. This happened after a week of low battery warnings even though I had it on the charger, and after I dropped it. I tried taking the battery out for a while and reinserting it; hard resetting it with reset while haolding the OK butteon; holding Q and T while resetting. I tried removing the battery overnight, then pressing D and B and plugging in the power; also, holding Fn, D, and M while pressing reset. The charging light comes on and something beeps when I did a hard reset. The display seems to change to a different shade of black when I try to trun it on but nothing that I can use.

Did I do damage to the screen when I dropped it or is it a used-up battery? I had its Piel Frama case on when dropped and I've dropped it before without a problem. If it's the screen, what can I do to repair it? If it's just the battery, I can replace it.

Go to the top of the page
+Quote Post
Start new topic
post Jul 29 2008, 01:32 PM
Post #2

Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551

Thanks, I was rather skeptical. smile.gif

Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 4th October 2015 - 07:21 AM