OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Wrong Date And Pdaxrom On/off Issues, How I dealed with them some time ago
kkazakov13
post Feb 17 2007, 10:58 PM
Post #1





Group: Members
Posts: 409
Joined: 3-December 06
Member No.: 13,063



When I started with beta3, had some time issues and pdaxrom occasionally "locking up" - which turns out to be because of wrong clock. Here I share my way of fixing them.

I use the following pair of scripts.
When you need date synchronization, just call 'dt' script.

(modify the values to your needs, I live in Sofia and use for sync ntp.intergenia.de, which you might not be able to access. Place the files in /usr/local/bin, and 'chmod +x' )

dt
CODE
#!/bin/bash

lt_unset

ntpdate ntp.intergenia.de
hwclock --systohc

lt_set


lt_set:
CODE
#!/bin/bash

rm -f /etc/localtime
ln -s /usr/share/zoneinfo/Europe/Sofia /etc/localtime


lt_unset:
CODE
#!/bin/bash

rm -f /etc/localtime



in /etc/apm/scripts.d/hwclock the functions inside look like this:

CODE
suspend() {
 lt_unset
 hwclock --systohc
 lt_set
 return 0
}

resume() {
 lt_unset
 hwclock --hctosys
 lt_set
 return 0
}


I can guarantee you that you will have _no_ problems with the clock anymore, just set the correct timezone and ntp server. If you don't have internet, you just can issue commands in 'dt' one by one, replacing ntpdate with 'date xxxx' command to set the clock.

Also, if you accidentally turn off your zaurus, don't turn it on immediately. wait 3-4 seconds at least, and then do it.

timezones package from the feed is required.
Go to the top of the page
 
+Quote Post
louigi600
post Feb 18 2007, 01:39 AM
Post #2





Group: Members
Posts: 474
Joined: 21-May 06
Member No.: 9,928



QUOTE(kkazakov13 @ Feb 18 2007, 08:58 AM)
When I started with beta3, had some time issues and pdaxrom occasionally "locking up" - which turns out to be because of wrong clock. Here I share my way of fixing them.

I use the following pair of scripts.
When you need date synchronization, just call 'dt' script.

(modify the values to your needs, I live in Sofia and use for sync ntp.intergenia.de, which you might not be able to access. Place the files in /usr/local/bin, and 'chmod +x' )

dt
CODE
#!/bin/bash

lt_unset

ntpdate ntp.intergenia.de
hwclock --systohc

lt_set


Unfortunately the hwclock function has not been compiled into busybox in r121 and, to my knowlage, no alternative is yet avalible.
Go to the top of the page
 
+Quote Post
kkazakov13
post Feb 18 2007, 04:43 AM
Post #3





Group: Members
Posts: 409
Joined: 3-December 06
Member No.: 13,063



I did not said it's for r121, but for beta3
Go to the top of the page
 
+Quote Post
ZDevil
post Feb 18 2007, 06:20 AM
Post #4





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



I simply get rid of atd, which meddles with the system clock, and date setting works fine.
I am sure there is a thread talking about this a couple of months ago, though i can't recall it off the top of my head. The last thing i remember but didn't try is to turn atd on and off by a script, but I I didn't have the resource to spend on researching this.
Also as a result, i lost the last reason to keep KO/Pi in my system. Now still searching for a good alternative... dry.gif
Go to the top of the page
 
+Quote Post
tombraider
post Feb 18 2007, 08:52 AM
Post #5





Group: Members
Posts: 409
Joined: 23-November 04
From: Murphy, North Carolina USA
Member No.: 5,590



ZDevil:

The date/time setting going to a total crash problem healed itself somehow on my beta3 installation on my C1000 after I installed a bunch of libs and software. Unfortunately, it was one of those things where I did not NOTICE it was fixed until after I had done a bunch of changes so I can't say exactly what DID fix it. sad.gif But I did not have to remove atd...amazingly, and I don't have to stop and start it via the console commands anymore.

Of course I still have the on/off switch problem; the changing date and time arbitrarily problem, and the running down the battery problem when it is in suspend....oh,well.

I have to say that pdaxrom is so amazing that despite absolute show-stopper problems, I still have it installed on my C1000. Of course, one can only take so much pain so I will, perhaps, be going back to a Sharp Rom sometime.

I don't understand scripts or I would try kkazakov13's method of at least keeping a correct date.



QUOTE(ZDevil @ Feb 18 2007, 10:20 AM)
I simply get rid of atd, which meddles with the system clock, and date setting works fine.
I am sure there is a thread talking about this a couple of months ago, though i can't recall it off the top of my head. The last thing i remember but didn't try is to turn atd on and off by a script, but I I didn't have the resource to spend on researching this.
Also as a result, i lost the last reason to keep KO/Pi in my system. Now still searching for a good alternative...  dry.gif
*
Go to the top of the page
 
+Quote Post
kkazakov13
post Feb 18 2007, 10:08 AM
Post #6





Group: Members
Posts: 409
Joined: 3-December 06
Member No.: 13,063



I really _rely_ on Z's date/time now, something I couldn't do few months ago. All thanks to my scripts. I like to make scripts. Have even one which I use to reinstall beta3 from plain files, and then bring it back to the exact settings like I want it, without the garbage (when I mess too much). So this means, reinstalling beta3 and having it usable with all the packages, fixes and all, takes about 20 minutes.
Go to the top of the page
 
+Quote Post
tovarish
post Feb 18 2007, 11:15 PM
Post #7





Group: Members
Posts: 299
Joined: 27-October 04
Member No.: 5,233



you dont need to delete /etc/localtime if you do
hwclock --utc --systohc
and
hwclock --utc --hctosys

QUOTE(kkazakov13 @ Feb 18 2007, 07:58 AM)
When I started with beta3, had some time issues and pdaxrom occasionally "locking up" - which turns out to be because of wrong clock. Here I share my way of fixing them.

I use the following pair of scripts.
When you need date synchronization, just call 'dt' script.

(modify the values to your needs, I live in Sofia and use for sync ntp.intergenia.de, which you might not be able to access. Place the files in /usr/local/bin, and 'chmod +x' )

dt
CODE
#!/bin/bash

lt_unset

ntpdate ntp.intergenia.de
hwclock --systohc

lt_set


lt_set:
CODE
#!/bin/bash

rm -f /etc/localtime
ln -s /usr/share/zoneinfo/Europe/Sofia /etc/localtime


lt_unset:
CODE
#!/bin/bash

rm -f /etc/localtime



in /etc/apm/scripts.d/hwclock the functions inside look like this:

CODE
suspend() {
 lt_unset
 hwclock --systohc
 lt_set
 return 0
}

resume() {
 lt_unset
 hwclock --hctosys
 lt_set
 return 0
}


I can guarantee you that you will have _no_ problems with the clock anymore, just set the correct timezone and ntp server. If you don't have internet, you just can issue commands in 'dt' one by one, replacing ntpdate with 'date xxxx' command to set the clock.

Also, if you accidentally turn off your zaurus, don't turn it on immediately. wait 3-4 seconds at least, and then do it.

timezones package from the feed is required.
*
Go to the top of the page
 
+Quote Post
Meanie
post Feb 18 2007, 11:27 PM
Post #8





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



this is what I have in /etc/apm.d/scripts/hwclock

CODE
suspend() {
 /etc/rc.d/init.d/atd stop 2>/dev/null >/dev/null
 hwclock --systohc
 return 0
}

resume() {
 hwclock --hctosys
 /etc/rc.d/init.d/atd start 2>/dev/null >/dev/null
 return 0
}


and my time is always correct
Go to the top of the page
 
+Quote Post
Ling
post Feb 19 2007, 04:24 AM
Post #9





Group: Members
Posts: 352
Joined: 3-June 04
From: Virginia, US
Member No.: 3,563



Is this the default for pdaXii13? I assume so as I have never had a problem.
Go to the top of the page
 
+Quote Post
daniel3000
post Feb 19 2007, 06:12 AM
Post #10





Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027



QUOTE(Meanie @ Feb 19 2007, 09:27 AM)
this is what I have in /etc/apm.d/scripts/hwclock

CODE
suspend() {
 /etc/rc.d/init.d/atd stop 2>/dev/null >/dev/null
 hwclock --systohc
 return 0
}

resume() {
 hwclock --hctosys
 /etc/rc.d/init.d/atd start 2>/dev/null >/dev/null
 return 0
}


and my time is always correct
*


Interesting - does KO/PI alarm work from suspend, although atd is stopped prior to suspending?

daniel
Go to the top of the page
 
+Quote Post
tombraider
post Feb 19 2007, 09:13 AM
Post #11





Group: Members
Posts: 409
Joined: 23-November 04
From: Murphy, North Carolina USA
Member No.: 5,590



I also have this code below in hwclock. Would I leave that in or delete it? And does this fix the problem that when the Z is rebooted it goes back 3 days and 8 hours?

CODE
case "$1" in
 suspend)
     suspend
;;
 resume)
     resume
;;
 *)
    echo "Usage: $0 {suspend|resume}"
    exit 1
esac

exit $?

BTW Why doesn't the internet time checking work in the Date/Time utility when I am internet connected? I put in what I believe to be a valid ntd server? Would be nice if it worked. It DOES look so nice...it's a shame it seems to serve no function. Or do others have this feature working for them?

QUOTE(Meanie @ Feb 19 2007, 03:27 AM)
this is what I have in /etc/apm.d/scripts/hwclock

CODE
suspend() {
 /etc/rc.d/init.d/atd stop 2>/dev/null >/dev/null
 hwclock --systohc
 return 0
}

resume() {
 hwclock --hctosys
 /etc/rc.d/init.d/atd start 2>/dev/null >/dev/null
 return 0
}


and my time is always correct
*
Go to the top of the page
 
+Quote Post
zeigerpuppy
post Apr 10 2007, 03:15 AM
Post #12





Group: Members
Posts: 109
Joined: 23-December 05
Member No.: 8,778



I am having a problem with my clock on Beta 3,
it resets to Feb 28th on every suspend (very annnoying) and I noticed that there is something wrong with my hwclock:

# hwclock --systohc --debug
hwclock from util-linux-2.12j
hwclock: Open of /dev/rtc failed, error=16: Device or resource busy.
No usable clock interface found
Cannot access the Hardware Clock via any known method.

I have recently installed the kdepim2.2.7 and kopi-apm_1.1
but I think things were flakey before (I didn't try the hwclock command previously however).

Anyone know what to try next??

EDIT
sorry - found the problem, had to stop /etc/rc.d/init.d/atd first!
I guess this should be added to the above scripts
Go to the top of the page
 
+Quote Post
ToneBlind
post Jul 10 2009, 10:40 AM
Post #13





Group: Members
Posts: 82
Joined: 11-December 07
Member No.: 21,059



QUOTE(daniel3000 @ Feb 19 2007, 07:12 AM) *
QUOTE(Meanie @ Feb 19 2007, 09:27 AM)
this is what I have in /etc/apm.d/scripts/hwclock

CODE
suspend() {
 /etc/rc.d/init.d/atd stop 2>/dev/null >/dev/null
 hwclock --systohc
 return 0
}

resume() {
 hwclock --hctosys
 /etc/rc.d/init.d/atd start 2>/dev/null >/dev/null
 return 0
}


and my time is always correct
*


Interesting - does KO/PI alarm work from suspend, although atd is stopped prior to suspending?

daniel

Blast from the past, I know. I just wanted to say that the KO/PI alarm wakeup fix (kopi-apm) doesn't appear to work in pdaXii13. When I suspend and there is a pending KO/PI alarm, my Zaurus won't wake up and I need to perform a hard reset.

I verified that disabling the hwclock script allows the KO/PI alarm wakeup fix to work. Apparently the original solution for the KO/PI alarm wakeup involved apm, and not atd, but since apm didn't work properly due to some bugs, the atd solution took its place. I might work on trying to fix apm to use that as a solution. However, I'm wondering if stopping atd on suspend might affect some other things, and therefore a better solution for the conflict might be to edit hwclock and reimplement it so that atd is not stopped.

I'm not expecting an answer to this, since pdaXrom seems to be pretty much done in terms of user base and support, but I'm documenting it for the benefit of future generations. wink.gif
Go to the top of the page
 
+Quote Post
ToneBlind
post Jul 10 2009, 01:13 PM
Post #14





Group: Members
Posts: 82
Joined: 11-December 07
Member No.: 21,059



QUOTE(ToneBlind @ Jul 10 2009, 11:40 AM) *
Blast from the past, I know. I just wanted to say that the KO/PI alarm wakeup fix (kopi-apm) doesn't appear to work in pdaXii13. When I suspend and there is a pending KO/PI alarm, my Zaurus won't wake up and I need to perform a hard reset.

I verified that disabling the hwclock script allows the KO/PI alarm wakeup fix to work. Apparently the original solution for the KO/PI alarm wakeup involved apm, and not atd, but since apm didn't work properly due to some bugs, the atd solution took its place. I might work on trying to fix apm to use that as a solution. However, I'm wondering if stopping atd on suspend might affect some other things, and therefore a better solution for the conflict might be to edit hwclock and reimplement it so that atd is not stopped.

I'm not expecting an answer to this, since pdaXrom seems to be pretty much done in terms of user base and support, but I'm documenting it for the benefit of future generations. wink.gif

Obviously, atd must be stopped for hwclock to work (in Beta3 and pdaXii13 at least.) So the only way to solve this conflict and have both proper time and wakeup for KO/PI alarms is to change the kopi-apm script to actually use apm, which to my knowledge would involve fixing apm. I'll have a look.

And yes, I know I'm talking to myself here. And no, I'm not crazy (at least not because of this. smile.gif )
Go to the top of the page
 
+Quote Post
ToneBlind
post Jul 10 2009, 02:30 PM
Post #15





Group: Members
Posts: 82
Joined: 11-December 07
Member No.: 21,059



The obvious solution was to only stop atd before calling hwclock, and starting it right after. I've tested this, and now both the clock and atd (which means KO/PI alarm wakeup events) work.

CODE
suspend() {
/etc/rc.d/init.d/atd stop 2>/dev/null >/dev/null
hwclock --systohc
/etc/rc.d/init.d/atd start 2>/dev/null >/dev/null
return 0
}

resume() {
/etc/rc.d/init.d/atd stop 2>/dev/null >/dev/null
hwclock --hctosys
/etc/rc.d/init.d/atd start 2>/dev/null >/dev/null
return 0
}
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 2nd September 2014 - 03:46 PM