OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

4 Pages V  < 1 2 3 4 >  
Reply to this topicStart new topic
> Upgrading Beta1/beta3 To Pdaxii13, on all clamshell models
Meanie
post Feb 28 2007, 04:32 PM
Post #31





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(grog @ Feb 27 2007, 02:06 AM)
QUOTE(Meanie @ Feb 25 2007, 10:23 PM)
install this package on beta1 and see what happens with the SD card (of course don't install this package from a SD card directly smile.gif
*

QUOTE
so who tried it? does it work?
*

Busy with family stuff most of the weekend, so not much time. Tried it now, modules seem to be loaded

CODE
root-:) lsmod
Module                  Size  Used by    Tainted: P
sharp_mmcsd_m          25888   0  (unused)
sdmmc_linux            12680   1  (initializing)
sd_memory               4680   0  [sdmmc_linux]
sd_core                17908   0  [sdmmc_linux sd_memory]
sd_linux               11496   0  [sdmmc_linux sd_memory sd_core]
mousedev                4496   1
pxa_bi                 21388   0  (unused)
net_fd                 25000   0  (unused)
usbdcore               34456   0  [pxa_bi net_fd]
usbdmonitor             5216   0

but lots of errors from dmesg

CODE
edc
r10: c15b4000  r9 : 00034cd8  r8 : c5b00da8
r7 : 00000010  r6 : 00000000  r5 : c5b01258  r4 : 00000010
r3 : c5ac5ff8  r2 : 00000010  r1 : 0000000f  r0 : c5b01258
Flags: Nzcv  IRQs on  FIQs on  Mode SVC_32  Segment user
Control: 197F  Table: A16B4000  DAC: 00000015  PID:  0
Process insmod (pid: 707, stackpage=c15b5000)
Stack: (0xc15b5ec0 to 0xc15b6000)
5ec0: c5b00c14 c011f66c 80000013 ffffffff c15b5f04 c15b5ee0 c5b00c14 c011f654
5ee0: 00000000 c5b011b0 c5b00000 c159d000 00000060 ffffffea c15b5fa4 c15b5f08
5f00: c0044088 c5b00aa8 c159d000 c15b5f1c c159e000 0000000b c3e0cd00 00000060
5f20: c5af0000 c5b00060 00003188 00000000 00000000 00000000 00000000 00000000
5f40: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
5f60: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000005
5f80: c5b00000 00000000 00000080 c002f9e4 c15b4000 00000000 00000000 c15b5fa8
5fa0: c002f840 c0043974 00000005 c003f934 00021ad0 00034cd8 ffffffff 40016000
5fc0: 00000005 c5b00000 00000000 0002eb28 00003188 00000000 00000000 0000000b
5fe0: 400e8aa0 bfffba80 0000c938 400e8aac 60000010 00021ad0 00000000 00000000
Backtrace:
Function entered at [<c011f648>] from [<c5b00c14>]
Function entered at [<c5b00a9c>] from [<c0044088>]
r8 = FFFFFFEA  r7 = 00000060  r6 = C159D000  r5 = C5B00000
r4 = C5B011B0
Function entered at [<c0043968>] from [<c002f840>]
Code: e3530000 0a000004 e1530000 0a000008 (e5933020)
SD: RCA=0xb368
SD: SD memory is detected
Unable to handle kernel NULL pointer dereference at virtual address 00000063
pgd = c0004000
*pgd = a0002001, *pmd = a0002001, *pte = a000108f, *ppte = a000100f
Internal error: Oops: ffffffff
CPU: 0
pc : [<c003ff2c>]    lr : [<c0041240>]    Tainted: P
sp : c16bdf74  ip : c16bdf98  fp : c16bdf94
r10: c0282fe4  r9 : c5ac0bb8  r8 : 20000013
r7 : c5ac2128  r6 : 00000000  r5 : c16bc000  r4 : 00000000
r3 : 00000001  r2 : c16bc000  r1 : c16bc0e8  r0 : 00000063
Flags: nzCv  IRQs off  FIQs on  Mode SVC_32  Segment kernel
Control: 197F  Table: A35F4000  DAC: 0000001D  PID:  0
Process ttach (pid: 710, stackpage=c16bd000)
Stack: (0xc16bdf64 to 0xc16be000)
df60:          c0041240 c003ff2c 20000093 ffffffff 00000000 c16bc000 00000000
df80: c5ac2128 c2d1cb10 c16bdfa4 c16bdf98 c0041240 c003ff18 c16bdfb4 c16bdfa8
dfa0: c0045fbc c0041220 c16bdfc4 c16bdfb8 c0046264 c0045f50 c16bdff4 c16bdfc8
dfc0: c5ac023c c004624c c2d1cb50 00000000 c03c4000 c03c4000 c03c4348 c03c4338
dfe0: 00000001 c03c5fbc 00000000 c16bdff8 c0030c04 c5ac00b0 00000000 00000000
Backtrace:
Function entered at [<c003ff0c>] from [<c0041240>]
r8 = C2D1CB10  r7 = C5AC2128  r6 = 00000000  r5 = C16BC000
r4 = 00000000
Function entered at [<c0041214>] from [<c0045fbc>]
Function entered at [<c0045f44>] from [<c0046264>]
Function entered at [<c0046240>] from [<c5ac023c>]
Function entered at [<c5ac00a4>] from [<c0030c04>]
Code: e3883080 e121f003 e5903000 e2833001 (e4803004)
Unable to handle kernel paging request at virtual address ffffffff
pgd = c0004000
*pgd = 00000000, *pmd = 00000000
Internal error: Oops: 0
CPU: 0
pc : [<c004bb20>]    lr : [<c0046168>]    Tainted: P
sp : c16bde4c  ip : c16bde60  fp : c16bde5c
r10: ffffffff  r9 : ffffffff  r8 : c003ff2c
r7 : ffffffff  r6 : 0000000b  r5 : c16bc000  r4 : c16bc000
r3 : a0000093  r2 : a0000093  r1 : ffffffff  r0 : c16bc000
Flags: NzCv  IRQs off  FIQs on  Mode SVC_32  Segment kernel
Control: 197F  Table: A35F4000  DAC: 0000001D  PID:  0
Process ttach (pid: 710, stackpage=c16bd000)
Stack: (0xc16bde3c to 0xc16be000)
de20:                                                                c0046168
de40: c004bb20 a0000093 ffffffff c3c8fae0 c16bde6c c16bde60 c0046168 c004baf0
de60: c16bde88 c16bde70 c00341a8 c0045f50 00000063 c16bdf2c 00000000 c16bdea8
de80: c16bde8c c0034ee4 c00340ac c16bc000 e4803004 c16bdf2c 00000063 c16bdec0
dea0: c16bdeac c0034f98 c0034e88 ffffffff 00000004 c16bdef8 c16bdec4 c0036b60
dec0: c0034f50 c16bdf2c c3190000 00000000 00000063 c16bc000 00000024 00000003
dee0: c02111e4 c02111c0 ffffffff c16bdf28 c16bdefc c0035694 c00369c4 c16bdf2c
df00: ffffffff c16bdf60 00000000 c5ac2128 20000013 20000093 c0282fe4 c16bdf94
df20: c16bdf2c c002f480 c003562c 00000063 c16bc0e8 c16bc000 00000001 00000000
df40: c16bc000 00000000 c5ac2128 20000013 c5ac0bb8 c0282fe4 c16bdf94 c16bdf98
df60: c16bdf74 c0041240 c003ff2c 20000093 ffffffff 00000000 c16bc000 00000000
df80: c5ac2128 c2d1cb10 c16bdfa4 c16bdf98 c0041240 c003ff18 c16bdfb4 c16bdfa8
dfa0: c0045fbc c0041220 c16bdfc4 c16bdfb8 c0046264 c0045f50 c16bdff4 c16bdfc8
dfc0: c5ac023c c004624c c2d1cb50 00000000 c03c4000 c03c4000 c03c4348 c03c4338
dfe0: 00000001 c03c5fbc 00000000 c16bdff8 c0030c04 c5ac00b0 00000000 00000000
Backtrace:
Function entered at [<c004bae4>] from [<c0046168>]
r4 = C3C8FAE0
Function entered at [<c0045f44>] from [<c00341a8>]
Function entered at [<c00340a0>] from [<c0034ee4>]
r6 = 00000000  r5 = C16BDF2C  r4 = 00000063
Function entered at [<c0034e7c>] from [<c0034f98>]
r7 = 00000063  r6 = C16BDF2C  r5 = E4803004  r4 = C16BC000
Function entered at [<c0034f44>] from [<c0036b60>]
r4 = 00000004
Function entered at [<c00369b8>] from [<c0035694>]
Function entered at [<c0035620>] from [<c002f480>]
Function entered at [<c003ff0c>] from [<c0041240>]
r8 = C2D1CB10  r7 = C5AC2128  r6 = 00000000  r5 = C16BC000
r4 = 00000000
Function entered at [<c0041214>] from [<c0045fbc>]
Function entered at [<c0045f44>] from [<c0046264>]
Function entered at [<c0046240>] from [<c5ac023c>]
Function entered at [<c5ac00a4>] from [<c0030c04>]
Code: e5843334 e10f2000 e3823080 e121f003 (e5913000)
SD: bus 0 is unregistered.
Unable to handle kernel paging request at virtual address c5ac603c
pgd = c1770000
*pgd = a3f47021, *pmd = a3f47021, *pte = 00000000, *ppte = 00000000
Internal error: Oops: 0
CPU: 0
pc : [<c006b430>]    lr : [<00000000>]    Tainted: P
sp : c1851ec0  ip : a0000013  fp : c1851ee8
r10: c3a6f060  r9 : c3f1b73c  r8 : 00003c00
r7 : c1fedd20  r6 : fffffffa  r5 : 3c000000  r4 : c3f1b720
r3 : c5ac6028  r2 : c1fedd20  r1 : c3a6f060  r0 : c3f1b720
Flags: NzCv  IRQs on  FIQs on  Mode SVC_32  Segment user
Control: 197F  Table: A1770000  DAC: 00000015  PID:  0
Process mount (pid: 885, stackpage=c1851000)
Stack: (0xc1851eb0 to 0xc1852000)
1ea0:                                     00000000 c006b430 a0000013 ffffffff
1ec0: c3a6f060 c1fedd20 c1fedd20 c32d9268 c02541d4 c1850000 0001e89c c1851f00
1ee0: c1851eec c006b638 c006b3c8 c3a6f060 c32d9260 c1851f30 c1851f04 c00b2dd8
1f00: c006b610 c1851f20 c1851f14 c006ed30 c1fedd20 c3a6f060 00000000 c03be360
1f20: c3b1c6c0 c1851f54 c1851f34 c006390c c00b2d08 00020000 00020000 00000000
1f40: c3f1c000 c002f9e4 c1851f84 c1851f58 c0063804 c0063814 c3b1c6c0 c03be360
1f60: c006eab8 c005b128 c3f1c000 00000001 00000001 00000003 c1851fa4 c1851f88
1f80: c0063b60 c00637c4 bfffdff8 00020210 00000000 00000005 00000000 c1851fa8
1fa0: c002f840 c0063b28 bfffdff8 c00356f4 00020210 00020000 00000000 00006000
1fc0: bfffdff8 00020210 00000000 00020210 bffff658 bffff668 0001e89c 00020230
1fe0: 40137e7c bfff57e8 400db290 400db264 60000010 00020210 4021c26c 401ef29c
Backtrace:
Function entered at [<c006b3bc>] from [<c006b638>]
Function entered at [<c006b604>] from [<c00b2dd8>]
r5 = C32D9260  r4 = C3A6F060
Function entered at [<c00b2cfc>] from [<c006390c>]
r8 = C3B1C6C0  r7 = C03BE360  r6 = 00000000  r5 = C3A6F060
r4 = C1FEDD20
Function entered at [<c0063808>] from [<c0063804>]
r8 = C002F9E4  r7 = C3F1C000  r6 = 00000000  r5 = 00020000
r4 = 00020000
Function entered at [<c00637b8>] from [<c0063b60>]
r4 = 00000003
Function entered at [<c0063b1c>] from [<c002f840>]
r7 = 00000005  r6 = 00000000  r5 = 00020210  r4 = BFFFDFF8
Code: e5840018 e5943018 e3530000 0a000048 (e5931014)


no /dev/mmcd/disc0/part devices created, just a /dev/mmcd/disc0/disc, which fails to mount

CODE
root-:) mount /dev/mmcd/disc0/disc /mnt/card
Segmentation fault

*



that's too bad then. no big SD support in that case...
Go to the top of the page
 
+Quote Post
macwiz
post Apr 13 2007, 04:17 AM
Post #32





Group: Members
Posts: 151
Joined: 15-March 04
From: UK
Member No.: 157



Hi. I got the upgrade to pdaxii13 working on my 860 model from a clean install of beta1. I am having trouble with it not recognizing any SD card after the upgrade. Any ideas?

Also if I quit X, the cli is scrambled and rotated. I have no problem with X being rotated though.

Apart from that I am eager to see what this distro can do.

Thanks for any help...
Go to the top of the page
 
+Quote Post
macwiz
post Apr 13 2007, 08:22 AM
Post #33





Group: Members
Posts: 151
Joined: 15-March 04
From: UK
Member No.: 157



QUOTE(macwiz @ Apr 13 2007, 12:17 PM)
Hi. I got the upgrade to pdaxii13 working on my 860 model from a clean install of beta1. I am having trouble with it not recognizing any SD card after the upgrade. Any ideas?
*


Sort of solved my first query. I had tried mounting from the command line, but clearly I was doing that wrong. Then I installed rox, which took a while because of a missing library, and then from rox filer just clicking on the card icon when in the /mnt folder did the trick.

Still got the problem I had on exiting X.
Go to the top of the page
 
+Quote Post
Meanie
post Apr 14 2007, 05:34 AM
Post #34





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(macwiz @ Apr 14 2007, 02:22 AM)
QUOTE(macwiz @ Apr 13 2007, 12:17 PM)
Hi. I got the upgrade to pdaxii13 working on my 860 model from a clean install of beta1. I am having trouble with it not recognizing any SD card after the upgrade. Any ideas?
*


Sort of solved my first query. I had tried mounting from the command line, but clearly I was doing that wrong. Then I installed rox, which took a while because of a missing library, and then from rox filer just clicking on the card icon when in the /mnt folder did the trick.

Still got the problem I had on exiting X.
*



sorry, I have no idea why it is rotated, but just don't exit X smile.gif

actually, can you rotate the screen before you exit X. will the display then be correct?
Go to the top of the page
 
+Quote Post
macwiz
post Apr 15 2007, 02:44 PM
Post #35





Group: Members
Posts: 151
Joined: 15-March 04
From: UK
Member No.: 157



QUOTE(Meanie @ Apr 14 2007, 01:34 PM)
sorry, I have no idea why it is rotated, but just don't exit X smile.gif

actually, can you rotate the screen before you exit X. will the display then be correct?
*


That was fun. Simple rotation and back again works fine. Rotate the screen and quit X leads to an interlaced screen with the text repeated in 3 columns. Looks very odd/ but you can just make out the login prompt. So I relogin and startx, and it is completely confused. Not only does the cursor move independently (mirrored and rotated I think) of the stylus, but it is the wrong way round and the applet icons are stretched.

So I wont be doing that too often.

Incidentally the keymapping is not quite right. I fixed the mouse buttons with the input panel, and found a fix for the brightness and screen magnification fn buttons above 1 2 3 4. But the magnifying has similar effects to the screen with it being rotated.

I guess I'd like to fix it if it needs it so I can play games like quake... going to try it now.

I'd also like to get my old corgi keymapping back from beta1. I saved the xmodmap, but am not sure what to with it.

However, I am still thrilled to get pdaxii13 on my c860... looking forward to getting it working.

Thanks

John
Go to the top of the page
 
+Quote Post
Meanie
post Apr 15 2007, 02:50 PM
Post #36





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(macwiz @ Apr 16 2007, 08:44 AM)
QUOTE(Meanie @ Apr 14 2007, 01:34 PM)
sorry, I have no idea why it is rotated, but just don't exit X smile.gif

actually, can you rotate the screen before you exit X. will the display then be correct?
*


That was fun. Simple rotation and back again works fine. Rotate the screen and quit X leads to an interlaced screen with the text repeated in 3 columns. Looks very odd/ but you can just make out the login prompt. So I relogin and startx, and it is completely confused. Not only does the cursor move independently (mirrored and rotated I think) of the stylus, but it is the wrong way round and the applet icons are stretched.

So I wont be doing that too often.

Incidentally the keymapping is not quite right. I fixed the mouse buttons with the input panel, and found a fix for the brightness and screen magnification fn buttons above 1 2 3 4. But the magnifying has similar effects to the screen with it being rotated.

I guess I'd like to fix it if it needs it so I can play games like quake... going to try it now.

I'd also like to get my old corgi keymapping back from beta1. I saved the xmodmap, but am not sure what to with it.

However, I am still thrilled to get pdaxii13 on my c860... looking forward to getting it working.

Thanks

John
*



since i dont have a c8x0, i never touched the keymap file. if you have a better working one, send it my way and i will include it in pdaXii13...

in fact, send any useful modifications my way for inclusion...
Go to the top of the page
 
+Quote Post
macwiz
post Apr 15 2007, 03:30 PM
Post #37





Group: Members
Posts: 151
Joined: 15-March 04
From: UK
Member No.: 157



QUOTE(Meanie @ Apr 15 2007, 10:50 PM)
in fact, send any useful modifications my way for inclusion...
*

Sure... if I get anything useful done I will send config files for you to ponder.

Quake started tiny and rotated. Returning to desktop and all screwed. Reboot fixes tho.
Go to the top of the page
 
+Quote Post
macwiz
post Apr 15 2007, 04:44 PM
Post #38





Group: Members
Posts: 151
Joined: 15-March 04
From: UK
Member No.: 157



If I run xrandr in aterm it returns:

0 640x480
1 480x640
2 240x320

I guess that last line should be 320x240. Where does xrandr pick up these values from and can I change the last one?
Go to the top of the page
 
+Quote Post
Meanie
post Apr 15 2007, 04:55 PM
Post #39





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(macwiz @ Apr 16 2007, 10:44 AM)
If I run xrandr in aterm it returns:

0 640x480
1 480x640
2 240x320

I guess that last line should be 320x240. Where does xrandr pick up these values from and can I change the last one?
*


try editing /usr/X11R6/bin/startx

and add the following value for RES

-screen 240x320@270

or

-screen 640x480@270

make sure you add it to the section for SL-C860, there is a similar entry for SL-C1000....
Go to the top of the page
 
+Quote Post
macwiz
post Apr 16 2007, 01:10 AM
Post #40





Group: Members
Posts: 151
Joined: 15-March 04
From: UK
Member No.: 157



QUOTE(Meanie @ Apr 16 2007, 12:55 AM)
QUOTE(macwiz @ Apr 16 2007, 10:44 AM)
If I run xrandr in aterm it returns:

0 640x480
1 480x640
2 240x320

I guess that last line should be 320x240. Where does xrandr pick up these values from and can I change the last one?
*


try editing /usr/X11R6/bin/startx

and add the following value for RES

-screen 240x320@270

or

-screen 640x480@270

make sure you add it to the section for SL-C860, there is a similar entry for SL-C1000....
*


I have actually got Quake running full screen. I'll have to write a little script to automate it.

CODE
xrandr -s 240x320
xrandr -o 3
/usr/apps/Games/Quake/AppRun


I didn't find editing startx made any difference.

When I quit Quake it returns to full res landscape screen the right way up. But unfortunately the cursor isn't where I press the stylus, so I press the menu button, then arrow keys to aterm and type reboot to reset the Z.

It's not that I am desperate to run quake, I just want to know that if I come across apps/games that want the lower resolution screen I can get around the problem.

If you ave any other suggestions for startx I am game.

Thanks

John
Go to the top of the page
 
+Quote Post
grog
post Jul 5 2007, 11:10 AM
Post #41





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



QUOTE(macwiz @ Apr 13 2007, 06:17 AM)
Hi. I got the upgrade to pdaxii13 working on my 860 model from a clean install of beta1. I am having trouble with it not recognizing any SD card after the upgrade. Any ideas?

Also if I quit X, the cli is scrambled and rotated. I have no problem with X being rotated though.
*

QUOTE(macwiz @ Apr 13 2007, 10:22 AM)
Sort of solved my first query. I had tried mounting from the command line, but clearly I was doing that wrong. Then I installed rox, which took a while because of a missing library, and then from rox filer just clicking on the card icon when in the /mnt folder did the trick.
*

Hi macwiz. I've just applied the pdaxii13 upgrade to my beta2 install, and I'm experiencing the same two problems as you. Cards won't mount (neither sd nor cf) and I get the funky sideways screen when I quit X. I know you said the former problem was solved by installing rox, but any idea of what the 'behind the scenes' issue was? According to my earlier findings, pdax1113's updated modules weren't compatible with the C860's kernel, but see below.

And did you ever get the screen rotation fixed? thks

QUOTE(Meanie @ Feb 28 2007, 06:32 PM)
[regarding failed tests of the 2.4.18 sd module]
that's too bad then. no big SD support in that case...
*

Hi again, Meanie. I've tried grappling with pdaxii13 again & I stumbled on something interesting. Previously my testing was from a beta1 base install. This time I tried it from my last beta2 working image (which was the last beta that really worked well on the C860). It was with my flipping back & forth that I noticed that the two use different kernels! ohmy.gif

beta1:
CODE
# uname -a
Linux zaurus 2.4.18-rmk7-pxa3-embedix #1 Mon, 14 Nov 2005 20:35:45 +0000 armv5tel unknown

beta2:
CODE
root@zaurus# uname -a
Linux zaurus 2.4.20 #1 Tue, 07 Mar 2006 01:09:26 +0000 armv5tel unknown

Does this mean that there might be hope for me yet? i.e. is there another module for the 2.4.20 kernel I can try?
Go to the top of the page
 
+Quote Post
HoloVector
post Jul 5 2007, 06:33 PM
Post #42





Group: Members
Posts: 474
Joined: 22-March 06
From: Winnipeg, Canada
Member No.: 9,420



QUOTE(grog @ Jul 5 2007, 01:10 PM)
....

beta1:
CODE
# uname -a
Linux zaurus 2.4.18-rmk7-pxa3-embedix #1 Mon, 14 Nov 2005 20:35:45 +0000 armv5tel unknown

beta2:
CODE
root@zaurus# uname -a
Linux zaurus 2.4.20 #1 Tue, 07 Mar 2006 01:09:26 +0000 armv5tel unknown

Does this mean that there might be hope for me yet? i.e. is there another module for the 2.4.20 kernel I can try?
*

blink.gif

sashz ported the 2.4.20 kernel to the c7x0 series!? Is this uname from before or after doing a pdaXii13 patching? If it really is running 2.4.20 then maybe the enhanced SD driver from the 3200 will work.
Go to the top of the page
 
+Quote Post
grog
post Jul 6 2007, 06:01 AM
Post #43





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



QUOTE(HoloVector @ Jul 5 2007, 08:33 PM)
sashz ported the 2.4.20 kernel to the c7x0 series!?  Is this uname from before or after doing a pdaXii13 patching?  If it really is running 2.4.20 then maybe the enhanced SD driver from the 3200 will work.
*

I'm pretty sure both of these were pre-upgrade, but I'll reflash & double check. And if by the 3200 sd driver you mean the one included in the pdaxii13 upgrade tarball, then no, it seems to cause problems. I'll double check that too & report back.
Go to the top of the page
 
+Quote Post
HoloVector
post Jul 6 2007, 06:32 AM
Post #44





Group: Members
Posts: 474
Joined: 22-March 06
From: Winnipeg, Canada
Member No.: 9,420



QUOTE(grog @ Jul 6 2007, 08:01 AM)
QUOTE(HoloVector @ Jul 5 2007, 08:33 PM)
sashz ported the 2.4.20 kernel to the c7x0 series!?  Is this uname from before or after doing a pdaXii13 patching?  If it really is running 2.4.20 then maybe the enhanced SD driver from the 3200 will work.
*

I'm pretty sure both of these were pre-upgrade, but I'll reflash & double check. And if by the 3200 sd driver you mean the one included in the pdaxii13 upgrade tarball, then no, it seems to cause problems. I'll double check that too & report back.
*


Well that is potentially good and bad news. Yes, I was referring to the one included in the tarball. Meanie repackaged the 3200 enhanced sd driver that shipped with the SharpROM so that it could be used under pdaX. I'm surprised that it didn't work. I hope it isn't due to hardware differences between the xx0 and xx00.
Go to the top of the page
 
+Quote Post
grog
post Jul 6 2007, 08:32 AM
Post #45





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



QUOTE(grog @ Jul 6 2007, 08:01 AM)
I'm pretty sure both of these were pre-upgrade, but I'll reflash & double check.

Confirmed. pre-upgrade beta1 = 2.4.18, beta2 (& presumably beta3) = 2.4.20. Which is what I expected, since AFAIK pdaxii13 doesn't touch the kernel itself.

QUOTE
And if by the 3200 sd driver you mean the one included in the pdaxii13 upgrade tarball, then no, it seems to cause problems. I'll double check that too & report back.
*
QUOTE(HoloVector @ Jul 6 2007, 08:32 AM)
Well that is potentially good and bad news.  Yes, I was referring to the one included in the tarball.  Meanie repackaged the 3200 enhanced sd driver that shipped with the SharpROM so that it could be used under pdaX.  I'm surprised that it didn't work.  I hope it isn't due to hardware differences between the xx0 and xx00.
*

No good news I'm afraid. After upgrade & reboot, NO cards are mounting properly, sd or cf. Using a 1GB sd & a 512MB cf for testing. Neither /dev/mm* nor /dev/hd* exist. Lots of errors from dmesg, most notably for sd:

CODE
pxa_sd_wait_id_response: responce time out (cmd=01 MMC_STAT=0x2142)

and for hd:

CODE
hda: LEXAR ATA FLASH, ATA DISK drive
hda: ERROR, PORTS ALREADY IN USE


And now one of the best things from beta2 (over beta1) is gone; the fn-brigthness & fn-zoom keys are broken (sigh).

The main reason I was trying to get pdaxii13 working is that I'm wanting to try other rom's, but there currently isn't an easy restore back to R197/8 like the NAND utilities provide. I also tried Angstrom again, but no joy there yet (yes, I did send a help message to the mailing list). From this state, I'm willing/forced to play around a bit smile.gif.
Go to the top of the page
 
+Quote Post

4 Pages V  < 1 2 3 4 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 29th December 2014 - 07:26 AM