OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Problem With Ranlib--solved
post Mar 11 2007, 01:35 AM
Post #1

Group: Members
Posts: 217
Joined: 12-February 06
From: Tokyo
Member No.: 9,124

Dear all, I'd like a bit of help with cross-compiling. It seems I'm the right tracks this time.
I have the cross-compiler and qtopia sdk working, and compiled SDL. I was now going or sdl_mixer when problems emerged:

- SDL_mixer configures and compiles fine, but when going for "make install", it fails with
arm-linux-ranlib /opt/Embedix/tools/arm-linux/lib/libSDL_mixer.a
eval: 1: arm-linux-ranlib: not found

And indeed with I try to run arm-linux-ranlib by hand:
$ sudo arm-linux-ranlib /opt/Embedix/tools/arm-linux/lib/libSDL_mixer.a sudo: arm-linux-ranlib: command not found

But the arm-linux-ranlib binary exists. Could you help me identify the problem?


--Solved-- setting the full path to RANLIB=/opt/Embedix/tools/bin/arm-linux-ranlib solved the problem
Go to the top of the page
+Quote Post

Posts in this topic
matthis   Problem With Ranlib--solved   Mar 11 2007, 01:35 AM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 23rd June 2018 - 02:28 AM