OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Qtopia 4.x On Stock Zaurus, possible?
johnny_a
post May 8 2007, 08:02 AM
Post #1





Group: Members
Posts: 19
Joined: 8-August 06
Member No.: 10,692



Is it possible - or what needs to be done to make it possible - to install Qtopia 4 libs (or statically linking them) on a stock Qtopia 2 Zaurus, and run Qtopia 4 apps?
Go to the top of the page
 
+Quote Post
speculatrix
post May 9 2007, 01:27 PM
Post #2





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(johnny_a @ May 8 2007, 05:02 PM)
Is it possible - or what needs to be done to make it possible - to install Qtopia 4 libs (or statically linking them) on a stock Qtopia 2 Zaurus, and run Qtopia 4 apps?
*


a stock zaurus runs qtopia 1.5

there are some ROMs on qtopia.net running qtopia2,
http://www.qtopia.net/modules/mydownloads/viewcat.php?cid=6
none of these run kernel 2.6 as far as I know so you'd get no performance boost, and as far as I know you'd lose backwards compatibility to run all the Sharp proprietary apps.

this has been discussed here... the thing is, if you want the cutting edge, try OZ or Angstrom and Opie2 (fork of qtopia4), if you want traditional apps and max compatibility try Cacko, and if you want maximum apps then pdaXrom. That's a bit oversimplifying I think.
Go to the top of the page
 
+Quote Post
johnny_a
post May 10 2007, 02:38 AM
Post #3





Group: Members
Posts: 19
Joined: 8-August 06
Member No.: 10,692



Thanks for the reply!

I confused Qt and Qtopia versions, sorry about that. I am currently converting my Qt 2 application to Qt 4, and I'm investigating if there's any chance that it'll be usable on old Zauruses without custom ROM. I suppose chances are pretty bleak. sad.gif
Go to the top of the page
 
+Quote Post
speculatrix
post May 10 2007, 02:46 AM
Post #4





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(johnny_a @ May 10 2007, 11:38 AM)
Thanks for the reply!

I confused Qt and Qtopia versions, sorry about that. I am currently converting my Qt 2 application to Qt 4, and I'm investigating if there's any chance that it'll be usable on old Zauruses without custom ROM. I suppose chances are pretty bleak. sad.gif
*


ah, well, you could probably take a sharp/cacko ROM and add the qt4 libraries alongside, keeping the old ones for compatibility.

I did try this with qt3-embedded and it worked (albeit slowly 'cos qt3 was pretty bloated).

I would like to see this work. Actually, I'd like to see a sharp-based ROM which had full backwards compatibility, the qt2/qtopia2 libraries (for running certain binaries extracted from Sony Mylo wink.gif and qt4 to keep it up to date.

Really, this sort of thing should have been done by Sharp, but the fact they haven't even produced a kernel 2.6 release for zaurus speaks volumes about their interest in customer care!

I've been wondering whether someone's going to try and port maemo/hildon to the zaurus, and qt(opia)4 (or opie2) to the N800 and try and establish a more common platform, hopefully the angstrom dudes will achieve their goals in that matter.
Go to the top of the page
 
+Quote Post
speculatrix
post May 10 2007, 08:08 AM
Post #5





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



I'm now trying out OpenZaurus 3541, and I wonder if there's a qtopia4 package to install on it - opie2 seems some way off and probably won't make it onto the Zaurus except maybe in angstrom.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th July 2014 - 01:05 AM