OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Only Able To Access D+m Menu, Solved. See inside for details.
Daedelus
post May 14 2007, 05:03 PM
Post #1





Group: Members
Posts: 8
Joined: 11-October 05
From: BC, Canada
Member No.: 8,294



Something odd happened to my 3000 this weekend, I'll explain below, but here's where I sit now. My 3000 will boot to the DIAG menu with the DM keys using either the battery, or the power cable and seems to work fine there. This leads me to believe that my Z is recoverable. I don't know what I should do to get it back up however, Should I try doing a NAND restore, and if so is there a step by step guide so I don't muck it up further and completely brick it.

For whatever reason It will not power on other then the diag menu. Currently attempting to power it on will cause the green HDD light to come on faintly with just the battery, and a little brighter with the power, but not quite the intensity of normal HDD activity. This is after I ran a HDD and NAND test from the DIAG menu. Before that the Power light would com on when the on/off button was pressed as long as there was external power. Prior to that, I had attempted to run an fsck from battery through the OK+on/off menu, when I was receiving an error message about hda3 on boot. It complained something in Japanese, and then restarted to the same error message.

Currently It's sitting on my desk with no battery or power cable attached I'd really like to get it working again, and I don't really care too much about the data stored in there, It would be nice to recover it, but non essential.

Thanks in advance for your replies smile.gif

--Daedelus
Go to the top of the page
 
+Quote Post
speculatrix
post May 15 2007, 12:37 AM
Post #2





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



this happened to me not long ago; I was able to do a NAND restore (from a 256MB cf card formatted as fat16) using the D+M menu.

I was very relieved when I power cycled it and it worked again!
Go to the top of the page
 
+Quote Post
Daedelus
post May 15 2007, 04:41 PM
Post #3





Group: Members
Posts: 8
Joined: 11-October 05
From: BC, Canada
Member No.: 8,294



Well yes, a NAND restore seemed to fix the issues. and I can finnally breathe again smile.gif

For those who might be interested,I followed the instructions located at Zaurus SL-C3000 - Stüvel.eu for the NAND restore on the 3000 Here's a C&P from the site.
QUOTE
Restoring a known-good NAND
If you have been messing up your Zaurus, you might need to restore a known-good NAND. It contains the basic software that gets the machine going.

   1. Download SYSTC300.DBK.gz and gunzip it.
   2. Place the file SYSTC300.DBK in the root directory of a CF/SD card.
   3. Insert the card into the Zaurus.
   4. Power down the Zaurus, remove the battery and adapter plug so that it is completely without power.
   5. Switch the battery lid lock back into the closed position, but keep the lid itself and the battery removed from the Zaurus.
   6. Press and hold the D and M buttons on the keyboard.
   7. Insert the battery and adapter, ensuring the orange battery charge light is lit.
   8. The maintenance menu will display. You can release the D and M keys.
   9. Rotate the Zaurus so the menu options are under each other and the text is in the regular orientation. Rotate the entire Zaurus, not just the screen.
  10. Press Left to go to page 3.
  11. Press OK.
  12. Press Down two times.
  13. Press OK three times.
  14. If everything is okay, you'll see a green progress bar. When it's done reset the Zaurus, replace the battery lid, and boot.

This however brought me back to the blinking battery light problem, which has been solved previously on this forum (c750 won't boot, diag menu only) and did this:
QUOTE
Remove battery and AC power and make sure battery switch is "open"
Insert battery, hold down D+B and close battery switch and press power.
This should boot Zaurus from Backup ROM
When booted, log in as root and do a shutdown -r now


I'm now running at full speed once more smile.gif

EDIT: Pttph, Looks like I spoke too soon, I'm having battery issues as well as suspend/resume issues now. I'm going to copy the data that I wanted off tonight, then try flashing up to the latest pdaXrom or derivitive. then look into getting a new battery if thats not the quick fix that I'm looking for.

Edit2: The flash to PdaXii13 fixed it, and I'm liking it much more then I did cacko. If you read this meanie, thanks for putting that release together, as it is excellent.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 03:13 PM