OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Is Your Z "dead" After Trying To Install Pdaxrom?, Dead as in software-wise, NOT hardware
post Jun 14 2007, 03:47 PM
Post #1

Group: Members
Posts: 2,342
Joined: 30-July 06
Member No.: 10,575

Issue: Installing uBoot fails (got flashing lights). Charge light doesn't come on.

Solution: The three Rs: Reformat the card (FAT16, under Linux, mkfs.vfat -F 16 /dev/CARDDEVICE), redownload the uBoot files, and retry the process.

Issue: pdaXrom won't find the install files when trying to install the ROM.

Solution: Boot into the emergency system and check to see that the card is mounted (type 'df' to see. If /dev/hdx1 or /dev/mmcblk0p1 is listed, it's mounted). Then, cd to the directory with the install files, for CF installs:

cd /mnt/cf

For SD:

cd /mnt/card

Then execute this:

sh autoboot.sh ./

The install should run fine.

Issue: My Z won't boot after trying to install pdaXrom. I want to go back to ROM xyz.

Solution: Do a NAND restore. Download the correct file from here (select your Z model on the right):


and put the SYSTCXXX.DBK file on an SD/CF card (FAT16 formatted). remove all power from the Z (battery and AC), then hold Fn+D+M and insert the adapter. YOu should get a diagnostics menu. Go to the third page and select NAND restore. Note that you should only have one card (either SD or CF in the Z at this point).

If it doesn't see the file, 1, make sure the name is in all caps, and 2, see below.

You can then install ROM xyz normally.

Issue: After formatting a card, I can't get a NAND restore/other FAT16-sensitive action to work.

Solution: Make sure the system ID is set correctly. fdisk your card:

for SD:

fdisk /dev/SDDEVICE

for CF:

fdisk /dev/CFDEVICE

Then set the partition's ID to 6 by typing 't' for type, then the patition's number (1), then '6' for FAT16. Reformat your card:

mkfs.vfat -F 16 /dev/CARDDEVICE

then put the necessary files on the card and retry the action.

Issue: My card isn't found when trying to do a NAND restore or I get the "SYSxxx.DBK: file not exist" error when I try to restore my Z.

Solution: Make sure you have the DBK file on the root of the card, and that the card is FAT16-formatted and the System ID is set correctly (see above). For SD, make sure there isn't a CF card in the CF slot as well.

I feel like I'm missing other common issues, if so, please post them.

If this thread could be stickied, that would be great. smile.gif
Go to the top of the page
+Quote Post
Start new topic
post Dec 1 2007, 01:59 PM
Post #2

Group: Members
Posts: 1,998
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882

To boot into the uboot emergency mode, you need to press [OK] when booting starts.

But to install debian, I recommend having the whole rootfs ready before installing uboot and the kernel, because uboot cannot handle ext3 and will freeze when accessing the internal drive or CF.
Go to the top of the page
+Quote Post

Posts in this topic
Capn_Fish   Is Your Z "dead" After Trying To Install Pdaxrom?   Jun 14 2007, 03:47 PM
ghostshadow   Question : If it's dead, how do you get it t...   Jun 15 2007, 11:25 AM
Capn_Fish   What did you do/try to do? EDIT: This only covers...   Jun 15 2007, 11:44 AM
ghostshadow   Phew Awesome! it worked, A mod can delete my p...   Jun 15 2007, 02:15 PM
pelrun   If you format the card device instead of the parti...   Jun 15 2007, 05:12 PM
Capn_Fish   Thanks for pointing that out. I was under the impr...   Jun 15 2007, 06:00 PM
gromituk   Thank you very much for this thread - I thought I...   Jun 16 2007, 06:23 AM
dominate   I'm confused... I tried to install u-boot... n...   Jun 20 2007, 06:27 AM
Capn_Fish   QUOTE(dominate @ Jun 20 2007, 09:27 AM)I...   Jun 20 2007, 07:23 AM
dominate   QUOTE(Capn_Fish @ Jun 20 2007, 09:23 AM)QUOTE...   Jun 20 2007, 07:57 AM
nauj27   QUOTE(Capn_Fish @ Jun 20 2007 @ 09:23 AM)You...   Aug 9 2007, 10:30 PM
adf   I tried to install U-Boot. It seemed to work- I go...   Dec 1 2007, 01:54 PM
ZDevil   To boot into the uboot emergency mode, you need to...   Dec 1 2007, 01:59 PM
adf   QUOTE(ZDevil @ Dec 1 2007, 12:59 PM) To b...   Dec 1 2007, 02:36 PM
adf   QUOTE(adf @ Dec 1 2007, 01:36 PM) QUOTE(Z...   Dec 1 2007, 02:40 PM
ZDevil   QUOTE(adf @ Dec 1 2007, 11:40 PM) QUOTE(a...   Dec 1 2007, 04:00 PM
gmad   This is better place to my ask, so I ask again.......   Dec 3 2007, 01:39 PM
Capn_Fish   Try doing a NAND restore without the NAND erase, i...   Dec 3 2007, 02:42 PM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 17th June 2018 - 11:34 PM